PSA: How to get collabora working on nextcloud 23!

The developers of nextcloud 23 decided to release a non-working richdocuments app (v5.0.0). No idea why. The richdocuments developer was aware of this problem before the official release of 23. Plenty of time to pull the app and prevent this.

To fix collabora (on a fresh install):

Download nextcloud 23;

unzip;

go into /var/www/nextcloud/apps/

download https://github.com/nextcloud/richdocuments/releases/download/v4.1.2/richdocuments.tar.gz

tar xf richdocuments tar.gz

chown -R www-data:www-data richdocuments

Install nextcloud

Go into the apps section

allow untested/enable richdocuments and collabora CODE server (DO NOT UPGRADE RICHDOCUMENTS TO 5.0.0)

You now have a working collabora setup.

7 Likes

Is there an issue at GitHub for the problem you mention in your topic?

Yes, it’s here:

1 Like

I can confirm it also works on an updated version of nextcloud. Thanks for the info!

1 Like

Doesn’t work for me. I installed 4.1.2 as instructed and chose “Use the built-in CODE” in the Settings page but it just says “Could not establish connection to the Collabora Online server.”

  • nc23 on raspi4
  • download link
  • the directory appinfo not change

running well

meinolf

When I follow the steps my Nextcloud instance refuses to allow me to use the old version and always presents this:

image

There doesn’t seem to be a way to skip it and keep the older version.

1 Like

sure
have the same problem in first

do the dir ritchdocuments/appinfo unchanged for the version 5
the rest of the directorys change with the link
then nextcloud will not update the app

1 Like

grafik

1 Like

I can confirm Paradox551install steps worked for me on Ubuntu 20.04 VPS. I did note that when I first opened a document it took minutes for the full interface to load. The side bar appeared straight away but the document took way longer. This resolved after about 5 minutes.

I also found the same problem that “tanc” had so you have to do a clean install and the steps from Paradox551.

The slow loading is still a problem. The side panel loads straight away but the document takes around a minute. I get this SSL error from Open Lite Speed server which looks like a mixed SSL error on the in built proxy so I am starting to think a separate docker instance of Collabora is the only way to go.

2021-12-05 15:17:32.689267 [NOTICE] [1994] [my.ip:53283-Q:7C75C20FA8760739-3936#my.domain] [STDERR] richdocumentscode (proxy.php) error exit, PID: xxxx, Message: No content in reply from coolwsd. Is SSL enabled in error ?

Thank you so much ! I was struggling for several days, searching everywhere (proxy, firewall…) and it ended up that was just the app that didn’t work…
Debian 11 - MariaDB - PHP 7.4 - Apache2 - NextCloud 23 fresh install

I had the same issue on an already installed Nextcloud instance in a VM which I upgraded to 23.

The solution I found was to Disable then Remove the Collabora app from the web interface first.

After I did this, I followed the following steps:

download https://github.com/nextcloud/richdocuments/releases/download/v4.1.2/richdocuments.tar.gz

tar xf richdocuments tar.gz

chown -R www-data:www-data richdocuments

mv richdocuments /var/www/nextcloud/apps/

Reload the web interface.

Go into the apps section and allow untested then enable Collabora Online. Make sure you DO NOT UPGRADE Collabora Online to 5.0.0.

3 Likes

Installing richdocument 4.1.2 is a really good workaround! Thank you.

I also run into problems caused by a change in the configuration of apache2.
I use the last collabora docker version.
pls see https://collabora-online-for-nextcloud.readthedocs.io/en/latest/install/
“lool” was replaced by “cool”

Collabora Docker works with Nextcloud 23.0.0.

1 Like

Following your instructions the app overview still shows richdocuments as version 5.0

Trying to enable it leads to the error:
image

Any ideas to bypass that?

This looks like an rights issues.

In my case, all nextcloud files are owned by UID www-data and GID www-data. You should check if the same applies in your case or not. If it’s a different user, change the UID and GID in the command below. Make sure the path to richdocuments is correct because the path from the command below is related to my installation.

chown -R [UID]:[GID] /var/www/nextcloud/apps/richdocuments

Thank you.
I can assure you that i’ve taken care of that. :slight_smile:
I have a CentOS where nextcloud is located under /var/www/html/nextcloud and the user:group is apache:apache.
There was indeed a rights issue but it was concerning selinux, which i’ve fixed too.
In the end the NC-Log still complains about the appinfo/info.xml saying: “filemtime(): stat failed for …”

Unfortunately I’m not so experienced to help with your situation.

I hope you can find a fix.