PSA: How to get collabora working on nextcloud 23!

Updated V23

App Settings are green light and say connected to Collabora Server. The “+” add-file menu has the Collabora Filetypes, let’s me pick a template and create the file.

But then it fails to open.

When clicking on .odt’s it goes to download.


Thank you for the tutorial.
But it is the shame on Nextcloud programmers that a NEW version of Nextcloud is not fully functional after a fresh installation and there is needed a fix like this!

1 Like

I have a similar experience.
I installed NC 23 as docker yesterday.
I am not able to create online any of .odt or .ods documents because there is a template issue.

It’s working! Thank you.

Does somebody was able to run collabora on a pi with arm64 (not VM) ?
I tried both solution:

  • automated install
  • manual install as mentionned by @SitramSoft

For both I have got the same result. Nextcloud is not accessible, it is loading continuously without result.

You need to remove manually richdocuments and richdocumentsserver through the OCC command line.

Setup: PI4_8GB - bullseye_64 - nginx - php8.0 - MariaDb - NC23_native

Thank you so much.

These kinda bugs really undermine my trust in NextCloud tough (and SAAS kinda developement). Been at it for days (and hours) to get this fixed.

It works on Raspberry pi 4. With Apache2, php8, Mariadb 10.6. Manuell installation.
Nextcloud 23 with Collabora 4.2.3 instead 5.0
So it works fine

There is now an updated Connector “Collabora Online 5.0.1” and its working now.
So please make the Update in your App List and Collabora is running again.

1 Like

I updated to 5.0.1 and it is not working here.
If I try to open a document, I’ m asked to download and open it in a local program.
I checked all the settings, but they look okay to me.
“Collabora server is online reachable”
Is this only in my configuration?

If I go back to 4.1.2 it is working well.

Okay: I completely removed the collabora code server and collabora online.
Then reinstalled them both. This time 5.0.1.
And now it is indeed working!

@NetSecond Thanks for the information. I’m new to NextCloud and am running a NextCloud Appliance. I go to the App List and only see version 4.2.3 and no ‘update’ button. I also did a search and didn’t find a 5.0.1 version. Any information would be helpful - Thanks again!

Hello @MsideMnstr,

welcome to the community of Nextcloud.
Is your Appliance already using NC v23? Otherwise there is no need to update your office package.

@rakekniven Thanks for the quick response! I ran ‘snap model’ when I SSHed into my nextcloud appliance and got back the following:
model Nextcloud core18 Appliance (amd64) (nextcloud-core18-amd64)

Does this mean I’m running v18 rather than v23? I used this to create my nextcloud appliance ( From what I understand this uses SNAP to manage updates and the like.

Thank you for your help!

I am not really familar with snap.

Please open https://<your nc domain>/status.php in your browser and report.

You can only install 5.x version, if you have Nextcloud 23.0.0 running …

Thats normal, you only have to change the server to own server and then back to build in server.
Then it is changing from download to open in Collabora Online internal server.

@rakekniven @NetSecond Thank you both for your help (and speedy replies). Here’s what I found when I opened https://<your nc domain>/status.php in my browser.

Looks like v22?

Screen Shot 2021-12-22 at 11.11.22 AM

I’m at my wit’s end with this new “Nextcloud Office” experience. richdocuments 5.0.0 wasn’t working, so downgraded as suggested. Now I see there’s a 5.0.1 but after installing that and downloading and enabling whatever version of CODE was available (can’t check) I’m now borked again. Internal Server Error…


Yes, this is very stable release of v22 series. If I would be you I would not touch it and keep it running.

1 Like

Thank you for the information! You’ve been very helpful. From what I’ve read today, since my nextcloud appliance uses SNAP I will need to wait until the first ‘dot’ (23.#) update to become stable in order to update to v23. After that, I should be able to update Collabora. Right now Collabora isn’t working properly but sounds like that’s been fixed for v23. Does all that sound correct? Thanks again and have a wonderful Holiday Season!


Same to you.