PSA: How to get collabora working on nextcloud 23!

Having the same problems as mentioned above. When i follow these instructions, once I enable Collabora my app just hangs and ends up resulting in a 504:

504 Gateway Time-out

nginx/1.18.0 (Ubuntu)

Sigh…thoughts? Wait for Collabora 5.0.2?

Thanks!

1 Like

What do you mean by ‘completely removed’? Did you do anything other than disable and remove?

1 Like

like @nightcobe I would be really interested in getting a bit more specifics. I tried removing the apps completely quite some times, including an additional everytime anyone (NC/Collabora/Collaboraserver) gets an update but no luck.

I am also asking for specifics. I am not getting it to work. I really want Collabora to work. I am now using OnlyOffice but it has its limitations and I like Collabora better.

/Martin

1 Like

I just updated to NC 23.0.1 and it is still not working with Collabora Online v5.0.1.
When I try to open a document it just loads forever and nothing happens.
Had the hope that this version might fix the problem. Anyone else having success?

1 Like

I updated first from nc 22 to now Nextcloud Hub II (23.0.4) and pulled latest version of the docker-image.
Settings say: Collabora Server ist online (green)
Now I get “Document loading fails”
Would be nice to get a guide
Thanx

Collabora Online have made a small change to the environments tags.

Domain has replaced with aliasgroup1 & aliasgroup2, so if you have domain in your docker setup the server will not start.

21.11.2.4.1 and before versions:

domain=<your-dot-escaped-domain>

21.11.3.6 and after versions:

aliasgroup1=https://<domain1>:443,https://<your-dot-escaped-aliasname1>|<your-dot-escaped-aliasname2>:443

Unfortunately i have no idea on how this should be setup and the official documentation is a bit unclear.

This is how i think it sould look, though I have been unable to get my setup working. It would be interesting to see if i have made a mistake.

Docker Compose
collabora:
    image: collabora/code
    #container_name: collabora
    restart: always
    command: /start-collabora-online.sh
    environment:
      - password=!!PASSWORD!!
      - username=!!USER!!
      - aliasgroup1=https://office.domain.co.uk:443,https://nextcloud.domain.co.uk:443
      - aliasgroup2=https://nextcloud.domain.co.uk:443,https://office.domain.co.uk:443
      - extra_params=--o:ssl.enable=false --o:ssl.termination=true

Source: https://sdk.collaboraonline.com/docs/installation/CODE_Docker_image.html

take a look here

It’s still broken in the release of 24.0.3. I no longer have the time or desire to tinker with previous releases and find out which one works. Does anyone have a guide for getting the built-in office working?