Document is not opening for editing in browser forces me to download document instead

Hi, this is my first time posting after having looked into several other threads.

After updating to Nextcloud 23 and enabling the Collabora built-in server it worked perfectly and I am able to edit documents within nextcloud, on my laptops, mobile, tablet perfect. But today I tried editing a document on my PC on the nextcloud and it was asking me to download the document it was not loading the document online. I tried doing the same thing on my laptop and it put in directly into the document to start editing did not ask me to download the document. The only difference is that my laptop is running windows 10 and my pc windows 11. I really don’t think it’s something on my nextcloud server.

I looked at this thread PSA: How to get collabora working on nextcloud 23! but the richdocuments app is updated to the latest version and it’s strange that it’s not working on 1 machine but 4 other devices are opening documents without any problem.

I am not sure if someone else is facing the same issue. Any help how to investigate this further or any possible solutions would be appreciated. Thank you

I agree with you conclusion - the problem must be on the client side of win 11 system. try incognito/private tab, try another browser. If it doesn’t help ask Collabora community - maybe they have more ideas…

I’m having the same issue. And your solution - use an incognito/private tabe - worked. Why would that matter?

I tried incognito and 2 other browser same result. I did not know collabor had their community thanks for pointing me to the right community

Thats not the solution but if it worked in incognito it would mean its some setting in your normal browsing settings. If this solely occuring on windows 11 I am suspecting this is something more to do windows intentionally making life hard for open source software. I will be asking the collabora community to see gow yo investigate this further and get to the root cause

Same browser working in incognito mode means the problem is browser cache or cookies. It should start working once you clean local storage of your browser and start fresh session…

Ok so today I tried again and magically the file opened. The only thing that I can say is that windows 11 updated so that might have been the issue

1 Like