NextCloud Office (richdocuments) 5.0.2 freezes/hangs apache


Ubuntu: 20.04
Nextcloud: 23.0.2
PHP: 8.0.16
MySQL: 8.0.28
4c (8t) with 64GB ECC and SSD storage (both main drive and nextcloud storage)

I installed Collabora Online - Built-in CODE Server (richdocumentscode 21.11.103) without issue. I can’t confirm if it is working though without installing the sister application: NextCloud Office. Before doing that, the server functions more or less the same after installing richdocumentscode 21.11.103. Maybe a tad slower, but who knows.

Upon installing NextCloud Office (richdocuments 5.0.2) the webserver (apache2) becomes immediately unresponsive. OCC commands take minutes to complete. The web interfaces fails to load. Htop, iotop, and bmon show… not a whole lot going on, and the rest of the system is fast and responsive. Looking in the apache error logs is no help either, nothing in there of note.

root@nextcloud:/var/www/nextcloud# sudo -u www-data php -d memory_limit=512M ./occ app:install richdocuments
richdocuments 5.0.2 installed
richdocuments enabled
root@nextcloud:/var/www/nextcloud# sudo -u www-data php -d memory_limit=512M ./occ app:remove richdocuments
richdocuments disabled
richdocuments 5.0.2 removed

If I disable (or uninstall) richdocuments 5.0.2 through the command line (which again, takes 2-3 minutes) apache immediately becomes responsive again and I can use the web gui again. I would have assumed there was some sort of setup period, or infinite loop bug, but the fact that htop shows nothing of note going on in the system leaves me no clues as to a culprit.

Here are the logs from nextcloud when trying to use richdocuments:

  • OCP\AppFramework\QueryException: Could not resolve OCA\Richdocuments\PermissionManager! Class “OCA\Richdocuments\PermissionManager” does not exist
  • OCP\AppFramework\QueryException: Could not resolve OCA\Richdocuments\Capabilities! Class “OCA\Richdocuments\Capabilities” does not exist

Has anyone encountered similar? Is there simple gotcha or some documentation I missed?

Looks like this issue here:
The ticket is still open, but locked. I’m wondering if a solution was ever found?

There have been numerous reports of this issue since NC 23 was released here, on Nextcloud Reddit, and elsewhere. So far the issue has not been addressed or acknowledged officially as far as I can tell other than an “Office Team Lead” comment on this thread, with no follow-up. Neither has anyone reported successfully getting the built in app to work on a bare metal or VM install. Of course this may be because those who have working systems do not come here to report it, but considering the number of people having this issue it seems suspicious.

Most people seem to be “resolving the issue” by moving to OpenOffice or other alternatives but I am still holding out hoping for the problem to be fixed, and ready and willing to assist in any way possible with identifying the underlying bug.

If you need a solution right away you should probably look elsewhere.


If you are interested, I documented my troubleshooting and findings in this thread and went about as far as I can without more knowledgeable feedback and/or advice on what to try next. Some of that info might be useful to you if you pursue this on your own like I did.

Thank you so much JudahK! I knew I couldn’t be the only facing this. I will try a few things you did to confirm your findings (connecting via local IP vs through the typical URL). It is also good to know I can just delete the app from the apps directory to remove it, rather than needing to use occ commands (which get extremely slow when both apps are installed together).

Thanks JudahK and hardingtnextcloud. I am so glad I found this post. I have spent the best part of two days trying to get a stable install of NC23 on VPS Ubuntu 20.04, Cyberpanel and Open Lite speed ( so fault is not confined to Apache web server). Must have reinstalled about 10 times trying NC22 as well but ending up with constant freezing of up to a couple of minutes. Today I tried disabling apps one at a time. I had to do this with OCC as I wasn’t able to access the webui. I had thought it was mail that was causing the freezing but after disabling NC Office 5.0.3 and Collabora 21.11.204 today, NC now seems stable.

Has anyone tried using earlier versions of NC Office and or Collabora that works and is stable. I will try earlier versions myself over the next few days to see if I can find a combo that works. I prefer OnlyOffice but the problem with saving/sync and loosing work means it is not a viable option.

A temporary fix appears to be installing an earlier Collabora online 4.1.2 with current Collabora code server 21.11.204. It is a slow (5 sec or so) to load the document but it at least works. Rich document 5 with NC 23 issues seem to be long standing since Dec 21.

Scroll down to solution by “SitramSoft”