Frequent Nextcloud 29 (Hub 8) update issues

Hi community, I create this Wiki post to help users to find solutions for frequent issues after update to NC29. This should avoid flooding forum with similar topics and help others identify and solve known issues.

this is a WIKI article - everybody is welcome to contribute. if you feel there is a repeated topic related to nc29 update please add it to the list

Github issues

Github tag 29-feedback

htaccess issue

The way how Nextcloud check if the data directory might be accessible from remote changed and for this reason new setup_warning is shown:

English:
Your data directory and files are probably accessible from the internet. The .htaccess file is not working. It is strongly recommended that you configure your web server so that the data directory is no longer accessible, or move the data directory outside the web server document root.

German:
Dein Datenverzeichnis und Deine Dateien sind wahrscheinlich vom Internet aus erreichbar. Die .htaccess-Datei funktioniert nicht. Es wird dringend empfohlen, Deinen Webserver dahingehend zu konfigurieren, dass das Datenverzeichnis nicht mehr vom Internet aus erreichbar ist oder dass Du es aus dem Dokument-Root-Verzeichnis des Webservers bewegst.

related threads:

Troubleshooting steps:

  • review your trusted_domains and overwrite.cli.url values in config.php
    (second one is important in case the server has no internet access and could point to internal URL)

well-known issue

English:
Your web server is not properly set up to resolve .well-known URLs, failed on: /.well-known/caldav For more details see the documentation

French:
Votre serveur web n’est pas configuré correctement pour résoudre les URL .well-known, a échoué sur : /.well-known/caldav Pour plus d’information, voir la documentation

problem is missing trailing slash in /remote.php/dav/ reverseproxy rewrite settings.

Nginx proxy manager (notice trailing /)
location = /.well-known/carddav {
return 301 $scheme://$host:$server_port/remote.php/dav/;
}
location = /.well-known/caldav {
return 301 $scheme://$host:$server_port/remote.php/dav/;
}

related threads:

cron not running

Error: Class “OC\BackgroundJob\TimedJob” not found in ..
different apps which are not ready for nc29 now cause the error so far music, backup, old richdocuments (8.4.0-beta.1)

cron memory warning

“Used memory grew by more than 10 MB when executing job”

Random logouts

After upgrading to Nextcloud 29 (and 28.0.5) users get randomly logged out of the instance and have to login again.
A fix is available at

12 Likes

I have this issue on one of my three NC29 servers - my production server :sweat_smile: The other two are for testing and demonstration / training (both of which run on non standard ports).

All three have been working perfectly prior to NC29. I have checked all the .htaccess and config.php files to no avail. In any case my data directory is not under the server root!

FYI I am running on up to date openSUSE 15.5

  • PHP 8.3.6 (fpm-fcgi)
  • Apache/2.4.51
  • https enabled and enforced on all domains

My assessment of the situation from reading and checking is this is probably a NC29 reporting bug and I believe it has been reported as such, looking for confirmation one way or another.

Update the problem goes away by downgrading PHP to:
PHP 8.2.15 (fpm-fcgi)

Also don’t get the PHP warning anymore:

PHP Deprecated: Optional parameter $userId declared before required parameter $path is implicitly treated as a required parameter in …/nextcloud/apps/deck/lib/Service/ConfigService.php on line 234

Hope this helps!

1 Like

@AJV what specific command did you issue in terminal? Sudo?

3 Likes

Thanks for looking at this! Here you go, logged in as root command and warning:

sudo -u wwwrun php occ setupchecks -vv

PHP Deprecated: Optional parameter $userId declared before required parameter $path is implicitly treated as a required parameter in /srv/www/htdocs/nextcloud/apps/deck/lib/Service/ConfigService.php on line 234

both work with PHP: 8.2.18. Please create complete topic if you have further issues.

Removing “fulltextsearch” resolves “cron not runnning” for me

1 Like

Notes v4.8.1 is very very old. It doesn’t even support v29. Something is strange about your environment since that version shouldn’t even be available to you. Your situation isn’t being caused by v29 itself. Can you please create a dedicated thread with your Server config details in it so that we can troubleshoot it outside of this thread?

I have many error after update to Nextcloud 29 like:

sudo -u www-data php occ setupchecks -vv
dav:
✓ DAV system address book: No outstanding DAV system address book sync.
network:
✗ WebDAV endpoint: An exception occured while running the setup check:
TypeError: OCA\DAV\SetupChecks\WebdavEndpoint::OCA\Settings\SetupChecks{closure}(): Argument #1 ($host) must be of type string, array given in /var/www/http/myweb/nextcloud/apps/settings/lib/SetupChecks/CheckServerResponseTrait.php:69
Stack trace:
#0 [internal function]: OCA\DAV\SetupChecks\WebdavEndpoint->OCA\Settings\SetupChecks{closure}()
#1 /var/www/http/myweb/nextcloud/apps/settings/lib/SetupChecks/CheckServerResponseTrait.php(69): array_map()
#2 /var/www/http/myweb/nextcloud/apps/settings/lib/SetupChecks/CheckServerResponseTrait.php(96): OCA\DAV\SetupChecks\WebdavEndpoint->getTestUrls()
#3 /var/www/http/myweb/nextcloud/apps/dav/lib/SetupChecks/WebdavEndpoint.php(67): OCA\DAV\SetupChecks\WebdavEndpoint->runRequest()
#4 /var/www/http/myweb/nextcloud/lib/private/SetupCheck/SetupCheckManager.php(51): OCA\DAV\SetupChecks\WebdavEndpoint->run()
#5 /var/www/http/myweb/nextcloud/core/Command/SetupChecks.php(72): OC\SetupCheck\SetupCheckManager->runAll()
#6 /var/www/http/myweb/nextcloud/3rdparty/symfony/console/Command/Command.php(298): OC\Core\Command\SetupChecks->execute()
#7 /var/www/http/myweb/nextcloud/core/Command/Base.php(177): Symfony\Component\Console\Command\Command->run()

My system run on : Betriebssystem: Linux 6.5.0-28-generic x86_64

Prozessor: Intel(R) Core™ i5-7300U CPU @ 2.60GHz (4 cores)

Speicher: 7.62 GB

Server-Zeit: Mon May 13 07:58:08 CEST 2024

Betriebszeit: 9 hours, 39 minutes, 1 seconds
|Distributor ID:|Ubuntu|

|Description:|Ubuntu 23.10|
|Release:|23.10|
|Codename:|mantic|

Regarding the .htaccess file not working warning: The solution for me was to remove the ‘localhost’ entry from ‘trusted_domains’ in config.php. Immediately the warning disappeared.

there is a new version of fulltextsearch - cron should run now.

1 Like

It does
thx