Update von NC13.0.6 auf 14.01: ein kleiner Erfahrungsbericht

Beim Upgrade der ersten Instanz ist der Installer mit “Server error” abgeschmiert, was natürlich sehr ärgerlich ist.

Deshalb habe ich bei der nächsten Instanz vor dem Upgrade mit

occ app:list

eine Liste der installierten Apps erstellt und nach dem Upgrade jede einzelne App kontrolliert ob die wieder funktionieren. (Der Installer ist hier beim Upgrade ebenfalls abgeschmiert). Tatsächlich waren ein paar Apps dabei, die im Web UI aktiviert waren, aber tatsächlich in der occ app:list nach dem Upgrade deaktiviert waren.

Da hilft nur ein

occ app:disable appname

mit anschließendem

occ app:enable appname

Also falls der Web Installer beim Upgrade mit Server Error stirbt, kann man dank der occ app:list systematisch alle Apps deaktivieren und hoffen, dass der Server Error verschwindet. Und nacher wieder den Urzustand herstellen - so glaubt man. Es gibt nämlich Apps, die man in Version 14 nicht installieren kann da nicht mehr unterstützt.

Hier noch ein paar zusätzlich Informationen:



Fazit:

:wink:

Ich dachte nur mir würde das so gehen weil ich schon wieder zu doof war…na ja, dieses mal hatte ich meine app auf den aktuellen Stand gebracht, zumindest glaubte ich das, alleine sie wurden abgeschaltet wegen nicht aktuell. Ich habe mich schon gefragt ob ich das nächste mal nicht einfach die alte Version behalte bis die nicht mehr geht und dann alles neu. Wenigstens bin ich nicht der einziege der das nicht hin bekommen hat.