Through HTTPS: Missing the customization of the login screen and the display of some icons and fields (but invisible locations are clickable) - Since my first installation from NC13 to NC15 - Reacts differently according to the shared web hosting service


To start I’m sorry if I make mistakes in English, I’m French. I do volunteer work for 2 very small associations.

I turn to you because, after many months of research, I think I have identified a possible factor of my problem, but still can not find a solution.

First of all, the malfunction has existed since the first installation (with NC13, and today up to NC14), and has consistently returned after trying to reinstall the program.

I have 2 installations of NextCloud. I followed the same procedures and yet they react differently.

The only thing I can identify, therefore, is that one of the installations is hosted in an OVH server in Paris, the other in an OVH server in Gravelines (Northern France).

On the Gravelines based installation, some icons and some fields do not appear when I connect to HTTPS. Without being able to identify why.

I should see a custom login screen. What I have never managed to get in HTTPS (since NC13). Whereas if I connect in HTTP, it works. On the installation in Paris, no problem.

But recently and inside the program, in Gravelines, and that’s only since the migration to the NC14 version, same today with the version NC14.0.3, there are also internal elements that have disappeared, only in HTTPS. I tell myself that with this information you could perhaps help me identify the cause?

Some examples :

  • In the Contact application, I no longer see the search field or the contact search symbol next to my user logo, nor any icon next to the address books.

  • In the Files application, I no longer see the folder or folder creation logos, or the logos to the left of Recent, Favorites, Shares.

  • In the Applications menu, I do not see any logo for some applications such as: Apporder, Brute-force settings, … but others always appear as: Accessibility, Calendars, …

These last problems have occurred since switching to NC14. But as it remains linked to the HTTPS, I say that it is certainly related to the bug of the personalized login screen that I have always known about this installation / server only.

And since it’s not all logos, I think it may be related to some files that would be in a particular folder, a right of access, perhaps related to the core of the program.

Paris - Works fine
Gravelines - Works wrong

Can one of you help me?

Thank you in advance :-*

1 Like

What is the difference between these setups? Are these hosted plans or vservers?

I did exactly the same installation on the 2 servers. Many times, thinking that the problem could come from the installation, but still with the same problem with the HTPPS on one of them only.
They are two separate servers, but supposed to provide the same shared web hosting services and the same configuration, from the same company but on two different geographical sites.
Many thanks in advance for the help :slight_smile:

Hi ffs69,

I am facing exactly the same problem on my NC, freshly upgraded today from 13.0.6 to 14.0.3, on a OVH shared hosting also located in Gravelines.
When checking the OVH panel, I see under ‘Multisite’ the following message
“Une erreur est survenue lors de la récupération du rapport de génération SSL. (d.hostingSSLCertificate is undefined)”

Maybe there could be an issue with SSL on the Graveline hostings.
Tried to regenerate the certificate but did change nothing.
Am trying to delete certificate and generate a new one, I’ll let you know when completed

It should be over cool! Since the time that I remain without explanation on these difficulties, and so soon after having created my post here. It’s a so great community! :metal: <3

So, nothing changed after recreating a newer SSL certificate but the error message on the OVH panel is still there.
Seems to be a little bug on the panel only, not affecting the site, check here:
However, I introduced a support ticket. Will keep you informed when I get an answer.

By the way, can you display the Gallery (on both instances) ?
On my side, I get " Erreur lors du téléchargement du modèle de diaporama.
Connexion au serveur perdu".
It was the same with NC 13.*.
I remember, long ago, switched to phpcgi to solve that but then I got errors with caldav/carddav clients, so switched back again to php.

Good evening,
I’m sorry, I do not use the Gallery application yet, so I can not say.
From my side I can attest that the configuration is exactly the same for both sites. And the same for the access rights to folders and files in the permissions from FTP.
I may be wrong but I tell myself that the difference could come from the configuration of a server software on the Gravelines site. Is it possible to identify it from a browser?
In May I left a comment on the blog Maxime Auvy ( to expose my problem and try to get a reply. Others seemed to experience the same difficulties. Then comments were turned off, it seems, or become private, I no longer have access.
If anyone can help? It would seem that we are several in the same case.
Finally, as some logos seem to appear anyway, I tell myself that there may be something that can be done since NextCloud to work around the problem.
Good to all of us, kisses

Hi ffs69,

Made some more tests and I can confirm this :

  • switching from php to phpcgi in the OVH config does solve the problem you describe and also solves the gallery app problem I mentioned (also in my own post here (

  • BUT doing this breaks my carddav/caldav synchro with Thunderbird AND with Davdroid

  • I switched back to php and my synchro is running fine again.
    And as strange as it sounds, invisible elements you mentioned are now displayed !
    (Is it related to some cache on the server side and will it stay stable in long term ?..)
    But gallery app is again broken.

Finally, my “valid” OVH config, is the following


Obviously, for my usage, carddav/caldav synchro (and webdav but this part does not seem to be impacted) is more important to me than a gallery app, but it would be nice to make it running to share photos with family and friends for example.

If anyone else has ideas…
Thanks to all.

Awesome, thanks for the answer! :sunglasses:
Indeed, having switched from php to php-cgi, then back to php and hidden icons reappeared.
However the home page is still not customizing on this Nextcloud.
If I leave in php-cgi, the homepage is well customized in HTTPS and icons are also present. I still have not left long enough to check the caldav synchronization problem. I’m afraid of breaking everything.
Could you explain to me the implications of changing the engine from PHP in production mode? Can this create irreversible bugs?
And what are Nextcloud’s recommendations on this?
On a forum I found that I had to switch to Jessie.i386, what I had done for both sites. Now I have configured like you:


Hi ffs69,
Sorry for the delay.

Today, my Nextcloud is back with missing UI objects.
As I said, i feared a “cache” thing that would not last.
For once, I had hopes not to be right ! :grin:
So, back to the start with no solution…

I also got answer from OVH support team and they confirm that the “SSL” error message on the OVH panel is due to a bug on the interface displaying this and that we can ignore it.

To answer your question about PHP settings, have a look here for details from OVH:
Nextcloud recommendations are not very clear about all these settings because they are also partially linked to the shared hosting, but I found some advices on different forum threads here and there.

One more thing, I created a new thread here to share experience with other OVH members:


First of all I’m sorry to come back so late, I had a lot of things to handle, then I hoped and waited for version 15 of Nextcloud to come out, but it did not solve anything.
I even have other problems now but I’m going to do other topics, I do not think it’s related to the problem of this topic.
Like @CFelten and many others, when I switch to phpcgi the icons reappear but I lose synchronization (with a small cache delay), and the opposite when I come back on php-fpm.
So I have no idea. Except that everything is working very well for another nextcloud hosted in OVH’s Parisian servers.
So the only assumption I always imagine is a difference in the configuration of a function, a program or a server between their different geographical sites.
After, maybe an expert would help us by technique and programming to identify why some elements are displayed well, and others not?
Hoping we can find a solution.
Many thanks

Hello everyone,

Just because I have identified another difference between my 2 shared web hosting services and that maybe the problem can come from there?

On my shared web hosting service in Paris where everything goes well the MySQL version is 5.5.60-0 + deb7u1-log

On my shared web hosting service in Gravelines where I have display malfunctions at least the version of MySQL is 5.6.39-log

Otherwise, if one of you can identify the cause and propose a solution with Firebug mode or equivalent, the display difference starts from the login page:

OVH Paris (MySQL 5.5.60-0 + deb7u1 - PHP 7.2.12):
http:// - Works well
https:// - Works well

OVH Gravelines (MySQL 5.6.39 - PHP 7.2.12):
http:// - Works well
https:// - Works badly - Need help

Thank you in advance. I know I’m not the only one to experience this dysfunction.

Sorry to insist but if anyone could help it would be very nice! :pleading_face::pray:
It is quite blocking as dysfunction to be able to propose the platform to my neofite comrades. It’s frustrating^^
Big kisses and long life :person_in_lotus_position:‍♂:stars::crossed_fingers:

Did you ask the support? I can always try to figure out if there is a difference (perhaps check php.ini output of both servers). But if it is related to the ssl-configuration like this it is hard to guess and even if you knew it, you’d have to hope that your provider is willing to change it. It’s already hard enough if you have full access.

Hi @tflidd,
I asked OVH again, they shirk the discussion :frowning_face::pensive:
"[…] this problem can not come from the infrastructure but from the configuration of the site.
Indeed I invite you to disable the different .htaccess files present on your hosting, they can be at the origin of the redirection towards a non-customized site. "
But I checked, configurations and folders via FTP are strictly identical.
Can there be a way to identify a part of the code that is missing and / or filtered in the display of a page?
I thought maybe that way someone could help me with a firebug or something like that.
Otherwise if there are ways that I test the configuration, with help, I am a volunteer and a taker.
Thanks in advance to the community,

Hi ffs69,
Maybe something interesting in this :

Hi ffs69,
Could you please see this message and tell us if you have the same warnings on both sites ?
(I guess yes)

Thanks !

I asked OVH again, they shirk the discussion…

I also think that there might be a difference in the servers configurations, maybe subtle, maybe hard to track, but the fact is there. You managed to compare and check every configuration and element that is accessible from your side, as user of a shared hosting.
If the problem comes from one of your files or settings as they say, why does it work like a charm in Paris ?!

Hello @CFelten,

First of all, I have bad news, the data of the OVH servers in Paris are being transferred to Gravelines! :frowning_face:

I confirm that my 2 configurations are strictly identical.

I just tried to install a new Nextcloud 15 in Gravelines, exactly the same symptoms (wobbly customization, the same icons and fields are invisible …), so it is not related to the installation! :wink::thinking:

.ovhconfig :


phpinfo.php :

There are differences in the values of:

  • mysqlnd statistics
  • Zend OPcache

Someone to help us?
Arigatō gozaimasu :pray:

ps: I have the same warnings that everyone has in his shared web hosting at OVH, the same on the 2 servers, so it is independent of the problem that we meet here :wink: :

* Some files have not passed the integrity check. Further information on how to resolve this issue can be found in the documentation. (List of invalid files… / Rescan…)

* PHP does not seem to be setup properly to query system environment variables. The test with getenv("PATH") only returns an empty response. Please check the installation documentation ↗ for PHP configuration notes and the PHP configuration of your server, especially when using php-fpm.

* The PHP OPcache is not properly configured. For better performance it is recommended to use the following settings in the php.ini:


I wish you happy holidays and meals close to overdose :joy::rofl::sob:

The one which works badly for https, it works for me as well. I don’t see the problem.