Gallery error downloading slideshow template

NextCloud 13.0.2.
OVH Shared hosting
PHP v7.1
MySQL database

Hi guys,
My gallery app seems broken.
When I click on the gallery button (in the upper rubbon), I get the following message and no content displayed
" Erreur lors du téléchargement du modèle de diaporama
Connexion au serveur perdu"
If I navigate to a folder in the files app and then switch to thumbnails view, I get the same.

I upgraded from 13.0.1 to 13.0.2 two days ago, maybe it caused this.

Nextcloud log is empty.

Already tried disabling all apps that were not activated on a fresh install, does change nothing.
Any ideas ?

Update on this;
Another detail that could be useful: my cloud is hosted on a OVH shared hosting.
Everything else works fine, html access, desktop and mobile syncing (files, calendar, contacts, …).

Any ideas what could be the problem with gallery app ?

Finally solved !
I found a solution in the users forum of my host (OVH).

SOLUTION: changed my hosting config from “PHP” to “PHP-CGI” (version 7.1).
And the Gallery app works fine now.

ATTENTION: switching from php to phpcgi in my OVH config solved the gallery behavior but created another BIG problem