Nextcloud 20.0.2snap2 Interface Incredibly Slow

I’m trying to nail down a major performance issue that has arisen in two separate self-hosted instances of Nextcloud (snap) and wanted to see if others were experiencing something similar.

Since Nextcloud 20 I’ve been getting exceptional performance out of the web interface. But starting yesterday afternoon everything has slowed to a completely unusable crawl. This began around the time that a new snap version (20.0.2snap2) was rolled out.

This has happened in two completely separate instances of Nextcloud and I’m seeing absolutely nothing abnormal in terms of ram, cpu or bandwidth usage. Other things I’m hosting in the same datacenter are running exceptionally well. And the desktop syncing (linux, debian, via both the client and online accounts) is as good as it has ever been. But the web interface has slowed to a crawl.

My suspicion is that it is related to the Nextcloud snap update. But I can’t see anything that would indicate that that is the case. So before trying to raise an issue on the github page for Nextcloud snap I thought I should check if others are experiencing similar.

Anyone else?

1 Like

Problem solved. Something in the snap update breaks Collabora Online app (with built in CODE server) and causes a failure to establish a connection to the built in CODE server and a constant attempt to make that connection. Disabling the app brings back snappy performance. I suspect the app needs to catch up with the update in some way, but an app update is not yet available. I think I need to disable auto-updates of the snap package to prevent this in future.


Just want to point out, I had this same issue but it was happening differently. I use traefik-forward-auth to protect some of the services I have in my system, since Nextcloud was meant to be public-facing, I turned it off and each page took 45 seconds before they tried to load. If I enabled traefik-forward-auth again on the Nextcloud domain, the issue went away.

Regardless, it was Collabora! Never fails that an Office plugin on Nextcloud messes stuff up.

I had the same problem, but i use Docker (not snap).

This is really bad. I searched everywhere to find the issue for 2 hours.
I got terrible loading times and very often timeouts after the update to Nextcloud 20.
I thought the update may have failed partially.

To clarify, 20.0.2snap1 was working fine, 20.0.2snap2 started slogging? There was only one difference between 20.0.2snap1 and snap2: snap2 runs occ -n db:add-missing-primary-keys for you, snap1 didn’t. Any chance you see any interesting logs from collabora? Maybe adding those keys breaks it somehow?

Exactly that. I have it set to auto-update. At some point yesterday the system surprised me by going into maintenance mode. And ever since then it started slogging away. Nothing in logs, and really hard to see it from ram/cpu/io usage. Someone on reddit also says it started a couple weeks ago after an update in docker and can’t be seen in logs or usage. It is super weird. But I have two instances of Nextcloud and this immediately impacted both even though I’d done nothing in either other than the auto-update. It just started happening. Sounds to me like the problem sits with Collabora/RichDocuments. But again, I’d done no app updates or anything like that. It just happened across two Nextcloud instances and was fully resolved in both by just getting rid of collabora (and same it seems for everyone else).

1 Like

That’s very odd, I hope someone has logged a bug against Collabora?


Facing the same issue on 20.0.2. Disabling Collabora + CODE fixes slowness.

1 Like

The same issue here
Ubuntu server 20.04 + Nextcloud 20.0.2 snap 2
Disabled Collabora + CODE
The server is working again normally.

1 Like

Just the same over here. Running an Ubuntu VPS with Nextcloud in a Docker container. After disabling the CODE server and Collabora Online everything just got back to normal.

Also the same

Ubuntu server 20.04 + Nextcloud 20.0.2 snap 2 running as a snap
Disabled Collabora + CODE now I have the normal performance as before

1 Like

Same! 20.04 + Nextcloud 20.0.2 snap 2

I’ve opened an issue in Nextcloud/richdocuments (nextcloud/richdocuments#1282).

At least for now we have the solution: disable collabora and the code server either via the web-interface admin settings (if you can get there), or via the server terminal (sudo snap run nextcloud.occ app:disable richdocuments && sudo snap run nextcloud.occ app:disable richdocumentscore).


Confirmed sudo snap run nextcloud.occ app:disable richdocuments && sudo snap run nextcloud.occ app:disable richdocumentscore resolved my issues.

Just like everyone else the issue began happening after the latest update.

1 Like

Yes, confirming that this fixed my issue as well.

1 Like

Guys… I was freaking out, when I realized how slow my webinterface was. Thought of the worst like got hacked or so. You are brilliant. I can confirm the same behaviour since the update and the fix works perfectly! Thanks, highly appreciated!

1 Like

I hope that everybody agrees that this solution does not fix the problem.
I use Office online editing in Nextcloud and now I had to disable this function because of the problem. That is why I need this function working back ASAP.

What I found is that if you go to Settings for CODE server, there is a link to Collabora Online, but it’s without /index.php - this is the right link, /index.php/settings/admin/richdocuments , I get /settings/admin/richdocuments . Maybe this can help?

@aob01 can you please exactly explain what you did?
Because I am not able to edit settings of Collabora server as you mentioned.
I will be glad for step by step tutorial.
Thank you.

It’s just my observation what probably went wrong.