Is there a solution RPi Arm64 NC20


what about libvirt? Isn’t it possible to emulate a x86 CPU on an raspberry 4?

1 Like

I had solve this problem on a test instance only with Only office or CO running on a different x86 machine.

1 Like

I can not help as I am in the same situation, do not download C. Server ARM64. The truth is that I am still with RP 3b+ but I put to watch the issue since it interests me for a near future.

We wait for if the named RP 4c comes out. Raspibian 64 bit and that the people of Collabora update their program.
Greetings to everyone

Resources on this page might help:

The hurried in there are English guides that I think will do what you want
1 Like

What happened? What faults have occurred?

Yes, you can run NC20 on Raspberry Pi 4 with NextcloudPi.
Yes, Collabora is available for the Pi 4 via the appstore. Just has some installer issues being worked out.

Your best bet for Raspberry Pi is to use NextcloudPi, which is an official project designed to simplify installation and maintenance. Upgrading to version 20 is simply a matter of going to nc-update-nextcloud and typing 20.0.0 so there was no reason to stop using it. You can track status of testing new releases on their Github here. You can search the forum for more info on ncp and look at their category. They also have a Telegram channel at

There is a lot of misinformation in this thread. Collabora is available now for arm64 devices, but there are some issues with the installer being resolved.

Collabora CODE is available from the appstore here for arm64 as of Nextcloud 19.

System requirements for Collabora CODE (in addition to Nextcloud itself)

Linux x86-64 or ARM64 (aarch64) platform
2 CPU cores
1 GB RAM + 100 MB RAM / user
100 kbit/s network bandwidth / user
350 MB space on disk
Nextcloud 19 with Collabora Online app 3.7.0 or higher
glibc (AppImage does not support musl libc)
Fontconfig ( - required by Collabora_Online.AppImage)

Hope this helps!


Some great resources there thanks

Very helpful thanks a lot. Im running NC and rev proxy Collabora on the same device so that may be where Im going wrong. I have a 2gb x86 intel compute stick that may work for collabora

I dont have any faults on the working system which is Pi4 NC 20, I just cant seem to connect collabora to CODE because it doesnt see it. That said and reading below, I think I just need to put it on a different IP

and on an x86 cpu, just be sure.

You can also try installing Collabora CODE (arm64) from the appstore. It is in there under office category. Basically it is a packaged version of Collabora that includes some blackmagic for satisfying the reverse proxy requirement. :+1:

it is working on nc20 with communitydocumentserver 0.18

1 Like


i am very sorry, but i tried myself some time ago to install collabora, and was not able to start it.
I now use onlyoffice with the needed app “community document server”. Be aware : Onlyoffice only works with the server app !
But until now, onlyoffice is extremely good !

with greetings,

Christian Anzinger

Thanks Christan, I had a problem doing this. How did you do it ?

I am not using a ready to use image.
I installed nextcloud on a small micro atx board with onboard intel processor an 4 HDDs…
so it is a bit different with a very hard time of trial an error. I recommend to try it yourself.
I bought the linux bible, actual version, a book about ubuntu server 18.04 (When you start now, you should use 20.04) and tried to install, and correct errors reported by nextcloud info under settings. Now my system is without any error and runs in a virtual machine in virtual box under ubuntu 18.04 server. This way i can make copies of the complete nextcloud system. I grew to this over time seperating zoneminder videorecording under linux (one vm) and pihole (another vm) and samba file server (on the main linux server)., You learn a lot, and understand, and its easier to backup the whole systems, and keep them up to date (in case of my server, it runs since 2018, and needs to be completely reinstalled 2022 …)
On a nextcloud without reported errors or correction, you simply activate the apps onlyoffice and the server, and you have the new option in every folder of making a new document …

i hope, you make it, because in images it works … or not …


Christian Anzinger

1 Like

I have a Raspberry Pi 4B with 4 gb using Ubuntu 20.

While version 19 was an easy installation and upgrades were working until version 20, this version required a complete re installation of the MySQL tables as well as Nextcloud (even though the database was backed up). It crashed somewhere in the latter steps of the upgrade process.

While everything is back to normal and working well, I have been working on another Raspberry Pi 4B (4gb) to do the Collabora work.

After the update provided on 10/16, the ARM64 CODE Server is working.

I was just finishing up on setting up a container on a Windows 10 computer. Thankfully I won’t have to complete the installation of the container.

Hi Tim, You have just about mirrored what I have done in the past few weeks and arrived at very similar issues to me. I think the RPi 4 will be great once the range of problems have a workaround or alternative solution but I think that for now at least I will be looking at Ubuntu 20 LTS and implementation of NC onto an Intel NUC or similar to address the inherent problems with both Collabora and OO. Having an integrated/owned at home document server is important for me and having a NC solution without this kind of defies the purpose of NC i.e. I would still be reliant upon other software or web services.

Hancom has been touted as an alternative but doesn’t seem to be available to try yet and may or may not be a viable alternative.

Also, I imagine or hope that nextcloudpi were looking to implement 20 as a build option for pi4 in the near future.


has anyone looked at this odroid device ? dual NAS Pi alternative
dual HDD slots
Amlogic S905X3 SoC

do you think this is strong enough for say 5 users with talk and potentially collabora ?

1 Like

my solution for now is to use ubuntu for pi4 and install it using snap.
sadly kodi doesn’t run as good on ubuntu as on raspbian

I think it will work well, but the limit may be in regards to Collabora. Collabora requires 1gb of ram + 100mb per users (x5), so that will likely by taxing the 4gb of memory available. In general, looks really nice!