Documents downloading, instead of opening in Collabora

Debian 10 - Fully patched
PHP 8.0.17
Nextcloud Hub II 23.0.3
Using our own Collabora Online-server.

I’ve been dealing with this since upgrading to 23.0.3. At seemingly random times during the day, people will suddenly be unable to open documents inside Nextcloud. Instead, it prompts them to download the document. The only way to fix it, is for me to go into the settings, select the Demo server, then select my own server again, and click save. This only fixes it temporarily, sometimes it’ll be okay for a week, and sometimes only an hour or so.

When this happens, there are no errors of any kind, in any of the following logs:
nextcloud.log
coolwsd.log
php8.0-fpm.log
apache logs
redis-server.log

I don’t know what other logs I might check.

Can anyone shed some light on how I might track this down?

I would check the github repos for related issues. Sounds frustrating. Found this for the built in code version.

It seems the referenced issue in github has died out without a solution. I have the exact same problem with this configuration:

  • Odroid HC4, 4 Gb,
  • Ubuntu 20.04 LTS headless, Linux 5.13.0-odroid-arm64 aarch64
  • Two SATA SSD’s — one as boot and system-drive, the other data drive for NextCloud.
  • NextCloud Snap - - installed with ‘sudo snap install nextcloud’
  • Nextcloud Hub II (23.0.3)
  • mysql 8.0.28
  • PHP 8.0.16, Memory limit: 512 MB
  • Apache

I’m using the built-in CODE and NextCloud reports that the Colabora Online server is reachable - but still it only downloads LibreOffice document.
Also as others have reported I too have the menu items to create new Ofiice documents but they do not work.
I have correct timezone, I’m not using Nginx or any of the other things that has been suggested as the culprit here. I think this is a bug in Nextcloud Hub II (23.0.3) – has anybody confirmed or rejected that?

Unbelievable. For many home users, Nextcloud Office is only interesting if it is a real part of the Nextcloud server and not an additional server on another hardware.

Considering how Nextcloud Office was once presented.

Let’s wait and see what new features are available at Nextcloud 24.

Home users aren’t the important part, paid corporate users are (for Nextcloud) since they probably like being able to pay their workers and keep the lights on.

But stuff like this is exactly why I’d be scared shitless if the company I work for suddenly wanted to swap to Nextcloud. Completely unacceptable hacky shit that doesn’t work though it’s supposed to is survivable in a hobbyist setting, but is a death knell for the entire solution if this is what corporations experience.

I’m also unable to get CORE + Nextcloud Office to work on my NC 23, which is irritating but not really catastrophic. If I was trying to run a company on this though it would be.

@DeadTOm

What are your server specs? That is the number 1 reason people have office suite trouble. It is quite demanding.

@jensottos your device is not powerful enough to handle the office suite. 4gb ram is the minimum for it to to do anything, which is why it performs very poorly. Makes sense it would cut out as load on your odroid ram and cpu increases. Bummer, but also the truth. You’ll want to run it on a VPS or other server if you want proper performance and availability.

Thanks, but none of the suggestions in the links fixed the issue for us.

Having increased the logging verbosity to debug, I’m now seeing a bunch of these errors in the logs, every time someone tries to open a document in Nextcloud.

{"reqId":"pObRGNBuLIZFN6DNjR9t","level":1,"time":"2022-05-02T14:50:30+00:00","remoteAddr":"<REDACTED>","user":"<REDACTED>","app":"no app in context","method":"GET","url":"/index.php/core/preview?fileId=67172&c=cbec9105ee4bcc639a1b23b715148a24&x=250&y=250&forceIcon=0&a=0","message":"Deprecated event type for OCP\\IPreview:PreviewRequested: Symfony\\Component\\EventDispatcher\\GenericEvent is used","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:99.0) Gecko/20100101 Firefox/99.0","version":"23.0.3.2","id":"626fefcf99912"}

{"reqId":"nX7rzY3iAceUkNts0TPq","level":1,"time":"2022-05-02T14:50:30+00:00","remoteAddr":"<REDACTED>","user":"<REDACTED>","app":"no app in context","method":"GET","url":"/index.php/core/preview?fileId=37759&c=df74c2962a454b8d418b0928199b282c&x=250&y=250&forceIcon=0&a=0","message":"Deprecated event type for OCP\\IPreview:PreviewRequested: Symfony\\Component\\EventDispatcher\\GenericEvent is used","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:99.0) Gecko/20100101 Firefox/99.0","version":"23.0.3.2","id":"626fefcf99950"}

{"reqId":"EBGgK3J33NBbK5Q967J4","level":1,"time":"2022-05-02T14:50:30+00:00","remoteAddr":"<REDACTED>","user":"<REDACTED>","app":"no app in context","method":"GET","url":"/index.php/core/preview?fileId=67194&c=bd6f516bd89ae052c55e70c9ac018b10&x=250&y=250&forceIcon=0&a=0","message":"Deprecated event type for OCP\\IPreview:PreviewRequested: Symfony\\Component\\EventDispatcher\\GenericEvent is used","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:99.0) Gecko/20100101 Firefox/99.0","version":"23.0.3.2","id":"626fefcf99986"}

Again, going into the settings, selecting the Demo server, then selecting “Use your own server”, and clicking “Save” temporarily fixes the issue. I’ve been unable to determine when it stops working again, or why.

This is going to be a deal breaker. If we can’t get this resolved, we’ll have to move on to a different product. :frowning:

PHP 8.0.17
Nextcloud Hub II 23.0.3

COOLWSD version:
21.11.3.6 git hash: [eb73aa3]
LOKit version:
Collabora Office 21.06.26.1 git hash: [524dda8]

Served by: Debian GNU/Linux 10 (buster) [effd2ce8]

8 core Intel(R) Xeon(R) CPU E5620 @ 2.40GHz
16GB RAM
Network bandwidth is 1gb
4.6TB of free space

At any given time, we rarely have more than 10 people editing documents at once.

We are well within the system requirements.

1 Like

Since you are running your own Collabora server, you can check on their end for more ideas and link back here.

https://forum.collaboraonline.com/

1 Like