Enable notification emails (Activity app) - not work

Hello everyone.

A strange problem.
Can’t turn on email notifications (Activity app).
I put a check mark, refresh the page there is no check mark.

Where to look?

NC 21

Here I put a tick. After reloading the page, the check mark disappears. Accordingly, notifications by mail do not work.

Capture

1 Like

@Artem2 had the same problem here, it appears to be a bug with the database (mysql 5.5 in my case) here’s how I resolved it make a backup first.
using mysql

1 enter mysql as root,
mysql -u root -p

2 check database name,
show databases;

3 enter your database,
use YOURNEXTCLOUDDB;

4 check if value is no,
select configvalue from oc_appconfig where configkey="enable_email";

5 change the “enable_email” value to yes,
update oc_appconfig set configvalue = "yes" where configkey = "enable_email";

6 check if the value changed,
select configvalue from oc_appconfig where configkey="enable_email";

7 save and exit,

commit;
quit;

hope this helps!

1 Like

I have the same issue. But i’m using Sqlite, any idea how to do it there?

Edit: Answering myself:
Downloaded /owncloud.db
Use “DB Browser for SQLite” to edit the database
Uploaded modified db

However, this bug should be fixed.

Thanks. After using the database commands, the checkbox stays enabled now (although reloading the page via F5). I didn’t try to disable it again via WebGUI to see how it behaves afterwards.

Howeve ,we are still getting no notification mails :frowning:

Maybe a solution:

Verify in the activity-settings, that notification email on download of shared files is checked.
Share a file as public link.
Logout of Nextcloud
download the shared file via the link.
You now should receive a notification mail next (as set in the settings)