Calendar sync with Thunderbird/Lightning broken due to Apache 2.4/http2?

#1

My nextcloud server (back then it was still running ownCloud) stopped syncing calendars with Thunderbird/Lightning a few weeks ago. Now I just learned, that my hosting provider (Hostpoint) upgraded from Apache 2.2 to Apache 2.4 which now supports http2. This upgrade seems to be what broke the sync.

Is there something I can do on the nextcloud server side to get the sync working again?

I have also added a comment to an existing bugreport for thunderbird (https://bugzilla.mozilla.org/show_bug.cgi?id=1106727). As the sync works with Android and iOS devices still works, TB certainly is also involved in this issue.

The nextcloud server is the latest version. TB/Lightning as well. Tested with Windows and Linux (Kubuntu 16.04LTS)

[fixed with NC 12.0.1] Syncing issue with Thunderbird + Lightning
#2

I’m doing just fine here with Apache 2.4.10 and the latest Thunderbird/Lightning on Win10. I know this isn’t particularly useful information for you, but maybe it’s a different part of the stack that’s causing the problem?

#3

Thanks for the info. I’m still trying to figure out what the exact problem actually is. All I know for sure is, that it stopped working, when my provider upgraded Apache.
Any help in finding the real problem is appreciated.

#4

I’m having the same issue.
The Thunderbird console tells me this:

CalDAV: Nexcloud points to a DAV resource, but not a CalDAV calendar
#5

This reminded me of an old bug report where Lightning does not support multiple calendars and so I tried to set up individual calendars and that works…
You need to click on the calendar you want to add to TB, which brings up a menu and click on share to get the URL to use.

#6

I have the same issue with Caldav and Carddav as well. I also made a post here. Unfortunatly your solution does not fix my problem…

#7

In my case this is not the issue since I’m using the individual calendar links from ownCloud/nextcloud. And it had been working for several years like this before!

#8

Did you find a solution yet? I’m facing the same issue. All windows clients with Thunderbird show the login window, but won’t accept any correct credentials. NC logs doesn’t seem to say anything unusual…

#9

No still no solution found… :frowning:

#10

Hi,

Works well here…

Don’t forget to write the complete url of your calendar in Thunderbird/Lightning

https://your-server/remote.php/dav/calendars/your-user-name/name-of-the-calendar/
and
https://your-server/remote.php/dav/calendars/your-user-name/contact_birthdays/

How can i sync the calendar with Thunderbird?
#11

Yes, I’m using the full URL. And it used to work for many years actually. But since my provider updated to http2 it does not work anymore with Thunderbird/Lightning but all other clients still work.

#12

O.K. meanwhile be sure that the openssl library version is = 1.0.2 or greater.
The1.0.2 version include specification RFC7301 (protocol ALPN) required for being able to accept HTTP/2 negociations.
The 1.0.1 version permit only NPN protocol wich is now obsolete.

#13

[user@server:~] $ openssl version
OpenSSL 1.0.2h 3 May 2016

The OpenSSL version on the server seems to be OK. Any other ideas?

#14

Sorry, no…

I know some administrators have been obliged to tweak their ciphers (no cipher from a specified black list may be used) but i didn’t have to do that here. Anyway must be a problem with your hosting provider.

Regards,

#15

… or rather TB/Lightning as it works with all other clients I have tested.
But thank you anyway!

If others also face this problem please comment on this Bug report https://bugzilla.mozilla.org/show_bug.cgi?id=1106727

#16

I have to correct myself: The issue was that two users obviously didn’t enter their passwords correctly, although they were 100% sure they did. The question remains, why Lightning wants them to reenter their credentials after migration, but anyways, it works now.

Sorry to barge in on this thread and I hope you’ll find a solution soon! :sweat_smile:

#17

It is also important to create the url be in lowercase format.

#18

Same problem on nginx. Interestingly, additionally to calendar not syncing, I can’t access Nextcloud from Opera Mobile with http2 enabled.

#19

I have the same problem, since I switched my server to http/2.

Actually I was hoping that adding it with Protocols h2 h2c http/1.1 would allow it to fall back to http/1.1 if http/2 is not working. But I also enabled H2Direct, which I read brings some compatibility issues. I will try it without and see if it helps. But it will take time until tomorrow. My preview generator is still pre-generating previews of dozens GB of pictures :stuck_out_tongue: .

Opera Mini actually works fine for me, with and without data compression (inaktiv while WLAN connection). I use the newest beta 21.0.2254, maybe they added support recently.

http://caniuse.com/#feat=http2 shows browser compatibility. Opera Mini is still listed as unsupported. Maybe this changed in the current beta, maybe it just works because of successful http/1.1 fall-back?

€: disable H2Direct directive doesn’t fix the thunderbird issue. I also updated thunderbird and lightning to the current beta (50 beta 3) but still no http2 support. Poor thing… maybe someone with access to mozilla forums can give some hint there.

€€: Okay, the latest issue was just because of the calender cache could not be touched or something. I deleted to old ones and added the exactly same DAV urls again and now it works. Also the contacts now work, why ever :smiley: . I don’t know if this is new, but at least in the thunderbird 50 beta there is also some setting in about:config to enable/disable SPDY and http2 suppoert.

#20

I finally found a workaround and got Thunderbird/Lightning got to sync again with nextcloud
The workaround is to set “network.http.spdy.enabled.http2” to false in the Thunderbird config.
See also https://bugzilla.mozilla.org/show_bug.cgi?id=1106727#c18

As additional information here is a Bug report against Apache for this issue https://bz.apache.org/bugzilla/show_bug.cgi?id=60663

1 Like