Caldav and Carddav stopped working with Thunderbird after manual upgrade

Hello Nextcloud community.

I have a problem with my caldav and carddav accounts after manually upgrading from Owncloud 8.2 to Nextcloud 9.0. I try to provide as many details as possible. Please let me know where to find logs or what to do to help debugging.

  • Nextcloud instance is running on a Synology Nas.
  • Installation of Owncloud was done back then manually by unpacking the files on the station. Unfortunately I cant find the howto anymore
  • For upgrading first owncloud was upgraded from 8.0 to 8.1 and then 8.2 with the official update centre. Afterwards Owncloud 8.2 was upgraded with Nextcloud 9.0 following the official recommendations from this site.
  • Caldav and Carddav worked on the 8.0 Owncloud version.
  • Sync is done with Thunderbird-Lightning client and Android caldav and carddav apps.
  • Both, calendar and contacts appear in Nextcloud-Interface, and they can be edited via the webinterface
  • however on the client-side, (thunderbrid) the calendar was first showing a connection error message. Than when making a new subscription a dialogue window pops up: “A username and password are being requested by <>. The site says: “sabre/dav””. After entering the credentials and confirming with “Finish”, this dialogue window is reappearing over and over again, so I guess login does not work.
  • same login problem appears for carddav.
  • I tried https and http. no difference.

What can I do to solve this?

P.S. Many thanks for continuing to develop this great tools!

For OC9 the Calendar and Contacts apps have been rewritten and the CalDAV and CardDAV backends of these apps were merged into ownCloud core. During the upgrade existing Calendars and Addressbooks should automatically bemigrated. As a fallback for failed upgrades or an option to test a migration dav:migrate-calendars and/or dav:migrate-addressbooks scripts are available via the occ command after you have added ‘debug’ => true to your config/config.php.

For the occ have a look here:

I feel a bit unsure on how to proceed. Are you sure I need to debug the calender migration? I tried the OGG commands after editing the config file but I get an error message “Could not open input file: occ”

The calender migration worked (as far as I can tell) since I can access the old calender and the old contacts from the webinterface (and android).

Furthermore I encounter the same problems in thunderbird when creating new calenders (or contact lists) in nextcloud. Therefore I am not sure if the calender migration is really the issue or if it is just a problem of thunderbird/lightning communication with the server…

seems that people on owncloud 9 had the same problem and could only solve it with downgrading to 8.2. again… :frowning: