Calendar sync with Thunderbird/Lightning broken due to Apache 2.4/http2?

Interesting, for me actually it worked after removing and adding the caldav calendars again, with “network.http.spdy.enabled.http2 = true”.
But as mentioned above, I used version 50 beta, the stable one seems to be still in the 40s. The fix might be implemented in between.

What part of the setting is that in?

It seems that I have a similar problem (see here), but setting network.http.spdy.enabled.http2 to false did not fix it. This said, going back in this thread, I see that the version of OpenSSL on my server is not ≥1.0.2:

# openssl version
OpenSSL 1.0.1e-fips 11 Feb 2013

Could that be the issue? If that is the case, is there any workaround? I am on a shared server and it is not in my power to update OpenSSL…


After upgrading NC from 11.0.1 to 12.x and I guess more or less at the same time getting an update to Thunderbird, I had the same problem.

I just realized I had to disable Thunderbird’s network connect by system proxy. Now it works again.

May that help?

Thanks MikeLupe for your answer. It does help to see I’m not the only one having this problem… but it did not fix my issue, unfortunately.

I went a bit deeper in my tests and trials, including trying an empty profile and changing a hidden pref, to no avail (details in this thread). Any suggestion would be greatly appreciated.

For the record, my problem is solved in NC 12.0.1, thanks to tflidd for the help and figuring it out.

I know this is rather an old thread, but I suddenly started experiencing the exact issue first described. The change, in my case, was a move from using the fastcgi mod in Apache 2.4 for php5-fpm to using the proxy_fcgi alternative. The result is that Lightning no longer connects to Nextcloud calendars.
The issue can be seen in the nextcloud log as "No ‘Authorization: Basic’ header found. Either the client didn’t send one, or the server is misconfigured,"
The difference is that, under the fastcgi option, the parameter “-pass-header Authorization” is added to the php5-fpm socket description, while this is not usual, or possible, when passing as a proxy.
The issue seems to be resolved in apache 2.4.13 and above, with a “CGIPASSAUTH” directive, but this is not available under earlier versions. In theory, according to what I have found, adding “SetEnvIf Authorization “(.*)” HTTP_AUTHORIZATION=$1” to the .htaccess should work, but this is already in Nextcloud’s .htaccess
Hope this helps someone.
As of now, I have no solution, but I think, at least, I have understood the issue.

I have stumbled on a solution, but to be honest, I do not understand the reason. I have been able to confirm that using php5-fpm with proxy_fcgi is the cause of authorisation issues, resulting in Lightning not being able to connect correctly to the NC server. Reverting to mod_fastcgi resolves the problem, but it seems NC devs are aware of this, and add relevant use cases into the .htaccess file. Unfortunately this still does not resolve the problem. Eventually I stumbled on an incantation that resolves this, using a proxy directive ahead of a SetHandler directive, and with this, mod_proxy_fcgi option with php5-fpm works for Lightning, as before.
The way I have done this is to add and enable a “php5-fcgi.conf” with the following
<Proxy “fcgi://localhost:9000/”>

<FilesMatch .php$>
SetHandler “proxy:fcgi://localhost:9000”

I would prefer to be using a socket, but this is acceptable.
Hope this helps someone.