Windows Client 3.4.1 - Sync not working

Hello,

updated my client via in app update notification to version 3.4.1
Since then the sync is not working.

The client searches for changes, but doesn’t down- or upload files. Sometimes freezes while searching for files.

Tried to downgrade the Client doesn’t work, so I’m back again and now stuck witch 3.4.1.

Any ideas on this or help?

What exactly did not work? - Did you get any error messages?
Did you disable automatic search for updates in the desktop client before downgrade? - Otherwise the update might start at next Nexcloud start.

Just delete the Nextcloud 3.4.1 desktopclient in the Nextcloud folder
C:\users\<username>\AppData\Roaming\Nextcloud
, before you try to downgrade to an earlier version and execute the installation of the previous version from there, if the package can be found in that folder.

After automatic update to 3.4.1 on my Laptop with Win 10 pro with Bitlocker, the client freezes completly and crashes the Windows explorer until I kill it by task manager. Tried new installation and delete the sync Files in the nextcloud folder, same problem. Nextcloud is up to date and runs on a synology with docker. The client works witout problems on my desktop pc with win 10 home.

Same for me. I noticed that the App uses ~20% CPU load at my computer and causes also the explorer to freeze partially.

Also I noticed that the App produces a substantial amount of log file (Some MB in a few minutes). From quick scroll through I found nothing regarding “errors” or so. Does the new Update need more CPU load for rescanning the sync-folder? For my instance I have a lot of files.

Same for me ! I downgrade the version to 3.3.5 and it’s OK

Would be great to provide logfiles to the developers with some more details about the setup (used OS version, use of VFS etc.) on github.com/nextcloud/desktop/issues

There is already a topic:

Seems to be an issue on the server side. I created a ticket.

If you have the same issue you might give a +1 or further information, if you found some.

Tried to start with “nextcloud.exe --logwindow”, it crashes before you can activate the logging.

In most cases - so my experiences - the might be something wrong in nextcloud.cfg, if the desktop-software crashes after starting.

Same to me, I installed the 3.3.6 version from here https://download.nextcloud.com/desktop/releases/Windows/ and the sync works again. Seems it has something to do with the new way of syncing the devices.

Interesting, you can also log to a file directly:
nextcloud.exe --logfile <file>

Tried --logfile several times but it writes nothing.
Perhaps interesting: When network is disconnected it is not crashing, after reconnection it crashes immediately. The crashed app has a continuing cpu-load of 30%.

So you can start the client without network and with logging enabled and the you can reconnect and let the client crash. If that still doesn’t work, I’d create a bug report on github.com/nextcloud/desktop/issues

Tried it this way, but it writes no logfile, don’t know why it is not logging.

Changed back to 3.3.6 without problems.

I tried installing today’s nightly built 3.4.50 20220107. No improvement either, switched back to 3.3.5 as I had this one locally available. However it would not start. Then downloaded and installed 3.3.6. Now works fine again.

Can confirm that reverting to 3.3.5 (haven’t tested 3.3.6) solves the sync problem for me with Truenas 12.0-U6.1.

For those of you replying with problems, are you using Windows 10 or 11? I’m on 11, and in my research, this might be a (if not the) cause.

I’ve just tried 3.3.5 and 3.3.6, and both do the same thing. I log in, create the sync, and 2 seconds later, Nextcloud just fails with nothing in the logs. Furthermore, there is literally NOTHING in my Nextcloud folder because I reinstalled EVERYTHING. So I really don’t know where else to look.

Did you try to rename/remove nextcloud.cfg before you install annother desktop client version?
C:\Users< username >\AppData\Local\Nextcloud

If there are wrong information in the cfg-file, the desktop client always will fail at startup.