WARNING Nextcloud Android client version 3.28.1 deletes user data Revert back to 3.28.0 (F-Droid)

WARNING Nextcloud Android client version 3.28.1 deletes user data Revert back to 3.28.0 (F-Droid).

Hope this is fixed soon in a new version in case some less technically inclined users might experience this and maybe lose files due to this…

See:

6 Likes

There is a bug, but nothing will be deleted. After a downswipe, for a actualisation, the size is back to normal. When i export the file, everything is as expected.

  1. ‘Everything is as expected’ is not true and also is not what the developer intended
  2. Nor does anyone know all the potential consequences for data loss as this functionality is utilized by dozens of 3rd party implementations.

Nevertheless, I think your title is a bit overdramatic, because no files are getting deleted. (on the server). :wink:

What we do know is that the files are no longer downloaded or made available locally on the phone through the Nextcloud app. However, files that were already downloaded are still available on the phone unless they are getting changed on the server, but even then they will only become unavailable on the phone and nothing will be deleted on the server.

EDIT 1: Already downloaded files seem to stay available on the phone, even if changes are made to them on the server, but the changes are not getting synchronized to the files on the phone.

What I don’t know is whether changes made by external apps on the phone to files that have already been downloaded are synchronised back to the server. If not, these changes might indeed be lost, but the unaltered version of the file will still be available on the server.

EDIT 2: I tested it, and the changes made on the phone to an already downloaded file seem to be synchronised back to the server (but not the other way around, see EDIT 1)

2 Likes

Same problem here, with the latest version 3.28.1 of NC on Android 14, I download the files (sometimes the app tells me that it can not be downloaded, sometimes app tells nothing). But it always shows me 0 bytes in the app and I can’t access the downloaded files from the app. The thing is that I see download activity in the network connection, so I deduced that I really downloaded the files.

The files are downloaded in the folder /Android/media/com.nextcloud.client/nextcloud/tmp, but then for the application to detect them they should be copied to /Android/media/com. nextcloud.client/nextcloud/myuser@myservername/… but although in this path the app creates the appropriate subfolders the files stays in the tmp subfolder and is not copied to the correct path for the app to detect them. If I manually copy downloaded files from tmp to myuser@myservername in the correct subfolder then the app detects them

I downgraded to version 3.28.0 and it worked, so I guess it’s a bug in copying the files locally.

1 Like

it would be good if you publish less updates but therefore more quality updates or updates that were tested.

both the nextcloud app and the nextcloud notes app had this week extremely critical bugs that made both apps unusable for important use cases and the only solutions were to install older vesions via fdroid.

2 Likes

devs announced a new version 3.28.2 as for yesterday which should fix the problem.
Does someone already have it installed?

3 Likes

I have just updated to version 3.28.2 and the synchronization is working again.

There are no new versions in Google Play and F-Droid yet, I updated it with the file nextcloud-30280290.apk from GitHub.

3 Likes

Still not being offered the 3.28.2 in the playstore, I downloaded the corresponding gplay-release apk directly from github.

I can also confirm that with this version, the downloads are working again :slight_smile:

2 Likes

i don’t get any new version on f-droid and gplay and therefore can not use nextcloud sync for the moment. hope for a new version in the next days

1 Like

At least 6 days since this very bad bug has been reported and not yet a fixed version of the app on the Play Store? This s is baffling, together with many other problems that seems to be ignored since ages… makes wonder if we should really continue push to use NC instead of moving on to other projects that do care more of their users.

2 Likes

Why is this post marked as a solution for this thread? 3.28.2 is not yet available in the Google Play store nor F-Droid…

If it wasn’t already bad enough…

Because the actual bug is fixed in 3.28.2, and an alternative option where you can download it until it’s officially released via F-Droid and Google Play has been suggested. That’s about as much as we can do in a community forum.

2 Likes

It’s a week later

3.28.1 remains the current version

Yes, we all know that. So what would be your suggestion for us the community to do about it?

I think spamming the thread by constantly repeating the same complaints and already known facts won’t speed up the release, but I could of course be wrong :wink:

Btw. Why don’t you just download the gplay-release-30280290.apk from here…?

3 Likes

Just got version 3.28.2 updated automatically via F-Droid.

1 Like

I can confirm that fixed an issue I had with KeepassDX, which couldn’t load the file because it was reported as 0 bytes.

1 Like

And also received the corrected 3.28.2 version via the Google Play Store

2 Likes