Update 13.0.1 to 13.0.5 stuck at "delete old files"

Hi the nextcloud community ! :slight_smile:

Nextcloud version : 13.0.1 (wanting tu upgrade to 13.0.5)
Operating system and version : Ubuntu 16.04 LTS
Apache or nginx version : Apache
PHP version : 7.1.18

The output of your Nextcloud log in Admin > Logging:

    [version] =>
    [versionstring] => Nextcloud 13.0.5
    [url] => https://download.nextcloud.com/server/releases/nextcloud-13.0.5.zip
    [web] => https://docs.nextcloud.com/server/13/admin_manual/maintenance/upgrade.html
    [autoupdater] => 1
    [eol] => 0
    [signature] => smxcnfDAiZHDgbJRf4qKOgpTHm2mPprJL4qD5B68uNh/p4QGrxWDt4aY1XDss5+V

2018-07-25T17:40:37+0200 2S0gIXNRah [info] storage location: /homepages/XX/dXXX/htdocs/nextcloud/data/updater-XXX/downloads/
2018-07-25T17:40:37+0200 2S0gIXNRah [info] end of verifyIntegrity()
2018-07-25T17:40:37+0200 2S0gIXNRah [info] endStep("6")
2018-07-25T17:40:37+0200 rGXCMWKuH8 [info] request to updater
2018-07-25T17:40:37+0200 rGXCMWKuH8 [info] currentStep()
2018-07-25T17:40:37+0200 rGXCMWKuH8 [info] Step 6 is in state "end".
2018-07-25T17:40:37+0200 rGXCMWKuH8 [info] POST request for step "7"
2018-07-25T17:40:37+0200 rGXCMWKuH8 [info] startStep("7")
2018-07-25T17:40:37+0200 rGXCMWKuH8 [info] extractDownload()
2018-07-25T17:40:37+0200 rGXCMWKuH8 [info] storage location: /homepages/XX/dXXX/htdocs/nextcloud/data/updater-XXX/downloads/
2018-07-25T17:41:14+0200 rGXCMWKuH8 [info] end of extractDownload()
2018-07-25T17:41:14+0200 rGXCMWKuH8 [info] endStep("7")
2018-07-25T17:41:14+0200 ZA5M9OEQ0L [info] request to updater
2018-07-25T17:41:14+0200 ZA5M9OEQ0L [info] currentStep()
2018-07-25T17:41:14+0200 ZA5M9OEQ0L [info] Step 7 is in state "end".
2018-07-25T17:41:14+0200 ZA5M9OEQ0L [info] POST request for step "8"
2018-07-25T17:41:15+0200 ZA5M9OEQ0L [info] startStep("8")
2018-07-25T17:41:15+0200 ZA5M9OEQ0L [info] replaceEntryPoints()
2018-07-25T17:41:15+0200 ZA5M9OEQ0L [info] replace index.php
2018-07-25T17:41:15+0200 ZA5M9OEQ0L [info] replace status.php
2018-07-25T17:41:15+0200 ZA5M9OEQ0L [info] replace remote.php
2018-07-25T17:41:15+0200 ZA5M9OEQ0L [info] replace public.php
2018-07-25T17:41:15+0200 ZA5M9OEQ0L [info] replace ocs/v1.php
2018-07-25T17:41:15+0200 ZA5M9OEQ0L [info] replace ocs/v2.php
2018-07-25T17:41:15+0200 ZA5M9OEQ0L [info] end of replaceEntryPoints()
2018-07-25T17:41:15+0200 ZA5M9OEQ0L [info] endStep("8")
2018-07-25T17:41:15+0200 K36ld3UHlj [info] request to updater
2018-07-25T17:41:15+0200 K36ld3UHlj [info] currentStep()
2018-07-25T17:41:15+0200 K36ld3UHlj [info] Step 8 is in state "end".
2018-07-25T17:41:15+0200 K36ld3UHlj [info] POST request for step "9"
2018-07-25T17:41:15+0200 K36ld3UHlj [info] startStep("9")
2018-07-25T17:41:15+0200 K36ld3UHlj [info] deleteOldFiles()
2018-07-25T17:41:24+0200 K36ld3UHlj [info] config sample exists
2018-07-25T17:41:24+0200 K36ld3UHlj [info] themes README exists
2018-07-25T17:45:16+0200 K36ld3UHlj [info] end of deleteOldFiles()
2018-07-25T17:45:16+0200 K36ld3UHlj [info] endStep("9")

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' =>XXX,
  'passwordsalt' => XXX',
  'secret' => XXX
  'trusted_domains' => 
  array (
    0 => XXX,
  'datadirectory' => '/homepages/XX/XXX/htdocs/nextcloud/data',
  'overwrite.cli.url' => XXX',
  'overwriteprotocol' => 'https',
  'dbtype' => 'sqlite3',
  'version' => '',
  'installed' => true,
  'mail_from_address' => XXX,
  'mail_smtpmode' => 'php',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_domain' =>XXX,
  'htaccess.RewriteBase' => '/nextcloud',
  **'maintenance' => false,**
  'theme' => '',
  'loglevel' => 2,
  'check_for_working_wellknown_setup' => true,
  'check_for_working_webdav' => true,
  'check_for_working_htaccess' => true,
  'logfile' => '/var/www/html/nextcloud/data/nextcloud.log',
  'log_rotate_size' => 10485760,
  'cron_log' => true,
  'filesystem_check_changes' => 1,
  'versions_retention_obligation' => 'auto, 60',
  'activity_expire_days' => 60,
  'updater.secret' => XXX',

The output of your Apache/nginx/system log in /var/log/____:

I couldn't find it

I did stuck first at 4th step “creating backup”
Then I went to the .config file and disabled the maintenance mode
Then disabled all apps, just let the update app running
Launched again and it stopped at “Delete Old Files” (print screen above)

And now when I reload the page it is written in a blanck page : “update in process”

I looked on internet but couldn’t find an answer
What would you be doing ?

Thanks for helping :slight_smile:

FYI I tried something I created another subject here : Installed 13.0.5 trying to copy previous data folder from previous installation via ftp (Filezilla)

But I would rather just fix the “delete old files” and just update from 13.0.1 to 13.0.5…

Anyone has an idea on how to do it ? :blush:

Would anyone have an idea on how to fix this ? :slight_smile:

Had the same problem updating from 13.04 to 13.06. I solved it by doing a manual upgrade following the steps in the manual (https://docs.nextcloud.com/server/13/admin_manual/maintenance/manual_upgrade.html) until step 8 because I’m on a shared server. Then I reloaded the page and it finished the installation.