Installed 13.0.5 trying to copy previous data folder from previous installation via ftp (Filezilla)

external_storage
update_problems
ftp
nc13
file_drop

#1

While waiting for an answer on my other subject : Update 13.0.1 to 13.0.5 stuck at "delete old files"
I tried another way :

I downloaded the 13.0.5 from the Nextcloud official website
Uploaded to my server via ftp (Filezilla)
And got Nextcloud 13.0.5 up and running like a charm !

I then tried to copy the data directory from my previous 13.0.1 Nextcloud installation, still on the server… But it appears on the ftp but not on the Nextcloud web interface…

I searched for answers, on inside and outside this forum, the answer seems to be the following… But I need help to do it… I am too new at all of this to do it by myself :

============
I also looked for the occ file on my computer : nothing
The same for the var/www/nextcloud file that is mentionned a lot in the previous answer : couldn’t find it

============
Do I really have to do all of this ?
I cannot juste cut and paste directories from one ftp file to another ?
Same with the database ? Just cut and paste ?

Thanks for your help :slight_smile:


Update 13.0.1 to 13.0.5 stuck at "delete old files"
#2

Would anyone have an idea on how to fix this ? :wink:


#3

i think there is no other way than doing it as described.
if the “old” data is already in the datadir of the new install, check the perms of that - likely this data still belongs to the ftp-user (or whover transferred it to your server), but is HAS TO be owned by the webserver-user (most likely www-data. do sth. like chown -R www-data:www-data /new/data/dir
Assuming the users are still the same, transfer the ownership of the “new” files as descibed above. since the
occ-command is not in anyone’s regular path but in nc’s install-dir (most likely /var/www/nextcloud ) you have to execute it with php and its full path and as the webserver-user; eg
sudo -u www-data /usr/bin/php /var/www/nextcloud/occ files:scan
(short explanation:
sudo -u www-data executes the following cmd as www-data
/usr/bin/php is the full path to the programm that executes the folloing cmd (script)
/var/www/nextcloud/occ is the script that is executed
files:scan are params to that script )
GOOD LUCK!