Test our new work-in-progress upgrader script

Try this script (or run the lines manually)

`#!/bin/bash

chown -R http:http /volume1/web/owncloud/
chown -R http:http /volume1/web/owncloud/apps/
chown -R http:http /volume1/web/owncloud/config/
chown -R http:http /volume1/web/owncloud/themes/
chown -R http:http /volume1/owncloud/

chown http:http /volume1/web/owncloud/.htaccess

find /volume1/web/owncloud/ -type f -print0 | xargs -0 chmod 777

find /volume1/web/owncloud/ -type d -print0 | xargs -0 chmod 777
find /volume1/owncloud/ -type d -print0 | xargs -0 chmod 777

chmod 777 /volume1/web/owncloud/.htaccess`

This worked for me.

This also worked for me, just had to change the commands to:

chown -R ncadmin:ncadmin /var/www/nextcloud/
chown -R ncadmin:ncadmin /var/www/nextcloud/apps/
chown -R ncadmin:ncadmin /var/www/nextcloud/config/
chown -R ncadmin:ncadmin /var/www/nextcloud/themes/

chown ncadmin:ncadmin /var/www/nextcloud/.htaccess

find /var/www/nextcloud/ -type f -print0 | xargs -0 chmod 777
find /var/www/nextcloud/ -type d -print0 | xargs -0 chmod 777

chmod 777 /var/www/nextcloud/.htaccess

I thought I already have .52 but that was a mistake, I only had .51.
So I could also test the Updater. After setting the permissions everything worked fine without an issue.

I hope you’ll release future updates on time for the updater.

something I did not mention properly. I’m getting the following error after using the latest updater and adding the config bit

Fatal error: Uncaught Symfony\Component\Process\Exception\RuntimeException: The Process class relies on proc_open, which is not available on your PHP installation. in /www/htdocs/123456789/domain/next.domain.net/cloud/updater/vendor/symfony/process/Process.php:144 Stack trace: #0 /www/htdocs/123456789/domain/next.domain.net/cloud/updater/src/Utils/OccRunner.php(45): Symfony\Component\Process\Process->__construct(‘php /www/htdocs…’) #1 /www/htdocs/123456789/domain/next.domain.net/cloud/updater/src/Utils/OccRunner.php(56): Owncloud\Updater\Utils\OccRunner->run(‘config:list --p…’) #2 /www/htdocs/123456789/domain/next.domain.net/cloud/updater/src/Utils/ConfigReader.php(106): Owncloud\Updater\Utils\OccRunner->runJson(‘config:list --p…’) #3 /www/htdocs/123456789/domain/next.domain.net/cloud/updater/src/Utils/ConfigReader.php(50): Owncloud\Updater\Utils\ConfigReader->load() #4 /www/htdocs/123456789/domain/next.domain.net/cloud/updater/src/Control in /www/htdocs/123456789/domain/next.domain.net/cloud/updater/vendor/symfony/process/Process.php on line 144

Keep in Mind, update from .50 to .51 was fine

i have tried it yesterday again but the updater did not mention that there is a possible update.

so i tried ‘updater.release.channel’ => ‘daily’, in my config but if i login in my owncloud 9.0.2 and go to the admin section
the update channel are still on stable. this shouldn’t be right?

i would like to upgrade to have the latest security fixes. any idea how i can get it to work?

Not sure if your running on a vm or not, but you could trying taking a snapshot on vmware if u are. Or try using superduper to copy the entire machine as an iso

I try to use the updater. The updater tells me there is an new Daily build available, but when I Click Update it tells me that I have the latest Version… Any idea?

.52 is the latest so the updater is wrong. Can’t help fixing it thought

If you use the daily channel it should work. Daily is always coded as Version 100 iirc

i test the updater and run in a timeout i think. so it stuck by step four.

the error.log shows:

[Fri Jul 15 21:30:45.235583 2016] [authz_core:error] [pid 11851] [client 94.222.45.113:47662] xxxx: client denied by server configuration: /var/www/virtual/webxxx/owncloud/htdocs/data/.ocdata

after i fixed the permissions i will start the updater again and it shows:

Step 4 is currently in process. Please reload this page later.

and i can not restart the updater again. how can i resolve this?

thanks Micha

Hello, just tried to use the updater script to update to 9.0.53, but the page is saying that 9.0.52 is the current version.

1 Like

I uploaded the updater script, and add the updater.server.url' => 'https://updates.nextcloud.org/updater_server/',' to my config.php, but nothing happen.

I’m currently on 0.9.52.

How can i reset the updater as it stopped working on extracting with the message “Step 6 is currently in process. Please reload this page later.”

under data is a directory begins by me with updater-oca*** in this is a file .step
this can be deleted.

Thank you, now i was able to see the Message: Extracting
Parsing response failed. Any Idea?

did someone have success with 9.0.53?

1 Like

This doesn’t seem to work. I get redirected to files.

I’m testing with an instance on 9.0.52 and there is no update being offered.

Hello
I get the following message …
What can I do?

-> https://example.com/updater/

updater.secret is undefined in config/config.php. Either browse the admin settings in your Nextcloud and click "Open updater" or define a strong secret using
php -r 'echo password_hash("MyStrongSecretDoUseYourOwn!", PASSWORD_DEFAULT)."\n";'
and set this in the config.php.

I have no root access (Shared Hosting).
Nextcoud 9.0.53

Call the Updater from within nc. Login, browse Administration and find Updater there

This omits the neccessity of dealing with the Updater Secret manually

Updater
Your version is up to date.
Update channel: stable
You can always update to a newer version / experimental channel. But you can never downgrade to a more stable channel.

no settings for secret manually

config.php
’updater.server.url’ => ‘https://updates.nextcloud.org/server/’,
‘updater.release.channel’ => ‘stable’,
‘has_internet_connection’ => true,