Updater download path

Hey,

just experienced a strange bug while I was updating my instance. I got the same message as @Crosant
Unfortunately his post never got an answer…

Here is basically the error in the updater:


When I hit the “Retry update”-Button I get the same message, nothing changes.

So I checked the updater.php, if I could find a mistake, because I did recently move my data-path into a new dir, cause of this


So I moved it back to the old place (and of course changed the config-value), but nothing changed and couldn’t find anything wrong in the updater.php.

Another strange behaviour is when I for example try to go back in browser:

The crossed-out path is just my domain, so the “/nextcloud/path”-part is missing.

hey again…

in the meanwhile, I thought: fuck off, I just do it from scratch again and downloaded the 11.0.1 version, unzipped it and ran the wizard and in the wizard I got an error that my new data-path is not possible due to rights problem. I tried to fix it by changing the rights like chmod 776 (was 770) recursive to the folder, but the installer still had the same problem.

So, I decided to move the data back where I already had it for almost a year running… After the successfull login, I started the updater to 11.0.2 version and got stuck at the same message (“Move new files in place: Parsing response failed”) again!

This is weird to me, because I thought the problem is referenced to the data-path, but it seems like there is something completely different going wrong…Unfortunately the updater.log isn’t really helping, but here a link. maybe someone else can see something special: http://pastebin.com/LskvJUru

yeah, of course I could install the 11.0.2 directly, but to be honest: I just don’t want to have next time the same problem again… :wink:

UPDATE:
Well now I even tried to install an untouched instance (with default-values, sqlite-db, default-path,…) and tried to update and again, the same error (step 9: moveNewVersionInPlace())!

What’s going on? I don’t believe that the updater is defect, but I don’t know why it doesn’t work anymore… any ideas?

Another Question is, what is the supposed action in this case? Because the “Retry update”-button didn’t work and I didn’t see any rollback possibility?