Test our new work-in-progress upgrader script

If you use the daily channel it should work. Daily is always coded as Version 100 iirc

i test the updater and run in a timeout i think. so it stuck by step four.

the error.log shows:

[Fri Jul 15 21:30:45.235583 2016] [authz_core:error] [pid 11851] [client 94.222.45.113:47662] xxxx: client denied by server configuration: /var/www/virtual/webxxx/owncloud/htdocs/data/.ocdata

after i fixed the permissions i will start the updater again and it shows:

Step 4 is currently in process. Please reload this page later.

and i can not restart the updater again. how can i resolve this?

thanks Micha

Hello, just tried to use the updater script to update to 9.0.53, but the page is saying that 9.0.52 is the current version.

1 Like

I uploaded the updater script, and add the updater.server.url' => 'https://updates.nextcloud.org/updater_server/',' to my config.php, but nothing happen.

I’m currently on 0.9.52.

How can i reset the updater as it stopped working on extracting with the message “Step 6 is currently in process. Please reload this page later.”

under data is a directory begins by me with updater-oca*** in this is a file .step
this can be deleted.

Thank you, now i was able to see the Message: Extracting
Parsing response failed. Any Idea?

did someone have success with 9.0.53?

1 Like

This doesn’t seem to work. I get redirected to files.

I’m testing with an instance on 9.0.52 and there is no update being offered.

Hello
I get the following message …
What can I do?

-> https://example.com/updater/

updater.secret is undefined in config/config.php. Either browse the admin settings in your Nextcloud and click "Open updater" or define a strong secret using
php -r 'echo password_hash("MyStrongSecretDoUseYourOwn!", PASSWORD_DEFAULT)."\n";'
and set this in the config.php.

I have no root access (Shared Hosting).
Nextcoud 9.0.53

Call the Updater from within nc. Login, browse Administration and find Updater there

This omits the neccessity of dealing with the Updater Secret manually

Updater
Your version is up to date.
Update channel: stable
You can always update to a newer version / experimental channel. But you can never downgrade to a more stable channel.

no settings for secret manually

config.php
’updater.server.url’ => ‘https://updates.nextcloud.org/server/’,
‘updater.release.channel’ => ‘stable’,
‘has_internet_connection’ => true,

Iirc the update Server URL is wrong and should be /updater_server/ I think

Documentation
https://docs.nextcloud.org/server/9/admin_manual/configuration_server/config_sample_php_parameters.html?highlight=config

Check if Nextcloud is up-to-date and shows a notification if a new version is available.
'updater.server.url' => 'https://updates.nextcloud.org/server/',

what is right?

I don’t know how current the documentation is, but I remember there was a discussion on github about the /server/ link being wrong.

ping @LukasReschke A word of wisdom please :smiley:

How close to shipping with a release is this script? I ask because I quite like my current install and don’t feel like spinning up a test for the sake of testing upgrades… so I’m still updating manually every time.

The first step will be to make it available as an app for existing installs and it should be part of NC10.

2 Likes

I tried to switched the channel to daily and reloaded the page.
I got the message that there is a new version available.
I switched back to stable and reloaded and no message.

So i can’t upgrade from .52 to .53

That make kind of sense, doesn’t it?

Other than that you are all right: the updater script is far from stable atm. Which is why, the devs are working hard on improving it :slight_smile:

Sorry, that was just a typo.