[Solved] [NextcloudPi] Issue with Berryboot Install of NextcloudPi

Hey guys,
sorry for posting yet another issue…
I received my 375GB WD Pi Drive today and want to use it for different projects. Therefore I thought Berryboot was the way to go. I followed the wiki guide (https://github.com/nextcloud/nextcloudpi/wiki/How-to-install-NextCloudPi-on-an-external-drive-using-Berryboot.), which is great!
Unfortunately after copying the NCP-image to the drive and first booting it up, I get an timeout error.
First these lines are displayed:
A start job is running for dev-disk-by\x2dlabel-boot.device and
A start job is running for dev-serial1.device
After 90 seconds I see:
Timed out waiting for device dev-disk-by\x2dlabel-boot.device

Any suggestions what is wrong here?
I’m using a Raspberry Pi 2 Model B, NCP Image NextCloudPi_12-04-17_berryboot.img, Berryboot berryboot-20170527-pi2-pi3.zip

The following screens are displayed afterwards…

let’s summon @OliverV for this

Abroad untill monday, when I ll be able to look into it,…

Is your Pi a single or multi core?
The berryboot version you used is for multi core only.

For single core Pi download the other version of berryboot here

As mentioned, I’m using the Pi 2 Model B, so it should be a quadcore… Thanks for looking into it!

Sorry removed my question, as jonaskor has no system running, no usable shell.
I am going to test run that image again tomorrow to see if it boots correctly, it should find and use a partition with label “BOOT”.

1 Like

Hey there,

I have the very same issue here with a RPi3 quadcore and a 375GB WD PiDrive.
I can not manage to setup NCP, neither via Berryboot nor via NOOBS-installer.
To eliminate some possible reasons, I tried…:

  • using different berryboot-versions (general-image “berryboot-20170527-pi2-pi3.zip” or wd-image “berryboot-20160130-r2.zip”
  • installation without network attached (-> no update) and with network (->auto update)
  • waiting for the drive’s background-formating to be finished (-> zzzZZzzz) before I went on with the installation
  • booting with or without the USB-stick (from where the NCP-image was loaded into Berryboot) attached

Thanks a lot in advance for your effort.
BTW: Terrific project!!

Thanks for reporting @elpollodiablo and @jonaskor

I’ve checked booting latest image for berryboot and it works fine. I cannot reproduce your errors.

Can you try booting/installing the Nextcloud11 image provided from berryboot’s featured tab, and let us know results?

Doesn’t seem to be a problem:

Thanks jonaskor. This confirms you have berryboot installed and operational. So must be image you are using.
Please check and post/confirm md5sum of downloaded image. It should be:

$ md5sum NextCloudPi_12-04-17_berryboot.img
9e16d50d58ac4dc8336c9f201f669f28 NextCloudPi_12-04-17_berryboot.img

I can confirm that md5sum is correct… 9e16d50d58ac4dc8336c9f201f669f28 …

Possibly might need to add :


in cmdline.txt

How did you format your micro-sd?
How did you format your external drive?

Adding datadev=iscsi didn’t change anything (I guess its not necessary to do this before first-boot of berryboot?)…

I formatted the micro-sd in Windows and the harddrive through berryboot… didn’t show any errors during format…

Any other idea what I could try? I still could just use the harddrive as external storage and do a normal ncp-config via micro-sd, but it would be awesome to have extra storage available for raspberry-projects in the future…

this might be useful for a list of options

Just figured out how to get the berryboot-console running (username: root, no password). Does this help?

/etc /fstab seems to look like this (I’m new to Linux, so I might be wrong here, but maybe it helps :smiley: ) :

yes it might!
paste content of fstab please

cat /etc/fstab

NCP looks for LABEL=boot to mount /dev/mcblk0p1 to /boot
It is why the line is or should be present and uncommented (no#) in fstab
Berryboot-console has no problem locating it. NCP does.
So maybe need to add LABEL=boot to /dev/mcblk0p1

You could also edit fstab and replace the LABEL=boot by PARTUUID=“7008e3e3-01”

sudo nano /etc/fstab

cat /etc/fstab shows what I posted in the screenshot above… There doesn’t seem to be any boot entry at all…

Your screenshot is/must be something else, here’s what my terminal input and output looks like:

:~ $ cat /etc/fstab
#proc /proc proc defaults 0 0
LABEL=boot /boot vfat defaults 0 2
#PARTUUID=37665771-02 / ext4 defaults,noatime 0 1
#a swapfile is not a swap partition, no line here
#use dphys-swapfile swap[on|off] for that

On berryboot-console location of fstab looks to be /mnt/etc/fstab
so to edit use:

sudo nano /mnt/etc/fstab

to view:

cat /mnt/etc/fstab

In fstab anything with a # in front is read as a comment, not executed.

This is the output I get trying different commands…

ls /mnt only shows me the directories data, images, lost+found and shared

Thanks for hanging in there, forgot you only have very basic console. Nano not included and sudo not required as you’re already root.
Sorry to say, at a loss as to make further suggestions to find resolution to this issue.
Have you tried the whole process again, start from scratch to see if you can reproduce this error?