[Solved] [NextcloudPi] Issue with Berryboot Install of NextcloudPi

thanks for your patience guys… yes, the key here is to be able to reproduce, or understand at what point things are going south

I just started from scratch several times. Always the same timeout-error…

What I did:

  • tried different Berryboot-versions (berryboot-20170527-pi0-pi1-pi2-pi3 andberryboot-20170527-pi2-pi3)
  • tried different harddrives (WD Pi Drive 375GB and a 600GB 2.5" drive)
  • checked md5sum of NextCloudPi-Berryboot-Image (NextCloudPi_12-04-17_berryboot.img)

Berryboot works fine in all setups, no errors during installation, also installing other operation systems (Kodi, Debian, Nextcloud 11) and running them works without problems.

So what else could it be? :thinking:

I know, it doesn’t help, but I can confirm: Berryboot is working fine - and the harddrive as well. Other images (including NC11) are being installed correctly and work from the usb drive. Only NCP still refuses working.

really weird… can somebody confim that it does work for them? so we can find out the differences

That would be interesting. And if someone with a running berryboot-ncp could post the output of cat /etc/fstab of the berryboot console (opened in berryboot menu - more options - username: root, no password) we could see, if its any different to my “fstab” content…

@OliverV, were you referring to /dev/mcblk0p1 or to /dev/mmcblk0p1 (with double m) ?
Because only the later one is showing up using ls /dev in berryboot console…

Tried to edit typo, couldn’t, should be /dev/mmcblk0p1 with 2m’s

I does work for me, as mentioned

Did so yesterday and it works fine.

Could you post the output of cat /etc/fstab of the berryboot console to see, if its any different to my “fstab” content?
The error seems to be related to fstab, as far as I understand google-search-results…

:~ $ cat /etc/fstab
proc /proc proc defaults 0 0
PARTUUID=09efbd88-01 /boot vfat defaults 0 2
PARTUUID=09efbd88-02 / ext4 defaults,noatime 0 1
#a swapfile is not a swap partition, no line here
#use dphys-swapfile swap[on|off] for that
UUID=d549f07b-1751-40c1-bafb-3ca162605aca /media/user/usb1t ext4 rw,users 0 0

df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 29G 2.4G 25G 9% /
devtmpfs 484M 0 484M 0% /dev
tmpfs 489M 0 489M 0% /dev/shm
tmpfs 489M 19M 470M 4% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 489M 0 489M 0% /sys/fs/cgroup
/dev/mmcblk0p1 42M 21M 21M 51% /boot
/dev/sda1 917G 15G 856G 2% /media/user/usb1t
tmpfs 98M 0 98M 0% /run/user/1000

NextCloudPi v0.41.13 is up to date

Can you start the NC11 to see what fstab and df show?

Unfortunately I don’t know the default login/password to get access to NC11 berryboot version (and couldnt find it on the internet either). If you can tell me what it is I can post the output :wink:

I think it’s the default:
user=pi
passwd=raspberry

Didn’t work…

Can you be litlle more specific, its not possible to investigate : Didn’t work!
A screenshot possibly?

The second screenshot in #8 show the login screen. I tried different “standard” password combinations and searched the web…

Edit: Sorry for the confusion, username pi and password raspberry work (only difficult to type as the german keyboard layout changes y and z …)!

This is the Output of cat /etc/fstab under Nextcloud 11 (featured on berryboot):

Okay, I just found the chroot_image command for the berryboot console. It looks quit useful. I mounted different operating systems and used cat /etc/fstab to be able to compare the diffences.
Here are the results:

NextcloudPi-Image

Nextcloud 11 (featured)

and DiepPi (Debian Jessie OS)

Is this any help at all?

I got it to work!!! :star_struck::star_struck::star_struck:

I changed the fstab using vi according to the fstab of NC11. And that worked perfectly! No more timeout error! So I guess this is the place to edit :wink:

Here are the screenshots including my fstab file :slight_smile:
Hopefully this helps to prevent this error in the future!
Keep me up to date!

1 Like

good job!:tada::tada:

:star_struck:
Glad you got it to work, but still puzzled tho, as how this happened.