[NextCloudPi] [Berryboot] Is there a HowTo for expanding the FileSystem?

Is there a HowTo to expand the Filesystem? Using raspi-config I get a message because no SDcard or something like that.


Honestly, this isn’t a lot of information to go off. Berry Boot stores all of the installed distributions within just one partition, unless you partitioned the SD card a specific way before installing Berry Boot. Assuming you let Berry Boot use up the entire SD card, it should have full access to the available storage. See this thread on Stackoverflow and search the web for more info on expand filesystem Berry Boot.

The most common way people free up space on NextcloudPi is by adding a usb thumb drive or hard disk they can mount under nextcloudpi-config to use as general storage in place of the SD card.

1 Like

have you tried searching the forum for berryboot as well?

and of course @just is right by letting you know

anyways… maybe this article is related to your problem? [Solved] [NextcloudPi] Issue with Berryboot Install of NextcloudPi

Sorry, for me it was clear that the SDcard is only used during booting the device. So I assumed that every one knows that I mean the Filesystem of the HDD.

root@nextcloudpi:/home/pi# df -l
Filesystem 1K-blocks Used Available Use% Mounted on
dev 412528 0 412528 0% /dev
none 153577348 3755036 141997940 3% /
tmpfs 423488 0 423488 0% /dev/shm
tmpfs 423488 11076 412412 3% /run
tmpfs 5120 4 5116 1% /run/lock
tmpfs 423488 0 423488 0% /sys/fs/cgroup
/dev/mmcblk0p1 42136 39913 2223 95% /boot
tmpfs 84696 0 84696 0% /run/user/1000
root@nextcloudpi:/home/pi# fdisk /dev/sda2

Welcome to fdisk (util-linux 2.29.2).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

Device /dev/sda2 already contains a ext4 signature.
The signature will be removed by a write command.

Device does not contain a recognized partition table.
Created a new DOS disklabel with disk identifier 0xe4498c2f.

Command (m for help): F
Unpartitioned space /dev/sda2: 148.9 GiB, 159906619392 bytes, 312317616 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Start End Sectors Size
2048 312319663 312317616 148.9G

Command (m for help): q

For me it looks like an unused space of 140GB what I like to use. Since I have also VM Version, I have seen that it is quite tricky to expand the Filesystem even when I have Gparted at a life CD und it ended up in frustration because every thing I have found in iNet didn’t work.
So this is the second time I am at this point

at the end of the day, raspi-config does something like

sudo resize2fs /dev/sda1

but the device names are different for berryboot, because it is using an HDD and not an SD card, so raspi-config doesn’t work, but doing the command manually should work.

1 Like