[SOLVED] Error while updating

Hi there,

I have installed Nextcloud 11.0.1 on a small hosting server where space is scarce… very scarce, indeed… Which is fine since I only use it as calendar and contacts.

So I would like to know if I can safely delete some content in /data/updater-random_letters/backups/nextcloud-11.0.0.10 … especially the content of /apps /core and /3rdparty

Thanks for your advice.

S.

Looks for me like the default backup before running the upgrade. So normally you can delete them, in such cases I first keep a local copy just to make sure if something breaks that I still have them.

2 Likes

Good idea. I’ll try this. Thanks for the advice.

Well, maybe that wasn’t such a great idea, after all… When I tried to update to 11.0.2, I got a “Parsing response failed. Step 4 is currently in process. Please reload this page later” error in step 4 : creating backup.

I managed to get back to original state by renaming /data/updater-ocrxxxxx/.step to OLD.step, then manually editing out my config file : ‘maintenance’ => true, to false and deleting the ‘updater.secret’ => ‘$2y$10$cSOexx……xxx’ line.

I will restore what I have removed (as mentioned in the first post) and report back.

Meanwhile, if you have any idea of anything else that might have caused this, I will gladly read it :wink: (bearing in mind that I have no access to ssh or root access, since I am on a shared hosting)

Thanks

1 Like

Looks like a status message couldn’t be processed correctly. @nickvergessen

@MorrisJobke as updater expert

Restoring previously deleted files and folders in /data/updater-ocrxxxx/backups/nextcloud-11.0.0.10 did not resolve the issue.

I still get the same error message.

If this release is important (security-wise) maybe I can try to update manually… any post I should read in order to do this successfully?

As stated before the backup dir is only used if the old state needs to be recovered. Feel free to delete after the update went successful and you notice no problems.

The .step file is usually removed during the occ upgrade or the web upgrader (the updater replaces code and the upgrader runs the actual migration steps of the new code).

So if you have problems with the updater just remove the whole updater-oc… directory and the updater doesn’t know anything anymore about any previous updater runs (which is fine if you don’t need the backed up code).

1 Like

Ok then. I will try that. But I fear that he mishap that occurred in step 4 (creating backup) might happen at a later stage, like copying new files… Oh, well, I will try anyway, and restore backup if it fails.

I’ll keep you posted. Thanks for your answer.

No change. Keeps failing at step 4.

Nothing changes even if I wait 30 minutes before reloading page. :cry:

Did you pressed the Retry button?

Could you open the web developers tools during the upgrade and check the last request (once this happens) and send us the response. It seems that there is something going wrong while creating the backup.

1 Like

Yes I did press retry, to no avail.

I am no tech and I don’t know where in the dev tools I should search. I use Firefox, here are the tabs I have

That is the correct tab. Now press “retry” or start the updater again. Because this tab is only filled, when the dev tools are opened.

Not sure what you’re looking for… I screencapped this, as it was the only thing that seemed of any interest… (This after the error message appeared)

I need the response tab. Best would be of all of the previous ones as well. (so en-tetes and reponse)

Here they are



Hi there,

I take the liberty to up this post since I still cannot update my Nextcloud instance.

Nextcloud version: 11.0.1
OS: Debian / shared hosting
Apache : 2.4.10
PHP version: 5.6.30
All details there http://ismayotte.lautre.net/www/phpinfo.php

Thanks for any hint you can provide me with…

@lukasreschke Do you have any idea, why this is happening?

@Pourrito Could you maybe show the same screens of the other POST requests to index.php?

I’m afraid I don’t know what you mean. :sweat:
How do I do that ?

I’m having the same issue with update from 11.0.2 --> 11.0.3 using the updater.

First I get a failure message:

Create backup
Parsing response failed. 500 Internal Server Error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@next.awequest.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Then when pressing “retry” I get the following:

Parsing response failed. Step 4 is currently in process. Please reload this page later.

Resetting seems to involve:

  1. Getting out of maintenance mode: open /config/config.php and change the line
    'maintenance' => true,
    to
    'maintenance' => false,
  2. Removing the file: /data/updater-{rand-string}/.step

This allows me to try the updater again, but it has failed at least 3 times. There used to be a manual way to backup and proceed on earlier versions. Is that still an option? Obviously the direct method via the browser would be best, but I’m open to alternatives.

Running no shared hosting environment (which could be the cause of issues, uncertain). Happy to provide whatever I can to troubleshoot.