Reset password ncp

I’m trying to access https://host/index.php/login but I don’t remember the password of ncp. in the nextcloudpi container logs there is this message: "Could not send password reset email: Could not send reset e-mail since there is no email for username ncp"

I honestly don’t remember the password. I have one, but that should be to access https://nextcloudpi.local:4443/ (by the way, I can’t access this address). So the solution is to set an email address for the ncp user? if so, how do I do it?

I don’t use nextcloudpi, but may this can help to change your password: https://docs.nextcloud.com/server/18/admin_manual/configuration_user/reset_admin_password.html

1 Like

Thanks a lot, I did it! But I didn’t understand why I can’t access https://nextcloudpi.local:4443/
What is this address for?

that’s the access to your ncp-webgui. it’s simlar to the one you get when you ssh’ing to your instance and do sudo ncp-config - just from a browser

the browser gives me ERR_NAME_NOT_RESOLVED
instead I can access https://host/index.php/apps/files/?dir=/&fileid=2

try your.local.IP.here:4443 rather than nextcloudpi.local:4443

the page loads for about a minute and then returns an error from the squid proxy

ummm… i dunno about squid proxy… and how it got installed :wink:

but here’s another hint of how to reset your ncp-password for your ncp-webgui.

ssh to your instance.

sudo nc-config

chose nc-passwd

enter a new one.
and thus you should be able to access your ncp-webgui under the given address

root@omv:~# docker exec -ti nextcloudpi sh
# sudo nc-config
sudo: nc-config: command not found

awww. i’m lost in terms of docker. maybe @OliverV would know more here?

I also ask the help of @Giuseppe

I have no idea how ncp works, but you can try this…

docker exec -ti nextcloudpi php -f /var/www/nextcloud/occ user:resetpassword your_username

For ncp docker run:

docker exec -it nextcloudpi ncp-config

To view or set password
for ncp web:4443 CONFIG>nc-password
for nc web use CONFIG>nc-admin

2 Likes
Running nc-passwd
password updated successfully
Site ncp already enabled
Site nextcloud already enabled
Site ncp-activation already disabled
Done. Press any key...

https://nextcloudpi.local:4443/ still gives me ERR_NAME_NOT_RESOLVED

Jimmy already suggested using the IP:4443 instead.
Did you try it?

Yes, ERR_TUNNEL_CONNECTION_FAILED
Could this be because I haven’t done any port forwarding?

:4443 is only available from your LAN
it just will not accept connections from WAN
So no port forwarding required for :4443

1 Like

okay, thanks for the info.
so why can’t I access the address?

because it’s not resolving. use the ip address.

yes, I also used the IP address