Remove the possibility to reset password for users

Remove the Reset Password from the login Page :thinking:

Nextcloud version : 13
PHP version : 7.1

I’ve altered the personal setting file so they can only change the language but i would like to know where to find the index.php to remove the reset your password link !

(I know that i will need to do again these change after updates)

The big downside of Nextcloud is the lack of user permission… :worried:

Thank you all !

Some thing that might work:

put this into your config/config.php:

 * If your user backend does not allow password resets (e.g. when it's a
 * read-only user backend like LDAP), you can specify a custom link, where the
 * user is redirected to, when clicking the "reset password" link after a failed
 * login-attempt.
 * In case you do not want to provide any link, replace the url with 'disabled'
'lost_password_link' => '',

Especially the ‘disabled’ function:

'lost_password_link' => 'disabled',

Depending on the use case, the guests app could be interesting (not yet fully tested and implemented):


‘lost_password_link’ => ‘disabled’

Life Saver ! thank you so much !

1 Like

Worked perfectly. Thank you!!

1 Like

Hi @Etiennehb,

I tried your tipp using ‘lost_password_link’ => ‘disabled’
that does not seem to work in NC 14.0.1
Instead I see the clickable link:


@Etiennehb Hi

This solution is also not working for me, adding:
‘lost_password_link’ => ‘disabled’
to config.php only append disabled in URL like this
The forgot password? link is still active.

‘lost_password_link’ => ‘#’ at least looks better for now since ‘disabled’ does not remove the link.

How can I completely remove the link from the front login page without the changes removed with the next update?

1 Like

There is already a bug report for NC 14:

To add to the discussion.

I can see that this was fixed on 20/11/18.

And this continues to work on Nextcloud 18.0.1 .

Wanted to disable this func with NC 19.0.1 => Not working

1 Like

I’m sorry, I was mistaken. It did work.
It’s just for some reason, the config.php file took a while to be taken into account…
Case closed : 'lost_password_link' => 'disabled', works in NC19.0.1