Reminders.app does not display NC tasks

Hi,

I trying to use the Reminders app of my mac to add tasks however, it doesn’t show NC tasks.

I correctly configured the account (with CalDAV):

The calendar works, but not the Reminders app:

Capture d’écran 2020-11-17 à 00.37.21

I configured my instance according to the doc:

I use Træfik as a reverse proxy.
My nextcloud is dockerised, version 20.0.1

I use cloudflare as a DNS resolver and I use their SSL/TLS encryption in Full (strict) mode.

I would like to point out that it works well with a task app on my android with DAVx5.

Any suggestions ?

The problem occure with:

  • MacOS: 11.0.11 (Big Sur)
  • Reminders: 7.0 (2185)

Note on iOS (via the macOS Simulator) I doesn’t works, I get an SSL error.

If I use let’s encrypt, I can see and edits my tasks with Reminders on iOS but not on MacOS.

First you can try to use the search function of this forum to find an answer on your question:

https://help.nextcloud.com/search?q=macos%20task%20sync

Next you can ask aunt G. for help. Although the following blog post is in German language you should be able to read it using e.g. Google translator. I think it describes your problem, which is mainly caused by an iOS software change, and might help you understanding/fixing the problem:

I also found this thread in English language in the Apple forum:

Yep, @j-ed, I already take a look before posts. Unfortunatly none of the proposed solutions worked.

To be clear, my problem is not related to iOS, it’s about Mac OS.

I tested with several other calDav solutions (radical/mailu/,fruux, etc.), none of them work.
I suppose a SSL problem. But I can’t figure out if it’s only that.

Based on the cited German blog post, the problem appears on both systems, iOS AND MacOS. The article indeed refers to a certificate issue:

Apple has straightened there certificate policy for server certificates on iOS 13 and macOS 10.15. A certificate need to fullfil the following requirements to be accepted:

  • The certificate key length need to be at least 2048 bits.
  • The certificate need to be signed with a SHA-2 certificate key.
  • The DNS name of the server need to be part of the SAN extension of the certificate (It isn’t allowed to put the DNS name in the CommonName field - I personally don’t believe that)

For certificates which have been created after September 1st 2019 this requirement is also needed:

  • The certificate need to contain an EKU extension with id-kp-serverAuth OID.
    (Don’t aks me what this is)
  • The certificate validation couldn’t be more than 825 days.
    (Source: https://support.apple.com/de-de/HT210176)

I have the same issue. Calendar and Tasks sync without issue on iOS 14.2. On macOS 11.0.1 (Big Sur), Calendar syncs, but tasks do not. It worked fine on Catalina.

I’m having the exact same issue as psychotic. Everything was working fine on Catalina, everything still works fine on iOS 14, but in Big Sur only Calendar will sync, Reminders won’t update at all.

Instead of using the Cloudflare SSL certificate, I have tried with a let’s encrypt.

This way, it works on iOS, but still not on MacOS Reminders.app
There must be a bug in the application (Reminders.app), or they stopped supporting CalDAV, because I have tested with several CalDAV providers/solutions, without success.

I’m also pretty sure that this is not a certificate issue and we mixing up two things here.
The problem described by j-ed was indeed through the upgrade to catalina as Apple changed the allowed connections.

Now, I think we face a new issue. I have the same problem as Heziode.
The syncronization works well on iOS 14 (contacts, reminders and calender) and also on Mac OS Big Sur but only for calendar and contacts. As described, the reminders app shows the headline of the servername but doesn’t sync the reminders.

(The weird thing is: during the first setup all tasks were synced one time with Big Sur. But suddenly the syncing stopped and as I deleted and readded the CalDav-Account, reminders doesn’t show up at all)

So to be clear again. This is not an iOS issue and not the same certificate issue as it was during the upgrade to Mac OS Catalina. I’m using Let’s Ecnrypt certificates without any problems.

No ideas for now. I think the same issue is described in this post:

Hope there will be a solution.

Greetings,

plate

I have tried with several tasks services that uses CalDAV. All services doesn’t works with the Reminders.app

I have reported the issue to Apple.
To try to push things a little bit you can also try to make a bug report.

Did you use the Apple Feesdback-Assistent. As I saw, one have to have a developer account the use this assistent.

Nearly every upgrade there is a problem with the reminders while calendar and most of the time contacts works well. Thats very annoying.

Greetings,

plate

Nope,

I have just called the telephone support, explained the problem to the assistant. After a while, it understand that this problem is beyond its competences, so it transmits to it’s “n+1”, re-explain the problem, and the “n+1” understand that the problem is probably a bug. So it create a ticket for there engineer team.

Ah. Ok. That sounds good.

Hi all!

today I have a nearly 2h call with the Apple support. We figured out, that the sync work if I start my Mac in Secure Mode (start with pressed Shift key). The conclution was that some application block the connection.

After the call I tried a few things and found out that my issue was caused by Little Snitch (5.0.4). When I disable the Little Snitch network adapter in system preferences the sync work also in normal Mode. I wrote the Little Snitch support. I will report here when I got an answer…

5 Likes

That’s a bit strange and is great info.

After reading your post, I also tried starting up with Shift held, and sure enough, it works. However, I don’t have Little Snitch installed. I do have the Cisco AnyConnect VPN client installed though, and after removing that, it started working fine.

I wonder if there is still a bug at the OS level that causes it not to function when any network filter driver is installed.

1 Like

Hi psychotic! I still have no feedback from the Little Snitch support. I will send them your info! Hopefully they have a better relationship with the Apple Devs/Support than I do. Don’t want to spent 2 more hours exlaining it some low level supporter… :wink:

Hi all! I got info from the Little Snitch support. They reported and/or follow other bugreports of the problem related to “Third-Party Network Extensions and Cloud Services” at Apple. Hope Apple take care of the problem soon…

2 Likes

Wow. Big big thank you for this information!

I didn’t try the secure mode, but after the description of you two I could guess some network issue. As I’m not using any of your tools, I’m using TripMode (which blocks network traffic during mobile connections). The TripMode network adapter seems to be active all the time even if the program is not running.
After deactivating this adapter in the network seetings, the tasks are synchronising.

Since TripMode isn’t that important for me currently, I will leave it deactivated for now.

Thank you again for your contribution and your effort calling the apple support as this has a big influence on my daily workflow :+1:

Greetings,

plate

1 Like

Apple released macOS 11.2 yesterday. I’ll try if the Update hopefully solve the issue and share it here what I’ve found out…

Ok.

Since disabling Little Snitch is not a real solution, I do not mark the subject solved for now.
I stay tuned for a working update of MacOS / Little Snitch that fix this issue.