Problems with Russian translation after upgrade to 28.0.2

Nextcloud version: 28.0.2
Operating system and version: Ubuntu 22.04.3 LTS
Apache or nginx version: 2.4.52
PHP version: v8.1.2-1ubuntu2.14

The issue you are facing:

In Russian version of application there are a few problems with the translations since new upgrade:

  1. The counter of folders and files is incorrectly showing {count} instead of the number
  2. The New button is no longer translated
  3. The Quota is no longer visible in the Users page

Is this the first time you’ve seen this error? Yes

Steps to replicate it:

  1. Login to NextCloud
  2. Open Personal Settings
  3. Change Language to Russian (Русский)
  4. Open Files - The “New” button and the text for the files and folders counter will be not translated
  5. Open The Users page - the Quota is no longer visible in the grid

The output of your Nextcloud log in Admin > Logging:

Not Applicable

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'skeletondirectory' => '',
  'default_phone_region' => 'RU',
  'passwordsalt' => 'salt',
  'secret' => 'secter',
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => 'secret_ip',
    2 => 'secret_dns_name',
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'secret',
  'htaccess.RewriteBase' => '/nextcloud',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'user',
  'dbpassword' => 'password',
  'installed' => true,
  'instanceid' => 'secret',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'trashbin_retention_obligation' => 'auto, 30',
  'filelocking.enabled' => 'true',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 0.0,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'secret',
  'mail_domain' => 'secret',
  'mail_smtphost' => 'secret',
  'mail_smtpport' => '465',
  'mail_smtpauth' => 1,
  'mail_smtpname' => '',
  'mail_smtppassword' => 'secret',
  'maintenance' => false,
  'maintenance_window_start' => 23,
  'theme' => '',
  'loglevel' => 2,
  'updater.secret' => 'secret',

The output of your Apache/nginx/system log in /var/log/____:

Not Applicable


Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

Not Applicable

Same problem after updating to the latest version. Moreover, when the page is refreshed, the correct translation of the button appears momentarily. Clearing the browser cache and cookies has no effect. The problem is on the server side.
I tried to search to correct the required translation in the l10n directory. But I didn’t find anything similar there

1 Like

While we waiting for any official response, you can fix this bug by yourself by navigating to /apps/files/l10n/ and correcting the variable names in the files ru.js and ru.json. For me, these were the lines around line 297.

1 Like

Thank you for this information. I solved folders count problem. Can you advise something with “+New” button? In the ru.js and ru.json files it is translated. And when page is loading the russian varian forst appears and then overwrites with “New”?