PHP 7.4 security updates EOL Nov. 28, 2022

:warning: PHP 7.4 security updates are ending November 28, 2022.

PHP version schedule

What PHP version is your Nextcloud running?

  • PHP-7.3
  • PHP-7.4
  • PHP-8.0
  • PHP-8.1

0 voters

1 Like

Glad to see no one is still using PHP 7.3 after the massive CVE.

1 Like

Looking like 50% of the community voters should be thinking about their PHP upgrade plans. :thinking:

@Cookies
Yes. But i think that is only the half truth. Actually it is not relevant for most users.

If you use the supported Debian 11 Bullseye with default PHP 7.4 or the supported Ubuntu 20.04 LTS focal with default PHP 7.4 than there is no security problem. Both are still supported and nothing is to do. You do not need newer PHP from a different source. Maybe you should better plan to upgrade Ubuntu 20.04 LTS to 22.04 LTS. In 2023 you can plan to upgrade Debian 11 Bullseye to Debaian 12 Bookworm.

Newer PHP versions may be better. But PHP 7.4 is still supported by both the operating system and Nextcloud.