No connection to Nextcloud at <url> Operation canceled

I already searched in the forum but did not found a solution to the issue. I have setup nextcloud from scratch and tried to synchronize files with the nextcloud client. Unfortunately it does not work but only gives me an error “No connection to Nextcoud at https://nextcloud.myserver.com\ Operation canceled”.

I can access the server via web browser or with latest Android client. Server is also pingable

Cient version 2.2.4

02-22 19:40:57:948 14925 OCC::AbstractNetworkJob::slotTimeout: virtual void OCC::AbstractNetworkJob::slotTimeout() OCC::PropfindJob(0x15b52c0) Timeout QUrl("<server url>/remote.php/webdav/")
02-22 19:40:57:951 14925 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() QNetworkReply::NetworkError(OperationCanceledError) "Operation canceled" QVariant(Invalid)
02-22 19:40:57:951 14925 OCC::PropfindJob::finished: PROPFIND request *not* successful, http result code is 0 ""
02-22 19:40:57:951 14925 unknown: QIODevice::read (QNetworkReplyHttpImpl): device not open
02-22 19:40:57:951 14925 OCC::AccountSettings::showConnectionLabel: "No connection to Nextcloud at <a href=\"<server url>\"><server url></a>.\nOperation canceled"
02-22 19:40:57:951 14925 unknown: QString::arg: Argument missing: "<nextcloud url>/desktop/2.2/" , 2
02-22 19:40:57:952 14925 unknown: QString::arg: Argument missing: "<nextcloud url>/desktop/2.2/" , 2
02-22 19:40:57:952 14925 OCC::FolderMan::slotAccountStateChanged: Account "papanito@nextcloud.myserver.com" disconnected or paused, terminating or descheduling sync folders
02-22 19:41:02:951 14925 OCC::Account::resetNetworkAccessManager: Resetting QNAM
02-22 19:41:02:954 14925 OCC::ConnectionValidator::checkServerAndAuth: Checking server and authentication
02-22 19:41:02:954 14925 OCC::ConnectionValidator::checkServerAndAuth: Trying to look up system proxy
02-22 19:41:02:954 15753 OCC::SystemProxyRunnable::run: virtual void OCC::SystemProxyRunnable::run() Starting system proxy lookup
02-22 19:41:02:956 14925 OCC::ConnectionValidator::systemProxyLookupDone: No system proxy set by OS
02-22 19:41:02:962 14925 OCC::AbstractNetworkJob::start: !!! OCC::CheckServerJob created for "<server url>" + "status.php" "OCC::ConnectionValidator"
02-22 19:41:03:171 14925 OCC::CheckServerJob::finished: status.php returns:  QMap(("edition", QVariant(QString, ""))("installed", QVariant(bool, true))("maintenance", QVariant(bool, false))("needsDbUpgrade", QVariant(bool, false))("productname", QVariant(QString, "Nextcloud"))("version", QVariant(QString, "11.0.2.5"))("versionstring", QVariant(QString, "11.0.2 RC3")))   QNetworkReply::NetworkError(NoError)  Reply:  QNetworkReplyHttpImpl(0x11b1200)
02-22 19:41:03:172 14925 OCC::ConnectionValidator::slotStatusFound: ** Application: ownCloud found:  QUrl("<server url>/status.php")  with version  "11.0.2 RC3" ( "11.0.2.5" )
02-22 19:41:03:173 14925 OCC::ConnectionValidator::checkAuthentication: # Check whether authenticated propfind works.
02-22 19:41:03:179 14925 OCC::AbstractNetworkJob::start: !!! OCC::PropfindJob created for "<server url>" + "/" "OCC::ConnectionValidator"
02-22 19:41:29:947 14925 OCC::AbstractNetworkJob::slotTimeout: virtual void OCC::AbstractNetworkJob::slotTimeout() OCC::PropfindJob(0x1389340) Timeout QUrl("<server url>/remote.php/webdav/")
02-22 19:41:29:947 14925 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() QNetworkReply::NetworkError(OperationCanceledError) "Operation canceled" QVariant(Invalid)
02-22 19:41:29:947 14925 OCC::PropfindJob::finished: PROPFIND request *not* successful, http result code is 0 ""
02-22 19:41:29:947 14925 unknown: QIODevice::read (QNetworkReplyHttpImpl): device not open
02-22 19:41:29:947 14925 OCC::AccountSettings::showConnectionLabel: "No connection to Nextcloud at <a href=\"<server url>\"><server url></a>.\nOperation canceled"
02-22 19:41:29:948 14925 unknown: QString::arg: Argument missing: "<nextcloud url>/desktop/2.2/" , 2
02-22 19:41:29:948 14925 unknown: QString::arg: Argument missing: "<nextcloud url>/desktop/2.2/" , 2
02-22 19:41:29:948 14925 OCC::FolderMan::slotAccountStateChanged: Account "papanito@nextcloud.myserver.com" disconnected or paused, terminating or descheduling sync folders
02-22 19:41:34:946 14925 OCC::Account::resetNetworkAccessManager: Resetting QNAM
02-22 19:41:34:953 14925 OCC::ConnectionValidator::checkServerAndAuth: Checking server and authentication
02-22 19:41:34:954 14925 OCC::ConnectionValidator::checkServerAndAuth: Trying to look up system proxy
02-22 19:41:34:954 15880 OCC::SystemProxyRunnable::run: virtual void OCC::SystemProxyRunnable::run() Starting system proxy lookup
02-22 19:41:34:956 14925 OCC::ConnectionValidator::systemProxyLookupDone: No system proxy set by OS
02-22 19:41:34:977 14925 OCC::AbstractNetworkJob::start: !!! OCC::CheckServerJob created for "<server url>" + "status.php" "OCC::ConnectionValidator"
02-22 19:41:35:197 14925 OCC::CheckServerJob::finished: status.php returns:  QMap(("edition", QVariant(QString, ""))("installed", QVariant(bool, true))("maintenance", QVariant(bool, false))("needsDbUpgrade", QVariant(bool, false))("productname", QVariant(QString, "Nextcloud"))("version", QVariant(QString, "11.0.2.5"))("versionstring", QVariant(QString, "11.0.2 RC3")))   QNetworkReply::NetworkError(NoError)  Reply:  QNetworkReplyHttpImpl(0x1428b10)
02-22 19:41:35:198 14925 OCC::ConnectionValidator::slotStatusFound: ** Application: ownCloud found:  QUrl("<server url>/status.php")  with version  "11.0.2 RC3" ( "11.0.2.5" )
02-22 19:41:35:199 14925 OCC::ConnectionValidator::checkAuthentication: # Check whether authenticated propfind works.
02-22 19:41:35:204 14925 OCC::AbstractNetworkJob::start: !!! OCC::PropfindJob created for "<server url>" + "/" "OCC::ConnectionValidator"
02-22 19:42:01:948 14925 OCC::AbstractNetworkJob::slotTimeout: virtual void OCC::AbstractNetworkJob::slotTimeout() OCC::PropfindJob(0x1306e20) Timeout QUrl("<server url>/remote.php/webdav/")
02-22 19:42:01:948 14925 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() QNetworkReply::NetworkError(OperationCanceledError) "Operation canceled" QVariant(Invalid)
02-22 19:42:01:948 14925 OCC::PropfindJob::finished: PROPFIND request *not* successful, http result code is 0 ""
02-22 19:42:01:948 14925 unknown: QIODevice::read (QNetworkReplyHttpImpl): device not open
02-22 19:42:01:948 14925 OCC::AccountSettings::showConnectionLabel: "No connection to Nextcloud at <a href=\"<server url>\"><server url></a>.\nOperation canceled"
02-22 19:42:01:949 14925 unknown: QString::arg: Argument missing: "<nextcloud url>/desktop/2.2/" , 2
02-22 19:42:01:949 14925 unknown: QString::arg: Argument missing: "<nextcloud url>/desktop/2.2/" , 2
02-22 19:42:01:949 14925 OCC::FolderMan::slotAccountStateChanged: Account "papanito@nextcloud.myserver.com" disconnected or paused, terminating or descheduling sync folders
02-22 19:42:06:947 14925 OCC::Account::resetNetworkAccessManager: Resetting QNAM
02-22 19:42:06:953 14925 OCC::ConnectionValidator::checkServerAndAuth: Checking server and authentication
02-22 19:42:06:953 14925 OCC::ConnectionValidator::checkServerAndAuth: Trying to look up system proxy
02-22 19:42:06:954 15982 OCC::SystemProxyRunnable::run: virtual void OCC::SystemProxyRunnable::run() Starting system proxy lookup
02-22 19:42:06:954 14925 OCC::ConnectionValidator::systemProxyLookupDone: No system proxy set by OS
02-22 19:42:06:960 14925 OCC::AbstractNetworkJob::start: !!! OCC::CheckServerJob created for "<server url>" + "status.php" "OCC::ConnectionValidator"
02-22 19:42:07:148 14925 OCC::CheckServerJob::finished: status.php returns:  QMap(("edition", QVariant(QString, ""))("installed", QVariant(bool, true))("maintenance", QVariant(bool, false))("needsDbUpgrade", QVariant(bool, false))("productname", QVariant(QString, "Nextcloud"))("version", QVariant(QString, "11.0.2.5"))("versionstring", QVariant(QString, "11.0.2 RC3")))   QNetworkReply::NetworkError(NoError)  Reply:  QNetworkReplyHttpImpl(0x1341dc0)
02-22 19:42:07:149 14925 OCC::ConnectionValidator::slotStatusFound: ** Application: ownCloud found:  QUrl("<server url>/status.php")  with version  "11.0.2 RC3" ( "11.0.2.5" )
02-22 19:42:07:149 14925 OCC::ConnectionValidator::checkAuthentication: # Check whether authenticated propfind works.
02-22 19:42:07:155 14925 OCC::AbstractNetworkJob::start: !!! OCC::PropfindJob created for "<server url>" + "/" "OCC::ConnectionValidator"
02-22 19:42:33:951 14925 OCC::AbstractNetworkJob::slotTimeout: virtual void OCC::AbstractNetworkJob::slotTimeout() OCC::PropfindJob(0x1880540) Timeout QUrl("<server url>/remote.php/webdav/")
02-22 19:42:33:951 14925 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() QNetworkReply::NetworkError(OperationCanceledError) "Operation canceled" QVariant(Invalid)
02-22 19:42:33:951 14925 OCC::PropfindJob::finished: PROPFIND request *not* successful, http result code is 0 ""
02-22 19:42:33:952 14925 unknown: QIODevice::read (QNetworkReplyHttpImpl): device not open
02-22 19:42:33:952 14925 OCC::AccountSettings::showConnectionLabel: "No connection to Nextcloud at <a href=\"<server url>\"><server url></a>.\nOperation canceled"
02-22 19:42:33:952 14925 unknown: QString::arg: Argument missing: "<nextcloud url>/desktop/2.2/" , 2
02-22 19:42:33:952 14925 unknown: QString::arg: Argument missing: "<nextcloud url>/desktop/2.2/" , 2
02-22 19:42:33:952 14925 OCC::FolderMan::slotAccountStateChanged: Account "papanito@nextcloud.myserver.com" disconnected or paused, terminating or descheduling sync folders
02-22 19:42:38:949 14925 OCC::Account::resetNetworkAccessManager: Resetting QNAM
02-22 19:42:38:952 14925 OCC::ConnectionValidator::checkServerAndAuth: Checking server and authentication
02-22 19:42:38:952 14925 OCC::ConnectionValidator::checkServerAndAuth: Trying to look up system proxy
02-22 19:42:38:953 16086 OCC::SystemProxyRunnable::run: virtual void OCC::SystemProxyRunnable::run() Starting system proxy lookup
02-22 19:42:38:953 14925 OCC::ConnectionValidator::systemProxyLookupDone: No system proxy set by OS
02-22 19:42:38:959 14925 OCC::AbstractNetworkJob::start: !!! OCC::CheckServerJob created for "<server url>" + "status.php" "OCC::ConnectionValidator"
02-22 19:42:39:187 14925 OCC::CheckServerJob::finished: status.php returns:  QMap(("edition", QVariant(QString, ""))("installed", QVariant(bool, true))("maintenance", QVariant(bool, false))("needsDbUpgrade", QVariant(bool, false))("productname", QVariant(QString, "Nextcloud"))("version", QVariant(QString, "11.0.2.5"))("versionstring", QVariant(QString, "11.0.2 RC3")))   QNetworkReply::NetworkError(NoError)  Reply:  QNetworkReplyHttpImpl(0x11fa8d0)
02-22 19:42:39:188 14925 OCC::ConnectionValidator::slotStatusFound: ** Application: ownCloud found:  QUrl("<server url>/status.php")  with version  "11.0.2 RC3" ( "11.0.2.5" )
02-22 19:42:39:188 14925 OCC::ConnectionValidator::checkAuthentication: # Check whether authenticated propfind works.
02-22 19:42:39:194 14925 OCC::AbstractNetworkJob::start: !!! OCC::PropfindJob created for "<server url>" + "/" "OCC::ConnectionValidator"
02-22 19:43:05:946 14925 OCC::AbstractNetworkJob::slotTimeout: virtual void OCC::AbstractNetworkJob::slotTimeout() OCC::PropfindJob(0x13df920) Timeout QUrl("<server url>/remote.php/webdav/")
02-22 19:43:05:946 14925 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() QNetworkReply::NetworkError(OperationCanceledError) "Operation canceled" QVariant(Invalid)
02-22 19:43:05:946 14925 OCC::PropfindJob::finished: PROPFIND request *not* successful, http result code is 0 ""
02-22 19:43:05:946 14925 unknown: QIODevice::read (QNetworkReplyHttpImpl): device not open
02-22 19:43:05:946 14925 OCC::AccountSettings::showConnectionLabel: "No connection to Nextcloud at <a href=\"<server url>\"><server url></a>.\nOperation canceled"
02-22 19:43:05:947 14925 unknown: QString::arg: Argument missing: "<nextcloud url>/desktop/2.2/" , 2
02-22 19:43:05:947 14925 unknown: QString::arg: Argument missing: "<nextcloud url>/desktop/2.2/" , 2
02-22 19:43:05:947 14925 OCC::FolderMan::slotAccountStateChanged: Account "papanito@nextcloud.myserver.com" disconnected or paused, terminating or descheduling sync folders
02-22 19:43:10:946 14925 OCC::Account::resetNetworkAccessManager: Resetting QNAM
02-22 19:43:10:952 14925 OCC::ConnectionValidator::checkServerAndAuth: Checking server and authentication
02-22 19:43:10:953 14925 OCC::ConnectionValidator::checkServerAndAuth: Trying to look up system proxy
02-22 19:43:10:953 16194 OCC::SystemProxyRunnable::run: virtual void OCC::SystemProxyRunnable::run() Starting system proxy lookup
02-22 19:43:10:954 14925 OCC::ConnectionValidator::systemProxyLookupDone: No system proxy set by OS
02-22 19:43:10:960 14925 OCC::AbstractNetworkJob::start: !!! OCC::CheckServerJob created for "<server url>" + "status.php" "OCC::ConnectionValidator"
02-22 19:43:11:177 14925 OCC::CheckServerJob::finished: status.php returns:  QMap(("edition", QVariant(QString, ""))("installed", QVariant(bool, true))("maintenance", QVariant(bool, false))("needsDbUpgrade", QVariant(bool, false))("productname", QVariant(QString, "Nextcloud"))("version", QVariant(QString, "11.0.2.5"))("versionstring", QVariant(QString, "11.0.2 RC3")))   QNetworkReply::NetworkError(NoError)  Reply:  QNetworkReplyHttpImpl(0x12f5040)
02-22 19:43:11:178 14925 OCC::ConnectionValidator::slotStatusFound: ** Application: ownCloud found:  QUrl("<server url>/status.php")  with version  "11.0.2 RC3" ( "11.0.2.5" )
02-22 19:43:11:179 14925 OCC::ConnectionValidator::checkAuthentication: # Check whether authenticated propfind works.
02-22 19:43:11:186 14925 OCC::AbstractNetworkJob::start: !!! OCC::PropfindJob created for "<server url>" + "/" "OCC::ConnectionValidator"
1 Like

I am having same issue, does anyone have idea about the reason?

I’m also having the same issue, according to my logs. They are two Windows sync clients as well as one Linux sync client affected (both using the Nextcloud sync client at version 2.2.4, Nextcloud server at version 11.0.2).

The most interesting point is: I’ve installed the Windows Nextcloud client on my laptop for work. After starting Windows, the sync client won’t connect with the log messages @papanito has posted before. When I connect to my empoyer’s VPN (and have to use their proxy), the sync client starts syncing (via the proxy)!
After a while, when I disconnect from the VPN, the sync client won’t use the proxy anymore, but keeps syncing! I can’t explain this behavior.

It seems that only the connections to the WebDAV endpoint are affected. The Web frontend works fine.

@papanito @jithin.benjamin I’ve found a solution. Deleting the account(s) in the sync client and re-adding them fixed it. I don’t know why, but well…

@stdll Thanks for your prompt response. Sorry to mention in my post earlier, I have already tried the option you suggested and it worked but if you Quit the application and try to reconnect you may face the same error :confused:

@jithin.benjamin You’re right, after restarting the PC it won’t sync anymore. :confused: I don’t even know what it was caused by. It started on Friday, but there were no updates, neither server-side or client-side. I suspected the PHP version (using 7.0.x), but it was updated two weeks before, not on Friday. Do you have any errors in your server logs? At the moment I suspect it’s a client thing because I don’t see any errors, neither in the Apache log files nor in nextcloud.log. Maybe it’s time to open an issue on GitHub.

@jithin.benjamin I’ve found a solution in my specific case. My router was at fault. We have a “hybrid” solution, meaning our internet connection is split between DSL and LTE. I’ve restricted connections to the Nextcloud server to DSL and voilà, it works. :smiley: I hope you find a solution as well!

Hey,

did someone found a solution, besinde the Router? It is pretty annoying to configure nextcloud every couple of hours.

Thank you!

I’ve got the same errors on my clients. Also client version 2.2.4. Would also be interested to have a solution

1 Like

I have another solution for you, @WhiteTom and @zisuu! By the way, this solved the problem for me as well, once and for all. :smile: The “router solution” was just an unfortunate coincidence.

Look at this topic:

I noticed that I had very slow login times as well. As it seems, one of our Nextcloud clients at home spammed incorrect login attempts and Nextcloud slowed down all of us (due to the same IP address) to a crawl. I had to wait approximately 30s to log in via the Web interface. Turns out mobile and desktop sync clients hate this and respond with “Operation cancelled”. :unamused: This also explains the strange fact that Nexcloud started working all of a sudden when I switched to my employer’s VPN network - I switched to an IP address that wasn’t slowed down.

So, to solve this, you can turn off the brute force detection, but I’d advise against it. I truncated the brute force detection table and made sure that all devices log in correctly. The following topic may help you:

What I don’t like about brute force detection is that the feature is not transparent at all. The following topic contains some improvements that’ll make it in future versions of NC (hopefully):

2 Likes

I’ve found that whitelisting my IP to nextcloud solves the client login problem for me. You can go to the admin page, then then security tab, and at the bottom is a field to whitelist IPs. I’m going to remove the whitelist in a couple of days and see if it is still resolved.

1 Like

Is there any way to debug this? Can I run the client somehow in verbose mode and get more info about my issue?

I have a hosted server that I pay for and have no admin access to it. I want to file a ticket for them and give them some technical info. How do I do that?

Thank you,
Andrei

Again: I’m in same trouble. From one day to the other, Windows client as well as iOS client stopped working with this same message.

Access via web works fine and no log entries while I attempt to log in/out from the Windows client.

The one thing that I changed was moving my server from OpenVZ to LXC. However, all services are running, it has the identical file system, IP etc and web access works.

Any help to debug this would be greatly appreciated!

This is what I get if I run nextcloud --logwindow

Once I cleaned up the table below all of my clients starting working for this user. I’m not sure what is causing these as the records are from our computers and the nextcloud app has the creds saved. We are also using CODE for editing office documents and using Zimbra Auth. My guess could be if either of those is acting up it counts as brute force attempt.

select * from `oc_bruteforce_attempts

1 Like

I have the same problem !
After I have cleaned up the “bruteforce_attempts” table my clients windows are connected after power on. The problem subsists on Ubuntu clients.

errors log:
[Tue Feb 13 16:53:21.572862 2018] [ssl:warn] [pid 11205:tid 140543244531584] AH01909: nuage.ouvaton.org:443:0 server certificate does NOT include an ID which matches the server name
[Tue Feb 13 16:53:54.410402 2018] [ssl:warn] [pid 13923:tid 140543244531584] AH01909: nuage.ouvaton.org:443:0 server certificate does NOT include an ID which matches the server name

1 Like

Same issue here after updating to nc13.0.0 from nc12.0.4.

Brute force app was not installed. Some clients using http and/or https haven’t experienced issues, but others just can’t connect. If I deleted the account and configure it again it starts syncing, but after rebooting or just closing nextcloud client (Windows version 2.3.2 build 1), i wont connect again.

My nextcloud is behind a nginx proxy, and after installing Brute force app and added the proxy IP to the whitelist, the clients start to syncing again.

Obiously if every client go through the proxy, and the proxy is whitelisted seems that no IP would be blacklisted.

Anyway, by now it seems to be solved.

I confirm white listing the ip of my adsl modem still solves the problem at May 27, 2018
NC 13.02

I can also confirm that whitelisting my router (192.168.1.1) solves client syncing problem as of June 26, 2018. This is despite a fresh install of nextcloud server on ubuntu 18.04, fresh sync with no restoration of databases (and thus no restoration of addons). Bruteforce addon was not enabled by default. Enabling it and adding the above IP to the whitelist solved the problem, all desktop clients can now sync with no problem.

The issue came about roughly 3 weeks ago, not sure why. I don’t think there is a correlation to any specific update client or server side. Web GUI log showed a lot of “Login failed: ‘[user]’ (Remote IP: ‘192.168.1.1’)”.

Hello,

I am new to this I am having the same problem, I have the nextcloud working fine, suddenly the windows or mac client stop making connection and syncing. I am searching everywhere but can not find a solution. I am already frustrated, and want to avoid to recreate again the complete server. but i am still afraid it happens again when I do that.

I just see this post “whitelist the router”. can you please elaborate in this and explain me as a 5-year-old baby. My DHCP server/Router/firewall is a Sophos UTM. Talking to a friend he mentions it might be a DNS issue at my home. But cant find anything related to that.

So if you can guide me thru this, How to get error logs, and how to fix it you will make my day and will be a outstanding linux and php learning process
,
This is my home setup: ISP modem is connected to my UTM sophos/firewall, nextcloud is installed on ubuntu 18.04, on a VM running EXSi. the https certificate is getting from Caddy Server.

Can you please tell me what you do and how?