Nextcloud Snap users, please list the issues you're facing

snap

#103

Probably. It’s always a trade-off. The benefit of having everything isolated in their own containers outweighs the extra resource usage, in my mind. Especially when you’re talking about multiple websites requiring different versions of PHP, or Ruby. Dependency management when you can separate everything out is so much easier.


#104

Thanks.
I guess even a small direction or notification in the documents would have filled that gap in the nexctcloud docs for me. Right now, it just looks to an average user like me who is looking for a personal private sync solution that the two installations are the same. In fact, it even looks like the preferred installation is snap installation and the manual installation is for those who does not want to use snap. I had not realized that the snap installation was brought to us by a different group of developers.


#105

I followed these instructions. I changed the ports Nextcloud uses to 81 and 444. I can access
NC via 1.2.3.4:444. I assume that the next command

sudo nextcloud.occ config:set overwritehost --value=“example.com:81

is to tell Apache to forward 80 and 443 to 81 and 444

But it returns the following error:

What am I doing wrong?


#106

Hello oparoz
I am using NC 13 as a snap into ubuntu-core
I would enable “Ldap user and groups” app, it is in the bottom of apps page, and it is grayed, I can’t enable it.
So I search aronmd and I arrive here. My question is:
is still unavalable Ldap integration and snap nextcloud?
Many thanx for your kind reply
Best Regards


#107

Oh no! Looks like we have a typo in the README. That needs to be config:system:set indeed.


#108

See this issue. Feel free to investigate if this is a feature that interests you.


#109

I got stuck creating the vhost that proxies to the snap. What is the document root for the snap? I’m using lighttpd and I’d like to park Nextcloud at cloud.mydomain.com.

I’ve created a vhost @ /etc/lighttpd/conf-available/cloud.mydomain.com.conf and guessed at the document root.

cloud.mydomain.com returns a 404

Edit-Update

After exploring for a while I found /snap/nextcloud/current/htdocs/ which contains index.php so I put that in at the document root. Now I get a 403 - Forbidden error.

Edit- Further Update

It is now clear to me that I need detailed instructions on how to set up a reverse proxy and how that proxy should interact with the snap. Can anyone help me?


#110

Hi there,

I’ve studied computer science thirty years ago, but otherwise I’m clueless.
I did get owncloud to work with the DigitalOcean installation routine, but I’d like to switch.
I never even get to the Nextcloud-Welcome screen. Have searched the web and the forum but to no avail.

My server is maeschke.com [in the follwing: ]

Here’s what I did:
I re-installed Ubuntu 16.04 64 bit from scratch.
apt-get update
apt-get upgrade
snap install nextcloud
sudo nextcloud.manual-install mm ######
sudo nextcloud.occ config:system:set trusted_domains 1 --value=
sudo nextcloud.enable-https lets-encrypt

It gives me

Failed authorization procedure. www. (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from […]: "

404 Not Found

Not Found

<p" IMPORTANT NOTES: - The following errors were reported by the server:

Domain: …
Type: unauthorized
Detail: Invalid response from
http://www./.well-known/acme-challenge/NrDAgz6awJXt_0_kavZxJ2FwDYyUnXxUV4aBUnPxdLc:
"

404 Not Found

Not Found

<p" --------------------------------

My DNS A entry is correct and the domain is routed correctly to the server.
Meanwhile, manually, let’s encrypt works for me: I do get a certificate.
It looks like Let’s Encrypt does not find the location where the certificate is located.?!?

Also…
the browser still shows the Apache Standard screen
(shouldn’t it show me the Nextcloud-Welcome screen?)

I’d very much appreciate your help.

Thanks and best regards

Martin


#111

@MartinM looks like you have Apache installed standalone as well. The snap also wants ports 80 and 443, which the standalone Apache install is already claiming, so it’s not running.

Do you need the standalone install of Apache, or can you remove it? You can change the snap’s ports if necessary.


#112

Thanks! I removed the other apache and now it works.


#113

Hi there,
I installed nextcloud with snap and now I’m trying to make it work for us.

Theming (with the theming app):
changing the logo only changes the logo on the header line, not on the login screen and not in the welcome window (is that on purpose?)

Skeletondirectory (I want to have empty directories for new users)
changing parameter skeletondirectory in config.php not possible under the
/snap… directory tree (“read only directory” - I assume that’s on purpose?)
and changing parameter skeletondirectory in
/var/snap/nextcloud/4371/nextcloud/config/config.php
has no effect.

Is there a documentation of what the different directories …
(in particular
/snap/nextcloud/4371 and
/snap/nextcloud/current )
… are good for?

Many questions. Hope that’s ok.

Best regards

Martin


#114

I’m not quite clear on what you’re saying, but I know of a bug in this area. Are you referring to this?

You’ll want to edit /var/snap/nextcloud/current/nextcloud/config/config.php.

Yes. Documentation for the snap is located here, the information for which you’re searching is available in the README.


#115

re. Skeletondirectory: thanks for that, problem solved
re. Theming app…
I’m running Ubuntu 16.04 and nextcloud 12.04 with snap installation. I’m not experiencing any error messages as mentioned in the link you provided. In the theming app, I changed the slogan, the logo and the background picture of the logon screen.

You can see the result on the logon screen of www.maeschke.com
Slogan is changed.
Logo is still the nextcloud logo (is that actually supposed to be changed?)
Background picture is still the nextcloud background picture.

It looks like everything that has to do with pictures on the logon screen cannot be changed.

Oh … and thanks for your help, I really appreciate that.

Best regards,
Martin


#116

Is set to 10 GB but the real limit is 2 GB


#117

I’m very grateful that snaps have been made available. Thank you!

Any word on a Nextcloud 13 snap?


#118

It’s in the testing phases now. Try it from from the 13/candidate channel:

$ sudo snap install nextcloud --channel=13/candidate

Or if you already have it installed:

$ sudo snap refresh nextcloud --channel=13/candidate

Installing on QNap NAS?
#119

What is the max number of files that can be uploaded together in Nextcloud snap…? I wish to backup some WordPress instance but I receive errors… I think that this is another issue to fix in the next version with the max file size allowed in upload… Thanks…


#120

I am running NC 13 RC4 snap on a Ubuntu LTS 16.04 server. I have no blocking issues, everything seems to be working.

However, uploading via the sync client and webdav is very slow. (I am guessing the sync client uses webdav right?) I can transfer files via the webinterface with at least 15MiB/s (my wifi is no faster). But up/downloading via webdav is more like 700/800KiB/s. This is for a Windows 10 webdav connection as well as for the NC Android client (beta 3 also). The instant uploads for pictures often fail, I think because of the slow speeds. Every now and then I get an ssl error as well when it fails.

My hardware is a small Intel NUC with 8GB of RAM. The cpu always stays below 10% and the memory consumption is about 700MiB…

Is there any way to speed up webdav on NC snaps? I have tried to find some tweaks, but I can’t find any that I can apply to the snap version it seems. I have also asked this question in the forums, but got no reply there.


#121

Here is my issue trying upgrade:


#122

I’ve been running the snap for about a week on Ubuntu Server 16.04 LTS, and am seeing a ton of "Sabre\DAV\Exception\BadRequest: expected filesize 10000000 got " errors after syncing our photo collection to the machine.

I’ve read where this could be due to a bad config, but I’m not sure how I figure out exactly what is running out of memory. (I’m nowhere near using all of my RAM)