Nextcloud Snap users, please list the issues you're facing

snap

#123

I have two problems that I can’t seem to fix on the snap version but works on the ‘normal’ installation.

  1. Theming doesn’t seem to work everywhere
    When I upload our logo, color scheme and background-image in the GUI settings page, everything
    changed as expected, except for the login page. I’ve only got this problem with snap installations.

  2. Clean URL’s, how to set that on a snap version of NextCloud?
    On a ‘normal’ installation, it is very easy to setup clean URL’s, but I couldn’t get this working on a snap installation. Is there a guide or something regarding this?


#124

is this only about ssh access or does the snap NC actually come with reduced accessibility (access configurations, like i.e. using a different location for the actual files) on the admins side?

also, what would the non-tech-user mind whether ssh access was possible. Isn’t the entire beauty of snap packes in the simplicity of installation of a complex application bundle with just one simple command?


#125

Hi Olivier, we’re using the nextcloud snap installation as transfer server in a small audit company. Since the installation is privacy sensitive, we have subjected it to a professional penetration test. I’d like to share the results with you. Please contact me on my email adress if interested. Best regards Martin


#126

Hi Martin,
I understand that for security you might not want to share the details of the report on a forum. Could you at least say if the conclusion of the test was positive?


#127

I tested that this works in 13.0.2snap1, give it another shot?


#128

Non UTF-8 charset banner warning:

Both NC12 and now NC13 since it updated today have worked fine. Set up on a Digital Ocean Droplet (ubuntu 16.04) according to their instructions. Letsencrypt for certificate, via noip.com.

Only gripe I have is the News app complains that the database does not handle non UTF-8 characters (emojis?). I don’t care for emojis, but wish the warning banner would disappear. It’s been there for 6 months now. I believe it is not the News App itself, but the configuration of the database. See:

20180509_SelectionNN


#129

It’s annoying that the news app is warning because you haven’t enabled something that is experimental, but you can totally do this if you wish.


#130

Thank you kyrofa. That fixed it in under a minute. Wow. Now I can continue to ignore emojis :wink:


#131

Amen! You should never have to be annoyed for six months. You’re always welcome to ask questions by logging an issue!


#132

My snap installation of Nextcloud updated itself last night from 12.0.5.3 to 13.0.2.

Most apps seem to be working, but Files is not working at all. Doesn’t list any files or directories.

There’s an error in my console from app.js: “Cannot read property ‘fileActions’ of null”

I verified through terminal that my files are still there. If I make a new directory on my computer, is syncs up to the server using the nextcloud app. But if I make a directory on the server, it doesn’t sync down to my computer. And again, web view is completely blank.


#133

Interesting development…
If I go to “Tags”, search for nothing, and then go back to Files, it will list them…


#134

Activation of a Lets encrypt certificate for https was repediately failing, so at some point i switched to a normal installation. (This was in January)


#135

Hi Kyrofa, did you add a second domain to your cert after you originally configured a first one?

I’ve got to add a second one to an existing setup, so wondered if it’s just a matter of re-running sudo nextcloud.enable-https lets-encrypt

then restartinging the snap, and if this would pick up on the new trusted domain which I’d added to NC and include it, without breaking the existing certificate/domain.

(sorry, this whole snap setup is a lot faster but takes time to get used to not tweaking config files as before!)

Thanks!


#136

@johnkahuna yeah I did. It’s not as easy as it should be, and I have a bug for that, but it’s not too bad. Taken from here:

First of all, disable HTTPS (this just removes a symlink, it doesn’t remove any certs):

$ sudo nextcloud.disable-https

Then blow away any certs that are there (this includes self-signed certs, Let’s Encrypt certs, everything). Make sure you get this command right, you don’t want to delete anything else in the current/ dir:

$ sudo rm -rf /var/snap/nextcloud/current/certs

Then pretend you’re enabling HTTPS for the first time, using the domains you want:

$ sudo nextcloud.enable-https lets-encrypt

#137

After a while, I can’t use any of the /snap/nextcloud. commands any more, For example nextcloud.occ freezes the tty


#138

Any chance you’re out of RAM? See anything in the syslog?


#139

I have to proof.

That happened in an not productive environment with nextcloud 13. The VM acutally ist down, but it would be nice to get a mysql backup. Will look after solving my bigger Problem :slight_smile:


#140

great thanks! will try this out when I can next put the server offline


#141

Hi,

my Nextcloud Snap instance runs perfectly on a RPI3. But I now want to migrate it to a stronger mashinewhich runs with Debian. I copied already the Data folder and mounted it in the same place withe the same name. I also copied the /snap/nextcloud folder to the new mashine but I couldn`t get this thing going. The old folder got a new name also. After I enabled nextcloud with “snap enable nextcloud” I only got a white page.

After some trails: which included to rename the backup folder with the number on it (in the nextcloud folder). It got the number of the folder of the new installation. After I enalbed it and run “snap info nextcloud” I saw that the “nextcloud.redis-server” was inactive. I have no clue what this server does. Now I got no page at all in the browser.

Has someone an idea?

best regards
simon


#142

Running snap 13.0.2.

I get the below message when trying to go to settings(.com/index.php/settings/user)

I tried reverting the snap but then was unable to login due to the login button not working.
I have sense refreshed the snap back to 13 to get some functionality back.

How do I resolve the below issue?

Internal Server Error

The server was unable to complete your request.