Nextcloud Desktop Client VERY slow

Nextcloud 27.1.6
Desktop Client 3.11.1

So i have nextcloud running on an intranet server which is connected with 10Gbit to the switch. The clients have 1Gbit connection to the switch.
We are running an internal unbound DNS that directs all requests directly to the internal network ip of the nextcloud server only external use the internet ip

Now when i upload download stuff from the webinterface the speed is as ist should be (around 100MB/s) if i use the desktop client to sync it barelz reaches 1MB/s

The server itself is sporting a ryzen 7600 with 64gigs of ECC ram on an asrock rack server mainboard.

So stuff should be blazing fast, but it aint.

Any idea?

Before digging too deeply, if an internal client was going through your external Internet link (even though it’s not supposed to per your config), what speed would you expect? Is it anywhere in that ballpark is does it have no correlation at all?

sadly that is also not even close. we have 300mbit symmetrical fibre.

i observed something funny today

It still is atrociously slow when in background. But when i bring it to focus by opening settings it speeds up dramatically

just clicking the tastkbar icon for the overview is not enough btw.

The speed depends a lot on several factors. I’d try to compare it to a bare speed if you connect through SCP/SFTP. 20%-50% of that speed should be achievable by adjusting Nextcloud (different caches, database), there are many topics here and in the documentation.

as i have said in the opening when using browser i can upload with 100MB/s no prob. The Desktopclient is the slow part. Which changes when i open settings (where you can watch the upload) then it speeds up to nearly full speed.

May have something to do with process priority being a bit too nice

There were a few reports these days about the performance and that other client (also the owncloud client) achieve much better performance.

And someone opened a topic in the bug tracker:

1 Like

That bug report is me, nothing came of it though.

Well, there is already a fix for one case. Not for you, but it is good to know that yours seems to be different, and with more input from others, they can perhaps narrow down the problem.

I noticed the same thing:

@Moritz_Haf You may want to add your valuable observations to this issue: