Nextcloud box does not boot on rasberry pi

I received my nextcloud box yesterday. Unpacked following instructions, inserted the provided pre-build SD card and booted up with a HDMI cable connected to my RPi2 so I could see any activity. The only activity I got was a screen with all colours of the rainbow. I waited 10 minutes but as the RPi2 LEDs showed a single constant red (I expected at least to see the green LED to flash during installation), I wasn’t hopeful. A white LED on the WD 1TB drive also lights up. I tried a few times with the same result.

Testing another SD card with a raspbian Jessie light image on it boots fine, so I conclude my RPi2 is ok. I tested the provided pre-build SD card in various computers and only on 1 laptop it would show 2 partitions (boot and root I seem to recall). The card is readable I would think.

Are these SD cards really so temperamental :confused:? Should I try to down load an image onto a spare SD card and see if that works? :unamused:

Has anyone had a similar experience.

I have now downloaded an image from and written it to an 4GB SD card. Again it won’t boot :sob:. I am just staring at a rainbow type image (i have a screen attached).

When I boot from the rabsbian SD, it very briefly shows the same rainbow image but then carries on with the booting process where the green LED intermittendly flickers. This makes me think that the boot process does not start.

Has anyone seen this before and can point me in the right direction?

The boot process is related to your operating system, well before nextcloud is involved in any way. Therefore, you can’t expect too much expertise here. A search in the RPi/Snappy communities should be considered where you can find more experts.
The LED flickering on RPi is coded:

As someone that could possibly buy a Nextcloud box in the future, I am a bit stumped by the fact that a customer that has bought a Nextcloud Box that doesn’t boot is advised to find a solution on his/her own at a different forum .

Is there no official support for the Nextcloud box?

You buy the box from WD, you get the Raspberry (or other ARM device) yourself, and then run the image. Related to Nextcloud, and partly to the snappy-stuff you’ll find some support here. And here it doesn’t seem to be related to NC itself, it’s the OS or the hardware. Not everyone here (like myself) is familiar with snappy or other box specifics, so perhaps someone more familiar with this environment will give more specific advice.

Seems to me then that @cookf needs to contact WD and get a SD card replacement.

Do you know what OS the NC Box SD card comes with? I have configured my Pi3 with Ubuntu Snappy Core and NC11 snap version, which works very well.

This should be the preinstalled system. Though RPi3 is not supported yet (or very new).

Thank you for your comments (especially tflidd). It makes sense that I get back to WD. I’ll try once more the Ubuntu snappy core first and add NC11 to it. I have managed to get NC11 to work on Raspbian but it is slow.

Raspbian shouldn’t be slower. There are perhaps some points in the configuration you can improve (the default settings of the snappy-image are done to work with Nextcloud). In general, don’t expect wonders from this device.

1 Like

The box is an SDcard and a HDD, any possible errors flashing up on the Pi aren’t really covered as it’s not a supplied product.

@cookf to be awkward, might you have another microSD to write the image to? Please fully describe your method of writing the image and the link to the image you’ve downloaded.

To answer some quesitons:

  • Yes SD cards can be very temperamental. They shouldn’t be but they are.
  • Yes many people have seen the same error as you, though reimaging the SD/writing a new SD resolves it.

Currently it’s a customised Ubuntu server 16.04 image - NOT Snappy Core. When the new image is released it’ll be Snappy Core.

Nextcloud isn’t generally quick on Pi. It’s not terrible but it’s certainly a household-targeted device rather than group-ready. If you use Raspbian or any other Linux image without the Snap you’ll have far more control over what you can tweak pertaining to performance and whatnot and when NC12 with new image thumbnail generation arrives you’ll notice a marked difference. For now though it’ll work fine as long as you’re set with the expectation that it won’t be as fast as on a powerful system.


Hi Jason,
Thank you for clarifying quite a few points.
Yes I have tried 2 other SD cards.

  1. First with Raspbian Jessie lite which booted the pi fine.

  2. I downloaded from and wrote it to a spare 4GB SD. No boot. Is this the correct image?
    I read about power issues and tried booting without the HDMI cable attached. No change, the red LED lights up, the green maybe once quickly but then shows no activity.

  3. I bought an 8GB noobs SD and installed raspbian which boots the pi without issue.

  4. Interestingly, last night I downloaded a snappy core image, but that also refused to boot.

I use my Linux Mint laptop with USB Stick formatter and USB image writer. These tools have worked fine for other SDs.

What is your advise? Should I buy another SD? I don’t understand that I can boot certain images and not others.

I find that very interesting indeed. Out of interest what is the exact model of your Pi?

The correct image is indeed:


Here is a SO link talking about rainbow screen, it may be that adding the delay to your config file will resolve it.

Other than that I’m unsure what to suggest really, this image is known to work with the Pi2, and is the official version of the image I was providing before that to over 50 downloads confirmed as working.

Hi Jason, thank you again.
My RP2 is a version B+ V1.2.
I’ll will try your suggestion and update the forum.

Darn it you’re giving me reasons to upgrade right when I just got fully content with NC11 :sweat_smile:

@cookf I’m not well versed in the Ubuntu side of the Raspberry Pi, but I’ve been running Nextcloud since it was released on my Pi. I have to say the best thing I did to increase performance was to enable APCu caching for my server. Nextcloud has tutorials on that in their documentation. You may have to look at other sources on how to set up caching for Raspbian or Ubuntu 16.04

The RPi2 v1.2 uses the same 64 bit CPU that the RPi3 uses, the old 32 bit CPU is being discontinued so it’s possible that the supplied SD card image also won’t work on a RPi2 going forward.

1 Like

Could it be this CPU issue? I bought a Nextcloud Box this weekend, and ordered a new Raspberry Pi 2. They both arrived yesterday. I tried to install but nothing happened. I tried a different SD card, nothing again. A friend of mine who was also installing one had exactly the same issue. I just checked, and indeed, my Pi has the new BCM2837 processor.
Maybe the Nextcloud Box product page could be updated?

1 Like

Oops. Looks like that Pi3 image needs to come sooner rather than later @oparoz

But here is the snag. My RPi2 is a 2nd hand eBay breed. It reads Model B+ V1.2 with time stamp 2014. I can’t read the chip number without a magnifying glass but would have thought that the chip upgrade took place recently.

You might have an older RPI, the RPI2 wasn’t released until Feb 15. Boot it with raspian and check to see how much memory it shows. If it shows 256 or 512 mb then your RPI is too old.

EDIT: @cookf I think you have one of the later original Raspberry Pi and not an RPi2. My RPi2 has printed on the board Raspberry Pi 2 Model B V1.1 with a copyright notice of 2014. This is the version you need. If your RPi has on the board Raspberry Pi Model B+ V1.2 then you have an older RPi that won’t work with NC.

1 Like

Hi @Greg_Fordyce. I think I had misunderstood the versions and must have purchased the wrong model. For the record, NC does work on this RPi1 version under Raspbian. It is slow but plodding on.

So I gather this topic is solved then (for me) with the following conclusion:

I bought a RPi B+, (32bit?) which is not a RPi2 and the supplied SD card contains the boot image (64bit?) that won’t run on this model.