Nextcloud aus dem Internet sehr sehr langsam, im LAN aber sehr schnell

Hallo zusammen,

[Ich musste alle Links “zerstören”. das sind keine Fehler, ich hab immer mit Leertaste den link deaktiviert, weil ich neu bin]

ich hab mich hier angemeldet, weil ich alleine leider nicht weiter komme. Mir gehen auch langsam die Ideen aus was ich noch googlen soll.
Helft mir bitte etwas auf die Sprünge. :slight_smile:

Mein Problem ist, dass NC im Lan bestens funktioniert, allerdings nicht, wenn ich über die DynDNS gehe.
Da passiert mal rein garnicht… bei h ttps://xxx.duckdns.org/index.php/login sehe ich das NC Symbol und Wolken, sonst garnichts…

Ich hab inzwischen fast alle Einstellungen getroffen oder überprüft die man so findet…

hier mein Setup:

Zur Installation habe ich mich an das Video von Apfelcast gehalten.
Video Tut von Apfelcast

PC // i5 6500t, 32gb ram, 512mb nvme, 2x 2tb hdd
100MB Upload und 40 MB Download (Die Werte erreiche ich laut Wieistmeineip auch tatsächlich und beständig)
Proxmox 7.3-4, GNU/Linux 5.15.83-1
LXC Ubuntu 22.04.1 LTS // 4 Cores,30GB RAM, 12GB Root, 1TB DATA
Nextcloud 25.0.3
PHP 8.1.14 (eigentlich 8.2, das hat aber zu “OCC_Problemen” geführt, deswegen hat ich das “zurückgestutzt” (update-alternatives --config php)
PHP-Addons: Core, date, libxml, openssl, pcre, zlib, filter, hash, json, Reflection, SPL, session, standard, sodium, apache2handler, mysqlnd, PDO, xml, apcu, bcmath, calendar, ctype, curl, dom, mbstring, FFI, fileinfo, ftp, gd, gettext, gmp, iconv, igbinary, imagick, intl, exif, mysqli, pdo_mysql, Phar, posix, readline, redis, shmop, SimpleXML, sockets, sysvmsg, sysvsem, sysvshm, tokenizer, xmlreader, xmlwriter, xsl, zip, Zend OPcache
MYSPQL: 10.6.11-MariaDB-0ubuntu0.22.04.1 Ubuntu 22.04
Apache/2.4.52

und noch ein Paar Config-Dateien:

/etc/php/8.1/apache2/php.ini

output_buffering = Off
max_execution_time = 30
max_input_time = 120
memory_limit = 512M
post_max_size = 20G
upload_max_filesize = 20G
allow_url_fopen = On
allow_url_include = Off
default_socket_timeout = 60
pdo_mysql.default_socket=
smtp_port = 25
mysqli.max_persistent = -1
opcache.enable=1
opcache.enable_cli=1
opcache.memory_consumption=512
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.max_wasted_percentage=5
opcache.revalidate_freq=1
opcache.save_comments=1
apc.enable=1
apc.enabled_cli=1

/var/www/nextcloud/config/config.php

?php
$CONFIG = array (
‘instanceid’ => ‘“instanceid”’,
‘passwordsalt’ => ‘“passwordsalt”’,
‘secret’ => ‘“Geheimnis”’,
‘trusted_domains’ =>
array (
0 => ‘xxx.duckdns. org’,
1 => ‘“locale IP”’,
),
‘datadirectory’ => ‘/mnt/data/’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘25.0.3.2’,
‘overwrite.cli.url’ => ‘h ttps://xxx.duckdns.org’,
‘dbname’ => ‘dbname’,
‘dbhost’ => ‘localhost’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘mysql.utf8mb4’ => true,
‘dbuser’ => ‘“dbuser”’,
‘dbpassword’ => ‘“dbpassword”’,
‘installed’ => true,
‘mail_smtpmode’ => ‘smtp’,
‘mail_smtpsecure’ => ‘tls’,
‘mail_sendmailmode’ => ‘smtp’,
‘mail_from_address’ => ‘“example.mail .de”’,
‘mail_domain’ => ‘“Emailanbieter”’,
‘mail_smtpauthtype’ => ‘LOGIN’,
‘mail_smtphost’ => ‘smtp-mail.Anbieter .de’,
‘mail_smtpport’ => ‘xxx’,
‘mail_smtpauth’ => 1,
‘mail_smtpname’ => ‘“Mail@Anbieter .de”’,
‘mail_smtppassword’ => ‘“GutesPasswort”’,
‘default_phone_region’ => ‘DE’,
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘filelocking.enabled’ => ‘true’,
‘redis’ =>
array (
‘host’ => ‘/var/run/redis/redis.sock’,
‘port’ => 0,
‘timeout’ => 0.0,
),
‘default_language’ => ‘de’,
‘default_locale’ => ‘de_DE’,
‘remember_login_cookie_lifetime’ => 1296000,
‘session_lifetime’ => 3600,
‘session_keepalive’ => false,
‘auto_logout’ => true,
‘knowledgebaseenabled’ => true,
‘allow_user_to_change_display_name’ => true,
‘auth.bruteforce.protection.enabled’ => true,
‘twofactor_enforced’ => ‘true’,
‘twofactor_enforced_groups’ =>
array (
),
‘twofactor_enforced_excluded_groups’ =>
array (
),
‘maintenance’ => false,
‘overwriteprotocol’ => ‘https’,
);

/etc/apache2/sites-available/nextcloud.conf

<VirtualHost *:80>
ServerAdmin “E-Mail”
DocumentRoot /var/www/nextcloud/
ServerName xxx.duckdns .org

<Directory /var/www/nextcloud/>
Require all granted
AllowOverride All
Options FollowSymLinks MultiViews

Dav off

SetEnv HOME /var/www/nextcloud
SetEnv HTTP_HOME /var/www/vextcloud

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

RewriteEngine on
RewriteCond %{SERVER_NAME} =xxx.duckdns .org
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

/etc/apache2/sites-available/nextcloud-le-ssl.conf

(Eckige Klammerauf)IfModule mod_ssl.c
<VirtualHost *:443>
ServerAdmin “E-Mail”
DocumentRoot /var/www/nextcloud/
ServerName xxx.duckdns .org

    <IfModule mod_headers.c>
            Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains; str>
    </IfModule>

    <Directory /var/www/nextcloud/>
            Require all granted
            AllowOverride All
            Options FollowSymLinks MultiViews
            <IfModule mod_dav.c>
                    Dav off
            </IfModule>
    SetEnv HOME /var/www/nextcloud
    SetEnv HTTP_HOME /var/www/nextcloud
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

SSLCertificateFile /etc/letsencrypt/live/xxx.duckdns.org/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/xxx.duckdns.org/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
</VirtualHost (eckigeKlammerzu)
</IfModule (eckigeKlammerzu)

Wenn ich was wichtiges vergessen habe bitte sagen. ps. Wenn es Abfragen per Putty sind, bitte die entsprechenden Befehle verraten xD
Und vielen Dank schonmal vorab!! Ich stecke echt fest…

Grüße Patrick

Ich bekomm n Vogel, ES GEHT !!!
ich hatte in Verzeichnis "etc/apache2/sites-enabled/ die Datei 000-default.conf. deswegen hat es wohl nicht funktioniert…

Aber der Zugriff übers Internet ist trotzdem sterbenslangsam … vom Login bis zum Öffnen der Welcome to Nextcloud Hub.doc vergehen 5 minuten und dann bricht NextcloudOffice mitten im Laden ab…

hallo @Anit wilkommen im forum :handshake:

ich kenne die Tutorials von @Apfelcast und habe das Gefühl dass sie funktionieren… grundsätzlich ist es gut dass dein System jetzt “etwas” funktioniert. Ich bin nicht ganz sicher ob deine Aussage

so gemeint ist dass NC selbst oder ein Dokument im NC Office abbricht. Das sind technologisch 2 unterschiedliche Sachen… Ich würde empfehlen zuerst alle unnötigen Apps - vor Allem Nextcloud Office (richdocuments) zu deaktivieren… Dann kannst du NC Basis kennenlernen, ein Gefühl für die Geschwindigkeit und Möglichkeiten bekommen und dann im zweiten Schritt zusätzliche Funktionen aktivieren…

@Anit
Du könntest mal die Dev-Tools deines Browsers (Taste F12) und dort Netzwerkanalyse verwenden. Ruf dann mal sowohl aus dem internen Netz und aus dem Internet deine Nextcloud auf. Versuch mal die Unterschiede zu ermitteln und poste die Ergebnisse.

Hallo,

vielen Dank für eure Kommentare.
Deaktivieren etc. hat mich auf die Idee gebracht nochmal NC neu auf einem neuen Ubuntu aufzusetzen. Wieder das gleiche tut. Ich finde die Apfelcast Videos übrigens auch sehr toll.

jetzt funktioniert es von aussen (Handy LTE) sehr gut! das Intro Video läd in wenigen Sekunden und die Beispielfotos sind schön anzuschauen. Voll zufrieden.
Wenn ich mich jedoch im WLAN einlogge ist die Geschwindigkeit dahin ?!
Aus dem WLAN funktioniert es, wenn ich die IP anwähle, aber über DUCKDNS ist nicht dran zu denken…
wie kann das denn sein !?
ich vermute das Problem in den Apache Configdatein:

Nextcloud.conf:

<VirtualHost *:80>
ServerName xxx .duckdns.org
Redirect permanent / h ttps://xxx.duckdns.org
“Klammerauf”/VirtualHost>

<VirtualHost *:443>
ServerAdmin “MeineEmail”
DocumentRoot /var/www/nextcloud
ServerName xxx .duckdns.org

    <IfModule mod_headers.c>
            Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains; str>
            Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
            Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav
            Redirect 301 /.well-known/webfinger /nextcloud/index.php/.well-known/webfinger
            Redirect 301 /.well-known/nodeinfo /nextcloud/index.php/.well-known/nodeinfo
    </IfModule>

    <Directory /var/www/nextcloud/>
            Require all granted
            AllowOverride All
            Options FollowSymLinks MultiViews
            <IfModule mod_dav.c>
                    Dav off
            </IfModule>
            SetEnv HOME /var/www/nextcloud
            SetEnv HTTP_HOME /var/www/nextcloud
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    SSLCertificateFile /etc/letsencrypt/live/xxx.duckdns.org/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/xx.duckdns.org/privkey.pem
    Include /etc/letsencrypt/options-ssl-apache.conf

Mir zeigt es auch trotz der Einträge die Fehlermeldungen zu Cardav, caldav, webfinger und nodeinfo an ?"

000-default.conf

<VirtualHost *:80>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/html

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

vim: syntax=apache ts=4 sw=4 sts=4 sr noet

also hast du jetzt das Problem umgekehrt?

hier ist wichtig zu wissen ob es “langsam” oder “gar nicht” funktioniert - im ersten Fallkann es daran liegen dass der Zugriff von intern, über den Router ins Internet und dann wieder zurück kommt - so etwas ist häufig nicht effektiv… kann auch durch den üblicherweise geringen xDSL Upload limitiert sein, im 2. Fall gibt’s mehrere Möglichkeiten angefangen bei der “rebind protection” über DNS Probleme bis IPv6 Besonderheiten… schaue dir diesen und die verlinkten Threads an

Ja genau jetzt ist es umgekehrt :roll_eyes:
Es ist im wlan langsam.

Ich arbeite mal die Thread durch. Vielen Dank.

Ich habe dank wwe die Lösung gefunden.
Mein Pihole dient als DHCP Server. Hier habe ich unter Local DNS > DNS Records meine DynDNS und IP eingestellt und somit geht es!!

ich kann mich nun “extern” einloggen und trotzdem Lan-Geschwindigkeit genießen. Von aussen ist alles unverändert!

Volle Zufriedenheit !! :smiley:

Vielen lieben Dank!