Intern geht extern nicht

Hallo an alle

Ich gehe stark davon aus das dieses Thema hier schon zu oft behandelt wurde und dennoch muss ich hier nach langem googeln zu geben ich bin zu dumm dieses Problem zu lösen. Ich hab zwar in vielen Foren Lösungen gefunden die wohl geholfen haben aber wenn ich dies bei mir angewendet habe, hat das leider nicht geholfen, somit wende ich mich jetzt an euch.

Mein Server
I3 10300T CPU
128 GB DDR4 3200 MHz Arbeitsspeicher
Zwei mal 1 TB NVM SSD gespiegelt
Irgend eine Onboard Grafikkarte
Hauptbetriebssystem ist Proxmox
Hier laufen mehrere Wordpress Container, ein PiHole, Ldap-Server, DHCP Server, Nginx Reverse Proxy Manager, MurMur, Jitsi, Jellyfin und viele mehr

Für die Virtuelle Nextcloud Maschine hab ich extra 2 500 GB SSD SATA eingebaut und gespiegelt im ZFS System

ich hab Nextcloud installiert nach der dieser Anleitung

Ubuntu 22.04 Server

2 Kerne
2048 GB Arbeitsspeicher
480 GB Festplatte

nano /etc/ssh/sshd_config
PermitRootLogin yes
service ssh restart

apt-get update -y && apt-get upgrade -y && apt-get dist-upgrade -y && apt-get full-upgrade -y

Automatische Updates
apt-get install unattended-upgrades
dpkg-reconfigure -plow unattended-upgrades

Installing apache

apt install apache2 -y

Install PHP

apt install software-properties-common -y
add-apt-repository ppa:ondrej/php
apt update

Install PHP & Moduls

apt install php libapache2-mod-php php-zip php-dompdf php-xml php-mbstring php-gd php-curl php-imagick libmagickcore-6.q16-6-extra php-intl php-bcmath php-gmp php-cli php-json php-mysql php-zip php-gd php-mbstring php-curl php-xml php-pear unzip nano php-apcu redis-server ufw php-redis php-ldap -y

adjust PHP.ini file

nano /etc/php/8.2/apache2/php.ini
memory_limit = 1500M
upload_max_filesize = 20G
post_max_size = 20G
date.timezone = Europe/Berlin
output_buffering = Off

Install Databse Server

apt install mariadb-server -y

Maria DB Server Konfiguration

mysql_secure_installation

Enter current password for root (enter for none): ← leer lassen und Enter drücken
Switch to unix_socket authentication [Y/n] ← y eingeben
Change the root password? [Y/n] ← y eingeben
Passwort eingeben →
Remove anonymous users? [Y/n] ← y eingeben
Disallow root login remotely? [Y/n] ← y eingeben
Remove test database and access to it? [Y/n] ← y eingeben
Reload privilege tables now? [Y/n] ← y eingeben

open SQL dialoge

mysql

create database calles nextcloud

CREATE DATABASE nextcloud;

create database user with password

CREATE USER ‘nextclouduser’@‘localhost’ IDENTIFIED BY ‘password_here’;

#grant accesss to databse
GRANT ALL PRIVILEGES ON nextcloud.* TO ‘nextclouduser’@‘localhost’;

#save changes and exit
FLUSH PRIVILEGES;
EXIT;

Download lastest nextcloud version

cd /tmp && wget https://download.nextcloud.com/server/releases/latest.zip
unzip latest.zip
mv nextcloud /var/www/

#adjust conf
nano /etc/apache2/sites-available/000-default.conf
DocumentRoot /var/www/html
zu
DocumentRoot /var/www/nextcloud
ändern

Enable the NextCloud and Rewrite Module

a2enmod rewrite
a2enmod headers
a2enmod env
a2enmod dir
a2enmod mime

restart apache

systemctl restart apache2.service

prepare data folder

mkdir /home/data/
chown -R www-data:www-data /home/data/
chown -R www-data:www-data /var/www/nextcloud/
chmod -R 755 /var/www/nextcloud/

→ open server ip in browser

Administratorenkonto anlegen
Passwort eingeben

Datenverzeichnis
/home/data/

Datenbank-Benutzer nextclouduser
Datenbank-Passwort
Datenbank-Name nextcloud
Datenbank-Host localhost

nano /etc/ssh/sshd_config
PermitRootLogin no
service ssh restart

Dann hab ich im Nginx Proxy Manager einen Eintrag erstellt
Domain Names → Meinedomain.de

Scheme = http
Forward Hostname = die IP von Nextcloud
Forward Port = 80
SSL Certificate = Meinedomain.de
Force SSL = Ja
HTTP/2 Support = Ja

Dann bin ich in /var/www/nextcloud/config und hab nano config.php
und habe in array ergänzt

<?php
$CONFIG = array (
  'instanceid' => 'xxxx',
  'passwordsalt' => 'xxxx',
  'secret' => 'xxxx',
  'trusted_domains' =>
  array (
    0 => 'Meinedomain.de',
    1 => 'NextcloudIP',
  ),
  'datadirectory' => '/home/data/',
  'dbtype' => 'mysql',
  'version' => '27.0.2.1',
  'overwrite.cli.url' => 'https://Meinedomain.de',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextclouduser',
  'dbpassword' => 'password_here',
  'installed' => true,
);

Ich komme über die Interne IP Adresse auf die Nextcloud und das geht auch alles schnell, aber wenn ich dann über die externe Domain gehe dann lädt er ewig und dann kommt die Fehlermeldung “504 Gateway Time-out” “openresty”

Ich habe zwar in einem anderen Beitrag

zwar das mit dem PiHole gelesen aber das Eintragen von DNS Records hat nichts gebracht außer das die Fehlermeldung “Die Website ist nicht erreichbar” kommt

Ich hatte vorher die Nextcloud mit Univention Corporate Server installiert da hatte es einwandfrei funktioniert aber es hat halt viel Ressourcen gebraucht jetzt wollte ich es schlanker machen, dann hatte ich es mit den Linux Turnkeys von Proxmox gemacht, das funktioniert auch aber es waren immer alte Nextcloud Versionen die sich nicht updaten liesen, also habe ich es wie auch in dem anderen Forum, nach der Anleitung von Apfelcast gemacht, nur bei dem geht es und bei mir nicht

ich hoffe ihr könt mir helfen

wenn ihr noch was braucht an Informationen, dann schreibt es und ich poste es hier rein

vielen dank schon mal im voraus für die Hilfe

Timm