New Nextcloud Box Snap installation

Hi,

My Box installation failed (wouldnt reboot after power cut).

This happened a few months ago now, so I do not really want to keep the data on my Box’s hard disk.

When it happened I tried the how to restart instructions but they did not work, so I assumed it was a problem with the SD card.

So, now I have finally got round to getting a new SD card and want to start again

I would like to install the snap version (I made notes of all the little set-ups and tweaks I made before), but am not sure which of the following routes I should take:

  1. Download the original image the Pi 3 from our download server here and then let it update to current versions.
    I think that this way I would end up with the Ubuntu Snappy OS? (the Box page says, ‘microSD card with Snappy Ubuntu Core as OS, including Apache, MySQL and the latest Nextcloud 10 pre-installed and ready to go’)

  2. Install Raspberry Pi OS (Raspbian), enable snapd, then install Nextcloud, as per this guide

Or perhaps there is a better way that I have not found?

Thanks

Leigh

I suggest using the Nextcloud Appliance image.

@kyrofa
Thanks!
I tried the update from various original versions of the box software but only one worked (cant remember which one) and even then when I updated the OS and snap to latest versions I couldnt access via browser (I could by ssh)

I also tried NextcloudPi, but with no luck

Using the Nextcloud Appliance did work, after changing the physical Pi2 to a Pi3 in the Box.

Now trying to work out how to use the external disk, but will start new thread on that if I get stuck

Thanks again

Leigh

Yeah nothing is technically wrong with the old images, the issue you ran into is that they’re baked with a pretty old version of the snap. Nothing wrong with that in theory, the problem is that when you update, you’re updating from whatever’s baked to whatever is current, and Nextcloud doesn’t support skipping major versions. You could recover pretty easily from that by refreshing to versioned channels one at a time until you’re fully up-to-date (e.g. snap refresh nextcloud --channel=19), but you need to know about that. It’s simpler to just use a more up-to-date image in the first place.

Hi!
I’m having lots of problems with the forum on Firefox/Manjaro XFCE so I hope I dont double post!

I am now trying to set up my Nextcloud Appliance which is pretty much my data on the external disk of my RPi3 Nextcloud Box.

So, I have set up the Folder Sync connection and all seems to be running well, as before

One problem is that I have 800GB of data so it predicts between days and months depending on how it is going - is there any safe way to copy the data over via a direct cable link of the external Box disk and my laptop and then to ‘register’ the data in my Nextcloud?

But the main problem is that the RPi3 keeps crashing after a few GB of data transfer / hour or so.

How do I keep the logs from just before the RPi crashes / access with logs generally? (I cant find the logs settings)

Thanks

Yeah, get the data on there via rsync or just using the external disk in the other machine, get it into the right place and make sure it’s owned by root. Once you’re done you can tell Nextcloud to do a scan with:

$ sudo nextcloud.occ files:scan

All the logs are in /var/snap/nextcloud/current/logs, does that help? Feel free to log an issue, we can help you dig into it.

Thanks!

I will now get onto transferring all my data from the laptop
Where will
sudo nextcloud.occ files:scan
scan?
Do I have to direct it to the external disk?

EDIT: Answer found here

sudo nextcloud.occ files:scan --path="<user_id>/files/<name given to disk in Nextcloud>/<Directory of interest on external disk>"

the word files has to be there

Re logs:
I tried to cd to /var/snap/nextcloud/current/logs but was denied permission
I tried sudo cd but cd didnt work with sudo
I tried su but I couldnt suss out the password (mine didnt work)
I tried sudo adduser <user> sudo but got
gpasswd: cannot lock /etc/group; try again later.
adduser: /usr/bin/gpasswd -a b-leigh sudo’ returned error code 1. Exiting.`

This is all certainly because I havent quite grasped sudoers/root etc :slight_smile:
And I think core handles this in a different way with keys?

Edit: Aha! sudo -i or sudo su

I managed to see the following list of log files via sudo ls /var/snap/nextcloud/current/logs:

apache_access.log
apache_errors.log.1
mysql_errors.log.1
php-fpm_errors.log.1
redis.log.1
apache_errors.log
mysql_errors.log
php-fpm_errors.log
redis.log

Which log file am I interested in?

Thanks again

Leigh

All working perfectly now!

Thanks for all help

In case anyone has the same problem in the future and finds this thread, in order to get it all working I had to sort out a few small hiccups, as detailed in the posts below: