Nextcloud Ubuntu Appliance change SSH password?

How do I change my Nextcloud Ubuntu Appliance SSH password, please?
Not the keys, just the password I have to type to access via SSH
I have already changed my admin password via the Web Interface

I’d try NextCloud Box reset admin password

i.e. you want to be able to SSH in with a password instead of a key? I’m not sure I’d recommend that, the key is generally more secure.

No, I just want to change the password that I access the RPi with core and Nextcloud snap on it via SSH
Ah! now I get it (I think) due to the keys I dont really need the password?

from here
During setup, console-conf will download the SSH key registered with your Store account and configure it so you can log into the device via ssh <Ubuntu SSO account name>@<device IP address> without a password.

Got it, from here

There is no default ubuntu user on these images, but you can run sudo passwd <account name> to set a password if you need a local console login.

I was not including my account name since I dont usually have to.

Right, you SSH in using the keys, you don’t need a password at all. As long as you keep the private key safe, this is far more secure than using passwords.

I have similar problems ssh-in to my ubuntu nextcloud appliance as my password is not accepted and I don’t know what to enter when asked for the password.
I have set up the ubuntu image on a raspberry pi, not yet logged into nextcloud and am trying to remotely ssh in with @ , however it won’t accept the password that is requested.
I set up an ssh account as described in:

And I saved the rsa key in my SSO account.
At the beggining I thought that it might be the cert passphrase needed - this didn’t work.
Then i tried without a password, with ubuntu, with admin, with raspberry etc …
I erased and set up the appliance again and again, set up new keys - same result.
I tried ssh-copy-id @, also rejected.
I deleted known-hosts, it did not work.

Then I thought that I needed a root pwd or a user set up on the appliance but as I can see from above this is not essential as the public key does the login authorization.

From here on I don’t know how to ssh in because of the password requested … - could anyone pls help ?

Terminal output:
user@mypci:~$ ssh SSOuser@
The authenticity of host ‘ (’ can’t be established.
ECDSA key fingerprint is SHA256:xxx.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ‘’ (ECDSA) to the list of known hosts.
SSOuser@’s password:
Permission denied, please try again.

I have the same problem. Do you solved it? How can I login via ssh?