Never set passphrase


I’ve used Nextcloud for a while and recently tried enabling E2E. At no point did it ask me to create a passphrase, but it now asks me to enter a passphrase every time the desktop client starts. The “Display mnemonic” box is empty. The only thing I can think of is that I tried playing with E2E years ago and have just been slowly upgrading the server over the years. Maybe some deprecated pieces of info in the database somewhere?

I have complete backups of the data and it all still seems to be working fine other than the desktop client popup. I can access my files on the iOS client, on my macOS machines and on the web without any issue.

What is my best path forward? Create a new user and move everything over there?

I’m using server 24.0.5 and 3.6.0 client versions.

Thanks for your help.

E2E seems to be incomplete so far… Lot of people try to use it but stop using it as it lacks functionality, usability and administrative support - e.g. reset/reinit mnemonic…

your issue exists for ages:

there is a discussion on GT which might show shortcomings and directions of this app

and the other one here

at the moment I don’t see huge advantage of this app over external solutions like Cryptomator (even recommended by NC team in the past)…

Thanks so much for the info. Glad it’s not just me.

I guess as long as the connection is encrypted and my hard drive is encrypted it should be fine. The server-side encryption should take care of the rest.

Makes sense. You can also restrict access to the e2e app by group under admin settings, which should stop it from nagging you about setting up the app in the desktop client.

1 Like

I think there is a bug in the desktop app that leads to this. Gets hopefully resolved at some point with ensure we do not generate E2EE keys without user intent by mgallien · Pull Request #4865 · nextcloud/desktop · GitHub