Missing folders, can see locally but not via web interface

I’m currently running Nextcloud 16.01 on Ubuntu 16.0.4. I have several cifs drives mapped to several local directories on my Nextcloud server. One in particular is my photos directory which has photos organized by year. However, for some reason the 2019 year folder doesn’t show up via the web interface or the phone app. If I browse to that directory locally at \files\photos I can clearly see the 2019 folder and the contents. But the \files\photos\2019 folder will not show up in the web/phone interface. I’m hoping someone can tell me what I need to do to correct this issue. It’s randomly been popping up for awhile, I had hoped upgrading to 16.01 from 15.x would have solved it but it didn’t.

I removed the directory from my external storage settings and re-added it. This appears to have corrected the issue. However I am still not sure why the issue occurred in the first place. I didn’t see anything in my nextcloud.log to indicate any kind of issue with this directory.

Hi. I’m sorry to say that if you’re using external storage app, it’s probably going to disappear again - it’s a known issue. Re-adding fixes it only temporary, same with re-scanning, and there’s an issue with scan -all command that it rewrites the folder change date displayed in the cloud interface (fixable by editing the database). (also related owncloud issue)

I found this project for scanning based on filesystem update events (makes more sense than scan on cron schedule) and it says that it’s external storage-compatible too, but didn’t have the time to test it yet since I’m running it all under docker compose and use local storage from host as the external one.

Currently I have a script set up that scans the files and rewrites the folder dates back (modified that bit in the script myself), and I run it manually every time a friend doesn’t see something in the cloud (happens more often when there’s a lot of new subfolders added).

Also I heard that creating a file/folder on the same level as disappeared one can trigger an update. I didn’t test it yes but it can be helpful for users without the admin access, if you don’t want to set up auto-scans.

I don’t quite understand why this crucial bug still exists, maybe not that much people are using external storage, and not with that many subdirectory levels.

Also, I noticed that external storage is much slower when mounted as a webdav network drive, and it always shows errors upon deleting or moving files (then refresh shows actions were successful), and once in a while it decides to un-share one of my external storage entries (as if it was re-added, maybe connected to disapppearing), and I’m unable to upload big files via web there for some reason (was using local nextcloud data folder with cron script to update permissions on external changes before, it was much faster and without issues, but it wasn’t supposed to be used this way, so I moved to external storage app).

Somewhat relevant topics:









1 Like