[iOS] Nextcloud Talk - No server found

Hi community,

I have a problem with the iOS version of Nextcloud Talk. The application does not find my server (Nextcloud 14.0.6). The Android app has no problems with that. There I can log in and make video calls.

I’ve already studied a few posts on this topic, including these two:


But I don’t think it’s a missing STUN/TURN server. And my server also uses an HTTPS connection via Let´s Encrypt.

My Android and iOS devices are inside the same network, the Nextcloud server is hosted by my external webspace provider. If STUN/TURN was the problem, then the Android app wouldn’t find my Nextcloud server either. Am I right here?

Apart from that, I don’t even want to set up a P2P phone call, I just want to enter the URL of my server. But I can’t get over this step. I already tried all possible spellings for the URL, even a direct entry of the IP address didn’t change anything.

All apps are up to date. The same applies to iOS, Android, Nextcloud 14 and the Talk app there.

It’s strange that the “Server not found” message appears almost instantaneously, as if there was no check at all whether a Nextcloud installation is available under the URL.

I would be grateful for hints and advice!

Thanks a lot!

Same here. Browser and Android App works as expected. But cannot log in with iOS app.
All actual versions.
Did you manage to make it work?

I join the problem. The latest version of Nextcloud Talk, configured TURN and STUN. The same error appears. What to do to fix it?

I found a solution. Apple doesn’t like self-signed certificates. Sign the certificate in let’s encrypt and iOS miraculously begins to see the nextcloud server…

Hi,

Apple and self-signed certificates are indeed a tiresome subject. But I have always used a Let’s Encrypt certificate for my Nextcloud installation on my web space. HTTPS and an officially signed certificate are thus available.

However, the Talk app does not work on iOS; the connection doesn’t work. Only on Android it works well.

Regards

For myself I use a subdomain, like https://sub.my.domain

And for the first time after replacing the certificate with a signed let’s encrypt, my iPhone also did not see the server. Only after I entered https://sub.my.domain/nextcloud/ , Nextcloud Talk app opened authorization page in my cloud.

After that I restarted the application and entered https://sub.my.domain/ and Nextcloud Talk app opened the device adding page for me.

P.S. the Certificate from Let’s encrypt I sign on a subdomain too (https://sub.my.domain). Certificate from domain (https://my.domain) is also not suitable here. Maybe this will help you.

Mr. Fermer seems right. It worked for the first time if you do it without a subdomain (but I had to reinstall the app before). After it worked for the first time, it also worked with the subdomain afterwards.

All in all, it seems more like a bug to me.

But it worked, so thank you very much for the help! :slight_smile: