Internet connection not recognized

nc9

#21

I’ve got the same error since this morning.

NC 10.0.1, Ubuntu LTS 16.04, PHP 7.0.8

Any solutions??


#22

Same here, debian 8, php5.6, mariadb

Haven’t changed somethin in the way how NC check for internet connection, like IP or test domain not accessible?


#23

Same here. Also no changes, just appeared today.
NC 10.0.1 on Ubuntu Server 16.04 PHP 7.0.8


#24

The error has now disappeared on its own.


#25

and though the broken certificate

on https://owncloud.org

…seems belonging together …?!


#26

Same here. It’s working again
I think it was the broken / expired https://owncloud.org certificate


#27

Thanks,
just works fine:)
No warning anymore :slight_smile:


#28

Issue fixed here also. It seems that NC is still relying on OC web servers for verifying an active internet connection. Why do they not change it to ping their own website?


#29

Can you tell me, how take this ?


#30

A better handling will be implemented in NC 11 (https://github.com/nextcloud/server/issues/1118#issuecomment-243085757) which is currently available as beta version to test:
Two reasons why you should test Nextcloud 11 Beta this weekend!

Can someone test and report if there is still an issue with that. If yes, please open a bug report on github.com/nextcloud/server/issues


#31

I have this problem with nc 11. Upgraded from 9 to 10 to 11. Using php 7.0.14 as FPM module on ubuntu 14.


#32

Not sure about that, FPM configuration on apache is known to be a bit tricky. I haven’t done that so far, often it comes with some managing software and special setups that might cause problems.

To investigate further, it’s probably better to open a new issue on the bugtracker on provide all information about your setup.


#33

I having the same issue on NC11 with Nginx.


#34

We solved the problem because curl_exec was disabled via php.ini …
So no curl, no internet


#35

I just experienced this when Nextcloud 12 came out. I had to append my server’s letsencrypt certificate /etc/letsencrypt/live/cloud.[domain].com/fullchain.pem onto [nextcloud dir]/resources/config/ca-bundle.crt. Then the error message went away and I could see upgrades, etc.

I’m using the official Nextcloud Docker image, if that matters.

Hopefully this helps somebody out there…


#36

hi koehn, what do you mean by “append” the letsencrypt certificate? i am experiencing the same issue.
would be thankful for your help!


#37

I haven’t needed this hack for a while, but I just had to cat /etc/letsencrypt/live/[domain]/fullchain.pem >> [nextcloud dir]/resources/config/ca-bundle.crt . I don’t have it in there anymore, but it did fix the problem at the time. I’m sure it was just an old ca-bundle.crt file that was the root cause. The one in my current install is 261889 bytes long; yours should be at least as big; copy the one from the current install if you need to.


#38

mine ca-bundle.crt file is exactly the same size at [nextcloud dir]/resources/config/ca-bundle.crt.
But I do not have this directory: /etc/letsencrypt/live/[domain]/fullchain.pem. I only got /etc/fonts oder /ectc/pki and somer other files like: resolve.conf, group,localtime etc.


#39

Exactly what was needed here as well. Now I wonder if I’ll have to update that every time the local certificate is updated?


#40

Normally, the intermediate certificates shouldn’t change that often, so you don’t have to do it every time (if you analyze your ssl settings on ssllabs.com, you can also see the whole certificate chain and when they expire, or use your browser).