Internet connection not recognized

nc9

#1

On the Admin page, I get this notice under the heading “Security and setup warnings”,

This server has no working Internet connection. This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work. Accessing files remotely and sending of notification emails might not work, either. We suggest to enable Internet connection for this server if you want to have all features.

The internet connection is working fine and I can not install the Contacts and Bookmarks apps. What am I missing here to get NC to recognize the internet connection? This is an OC install updated to NC.

Thanks for any help.


#2

Hi nixer, did you managed to fix this problem?
Regards.


#3

Check the config.php
Its a true/galse setting


#4

Hi z000ao8q,

I already tried setting ‘has_internet_connection’ => true, but I still have the warning:

“This server has no working Internet connection. This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work. Accessing files remotely and sending of notification emails might not work, either. We suggest to enable Internet connection for this server if you want to have all features.”

Any other suggestion?

Regards.


#5

Do you have any firewalls? I’d so, have you checked whether they’re blocking anything?


#6

No. I’m running nextcloud in a AWS instance and the outbound firewall rule is to allow all traffic to the internet.

Before the last update to 9.0.52, my nextcloud instance was working fine. Now I see the “no working internet connection” warning and I can’t see the available apps in app store.

Everything else seems to be working OK.

Regards.


#7

Sorry for not responding, but I have been on a vacation overseas and I was unable to visit this forum thread.

I gave up on trying to fix this problem, so I did a new install of nextcloud. Now I see that I need to update.


Mistake of updating Bookmarks
#8

If you are running a version of RHEL (like Centos or Fedora) there is a know bug with the SSL library used in cURL.

This is discussed here at the redhat bug tracker: https://bugzilla.redhat.com/show_bug.cgi?id=1241172 . Note the last post, it should be fixed in RHEL 7.3, IIRC this would then be pushed downstream to Centos 7.3.

Also have a look at this issue: https://github.com/owncloud/core/issues/16255


Could not get applications cURL error 28
#9

thank you! Actually I’m running CentOS 7.2. I’ll wait for the update, hopefully will be ready soon.
Regards!


#10

Hi guys,

I’m running on Debian Wheezy, and I having this error today on NC10.
What’s the solution?


#11

Same here, Ubuntu 16.04 LXC container.

The error suddenly appeared… Wasn’t there before.


#12

So I’m not crazy. Used nextcloud9 before, no error, upgraded to 10 4 days ago, no error. Today that error appeared. I tried to copy the certificate, as suggested in https://github.com/owncloud/core/issues/16255 but that did nothing.


#13

#14

When I had the data directory in /var/www/nextcloud/data it complained about the .htaccess error.

It was a new install, so I created a directory in /srv/nextcloud-data and chown -R www-data:www-data /srv/nextcloud-data … removed the working directory, unzipped again, reinstalled and now am experiencing the Internet connection not recognized error. The .htaccess error went away anyway.


#15

Hey,
i have same error:

This server has no working Internet connection. This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work. Accessing files remotely and sending of notification emails might not work, either. We suggest to enable Internet connection for this server if you want to have all features."

i use NextCloud 10.01, PHP 7.0.13, ubuntu server 16.04.1

Any solution for this error?


#16

Same here.

No changes have been made since last login to my cloud.

But today -> Adminitration Settings -> same error.

Remarked that the URL https://owncloud.org is “broken” too (has in different browsers (Chromium, Firefox, IE) an invalid https certificate … hint on HSTS

Certificate Error
There are issues with the site’s certificate chain (net::ERR_CERT_DATE_INVALID).

Any solution (putting e.g. a ca-certificate.cert into the owncloud/config directory) doesn’t work!


#17

No solution, but the same error:

NC 10.0.1, Ubuntu LTS 16.04, PHP 7.0.8

For search able in German:

Dieser Server hat keine funktionierende Internetverbindung. Dies bedeutet, dass einige Funktionen wie das Einhängen externen Speicherplatzes, Update-Benachrichtigungen oder die Installation von Drittanbieter-Apps nicht funktionieren werden. Der Fernzugriff auf Dateien und der Versand von E-Mail-Benachrichtigungen kann ebenfalls nicht funktionieren. Es wird empfohlen, die Internetverbindung dieses Servers zu aktivieren, wenn du/Sie alle Funktionen nutzen möchtest/-en.


#18

Same error here, running on an Arch Linux server. Worked yesterday and appeared this morning. I can connect via browser but sync clients don’t work.


#19

I have the same error. Nextcloud 10.0.1, php 7.0.13 also on Arch Linux. It just appeared this morning with no changes to the server.

What’s most odd is that the server very obviously does have access to the internet, as I can download files to the Android app.


#20

Do have the same error… I also get an error, connecting to https://www.owncloud.org via browser.

error code: SEC_ERROR_EXPIRED_CERTIFICATE