How to install Collabora Online

Hello all!
I’m one step before become a newbie in Collabora.

I just tried to install/activate both apps,

  • Collabora Online - Built-in CODE Server - 6.4.13
  • Collabora Online - 3.7.5
    on my Nextcloud 19.0.3 I have installed on the space of my Web-Hoster.

Message from Collabora Online - Built-in CODE Server is

You have the Collabora Online app enabled. For further information and configuration, please check: Settings > Administration > Collabora Online

but I get the failure message from Collabora Online

Collabora Online is a powerful LibreOffice-based online office suite with collaborative editing, which supports all major documents, spreadsheet and presentation file formats and works together with all modern browsers.

Could not establish connection to the Collabora Online server.

I have selected:

Easy to install, for home use or small groups. A bit slower than a standalone server and without the advanced scalability features.

Is there any I have to do or install additional to these both apps I oversee?

I read many threads around problems with Collabora Online directing to Docker. I was intended to use Collabora Online without any Docker installation.
As I understood the both apps should be enough to install using Collabora Online.

Any help is very welcome!

cheers, bdream

@Collabora

Exactly that was the reason I focused to get collabora up to run

And this is my question, how I get this Easy to install Application up to run in my Nextcloud installation as I get the error

as I mentioned already.

Hi @bdream,
did you manage to connect to collabora build in server? I face the same issue. I can access https://mynextcloud/custom_apps/richdocumentscode/proxy.php?req= but “Collabora Online” App wont recognize it.
Nextcloud 19.0.4
Code Server 6.4.14
Collabora Online 3.7.6

So i went ahead and tried the “easy” docker solution, installing nextcloud latest and collabora docker latest from https://www.collaboraoffice.com/code/quick-tryout-nextcloud-docker/
But it didn’t work eater. Collabora Online wasn’t able to connect.
So i installed the Build-In Code Server on the NC20, selected use your own server and it worked!?

Did you install on system or on docker? Access over https? Nginx Server? For the nginx server i found this https://www.collaboraoffice.com/online/connecting-collabora-online-built-in-code-server-with-nginx/

Didnt help for me but mabee for you.

Benjamin

Hi @marsoner,
no I didn’t.

I thought the idea behind the Build-In Code Server is not to install additional Docker or what ever stuff.
Only install and activate both Apps in NC and it run.

My NC installation is on Webhoster via Web Installer. Nothing else.

Further witing for help…

Cheers, bdream

Hi @bdream,

yes, i tought the same about not having to install further server, subdomains,…

So if you get further help please let mi know. I actually run my NC without the feature.

Cheers, marsoner

Hi @marsoner,
it’s so sad, isn’t it?
I thought also to get information how and what to do here but nothing.

So I would also run my nc without this feature. But actual I have another issue and ma nc is not more running.
Wil wor on this and maybe open another thread if I dont find a solution for it.

cheers, bdream

Need more information since you didn’t use the issue template. What are your server specs?

$ uname -r
What distribution are you running?
Is your distribution 32-bit or 64-bit? Requires 64-bit
How much ram do you have? Requires at least 4gb for the appliance to function. 2gb and it won’t work.

Hi @just,

i am on a opensuse 15.2 host running docker containers. Nextcloud:stable behind a nginx-proxy and companion solution.
64-bit and 6GBRam

I think my problem is more related to to the docker configuration.

Hi @just , where to find the issue template please?

From my Webhoster:
Operating System: Linux 3.10.0-1127.19.1.el7.x86_64 x86_64
CPU: Intel® Xeon® CPU E5-2630 v4 @ 2.20GHz (20 cores)
Memory: 25.35 GB

Adding: CentOS Linux release 7.8.2003 (Core)

PHP:
Version: 7.4.12
Memory Limit: 512 MB
Max Execution Time: 3600
Upload max size: 2 GB

MariaDB:
Type: mysql
Version: 10.3.25

Just installed nc stable version 19.0.4 and also 20.0.1 in another instance new and where not able getting the collaborate running.
Each time the same issue Could not establish connection to the Collabora Online server.

cherrs, bdream

I would check the collabora repo for related issues and documentation.

https://github.com/nextcloud/richdocuments

Hi @just ,
ok will do and hope to understand.

One question as base is if the assumption is correct to nee only the both Apps in NC

Or is there a need I oversee to install additional stuff?

Many thanks, bdream

My understanding is you install:

  1. Collabora CODE server. Since you have a decent server, install the independent Docker build as opposed to the pre-bundled Nextcloud app.
  2. Collabora Office Connector - this is the app, which adds the specific functionality to open all document types within Nextcloud and points to (1.)

Hi @just,

as i understood from the documentation, if i install a collabora docker i need a own subdomain to access it!? Thats not possible for me to create.

So i went for the integrated Collabora Build-In, its slower but i don’t care. My “customer” have to wait :slight_smile:

I can access the collabora link and now i found the problem. Error message in the nextcloud log says:
Error: count(): Parameter must be an array or an object that implements Countable at /var/www/html/custom_apps/richdocuments/lib/Service/CapabilitiesService.php#63

Maybe someone knows how to come over this? I try to google the error.

@bdream are you getting the same error in the log? Your installation is different so maybe you get a other message?!

cheers

Check this error again the project GitHub repository, which is linked to their appstore listing. File an issue if one is not already there.

1 Like

Hi @marsoner,
I have no similar error.

What I have here in ERROR is
Error no app in context Error: Call to undefined method OCA\Richdocuments\WOPI\DiscoveryManager::refretch()

/var/www/virtual/NC/html/nextcloud/apps/richdocuments/appinfo/app.php - line 65:

OCA\Richdocuments\AppInfo\Application->checkAndEnableCODEServer()

/var/www/virtual/NC/html/nextcloud/lib/private/legacy/OC_App.php - line 266:

require_once("/var/www/vi ... p")

/var/www/virtual/NC/html/nextcloud/lib/private/legacy/OC_App.php - line 155:

OC_App::requireAppFile(OCA\Richdocu ... {})

/var/www/virtual/NC/html/nextcloud/lib/private/legacy/OC_App.php - line 128:

OC_App::loadApp("richdocuments")

/var/www/virtual/NC/html/nextcloud/apps/dav/appinfo/app.php - line 36:

OC_App::loadApps([ "dav"])

/var/www/virtual/NC/html/nextcloud/lib/private/legacy/OC_App.php - line 266:

require_once("/var/www/vi ... p")

/var/www/virtual/NC/html/nextcloud/lib/private/legacy/OC_App.php - line 155:

OC_App::requireAppFile("dav")

/var/www/virtual/NC/html/nextcloud/lib/private/legacy/OC_App.php - line 128:

OC_App::loadApp("dav")

/var/www/virtual/NC/html/nextcloud/lib/base.php - line 996:

OC_App::loadApps()

/var/www/virtual/NC/html/nextcloud/index.php - line 37:

OC::handleRequest()

Just see in another instance I installed NC again
Error: count(): Parameter must be an array or an object that implements Countable at /var/www/virtual/NC/html/nextcloud/apps/richdocuments/lib/Service/CapabilitiesService.php#63

Line #63

		$shouldRecheckCODECapabilities = $isCODEInstalled && $isCODEEnabled && ($this->capabilities === null || count($this->capabilities) === 0);

cheers, bdream

@bdream @marsoner

just tested my playbook on a debian 10 (aws ec2) server.

if you just changed the following variables in the inventory:

nextcloud_fqdn = what.ever.you.like
nextcloud_certificate_type = ‘acme.sh’
install_collabora = true

you should get a working setup.

not sure if apache as web server is working. i just tested it with nginx.
and centos is work in progess. debain and ubuntu should do.

Hi @Reiner_Nippes,

i have seen your playbook. It looks like a really clean configuration (not like mines :)) So i tried to use at least the parts of your compose that i wont to get rid of on my configuration. Or better i tried to switch from my nextcloud:stable i use to your nextcloud:fpm-alpine and web configuration.

After a permission message (caused by switching to new container) on volumes i resolved that and got on the app container, when accessing the nextcloud, the ‘error’ internal server error and in the log “Get index.php 302” and “Get index.php 500” message nothing else.

Unable to solve the issue i went back to my docker-compose and enabled nc without collabora for the moment.

Do you know if it’s possible to switch my running nc:stable to a nc:fpm docker configuration without a new install and a restore?

I leave the question on this because after a simplification on docker system i think i’m able to solve the issue with collabora.

thanks a lot

first: you should alway have a backup.

i think if you use the same volumes it should be possible.

:smiley: yes im on a test system with backup for that too!

nope it’s not possible! there is something in the db that want let me do the switch. I tried to use a new volume, so i started the config screen setting up the nc. Everything ok but getting the 302 - 500 response on connecting after.

So I’m not really getting to a point. At least it was a nice exercise :nerd_face:

Hi @Reiner_Nippes,
yes its possible! Managed to switch to the fpm docker image. But didn’t solve the issue with collabora