First beta of Nextcloud 29

I have an NGINX setup using the config template that was current for NC28. I see this and similar warnings in /settings/admin/overview:

Could not check that the data directory is protected. Please check manually that your server does not allow access to the data directory. To allow this check to run you have to make sure that your webserver can connect to itself. Therefor it must be able to resolve and connect to at least one its trusted_domains or the overwrite.cli.url.

However, the settings are correct in config/config.php:

  'datadirectory' => '/path/not/within/document_root',
  'trusted_domains' =>
  array (
    0 => 'cloud.myserver.de',
  ),
  'overwrite.cli.url' => 'https://cloud.myserver.de',

EDIT/Solution: Parameter order was wrong, fixed on master, see commit (as pointed to in another thread).

1 Like