File is locked error message

In case I have upload many files via webdav I have many times the issue the one file is locked and I am not able to upload the other files because the sync stopped after the error message.

My current workaround is to clear the whole lock table in the database.

It would be great if the user/administrator is able to unlock a single file.
In general it would be the best to avoid these file locking issue.

Best regards
NC2016

Do you use redis as file-locking-cache?

I don’t know :frowning: Where/How can I check it?

Normally you have to install it manually. And if you can’t remember, your config.php should answer the question (option memcache.locking must be set):
https://docs.nextcloud.org/server/9/admin_manual/configuration_files/files_locking_transactional.html

1 Like

Than I think the answer is no because

  • “memcache.locking” is not added to config.php
  • the admin setting shows that no Memory Cache is configured

Please let me know if you need some more information

Best regards and thank you for your help
NC2016

Hi tflidd,

I have checked my hosting contract and there is no option for redis.
Because of your post I know the cause now.

Thank you for your support and best regards
NC2016

Because of the count of users I think that file locking is not really needed and so I have added

‘filelocking.enabled’ => false,

to my config.php for testing now

In case I’ll have trouble I’ll active file locking again.

Best regards
NC2016

1 Like

I had the same problem and turning off in the file locking in the config worked for me. Thanks!

Have any of you experienced any problems so far as a result of disabling file lock? Thanks!

You may be interested in contributing to an update on this topic: