File is locked - how to unlock

Thanks. This was helpful.

I was wondering why so many people have this issue. it seems the only time I need to perform this is when I’m doing a files:scan and the terminal session gets dumped for some reason. out side of that I’ve never had a locked file.

It’s too difficult for me to do it by terminal.
Could someone tell me what I have to delete by phpMyAdmin

Delete everithing?

On the overview of the tables, you normally have a button to empty (‘vider’) a table. You need to keep the table and its structure as it is.

1 Like

@tflidd Thanks !
I put the image for the next neebee (as me)

Would like to know the risks of disabling the file lock?

One of the contributors to this topic, @mwallace, mentioned that he “turned off file locking on [his installation hosted on] a shared server.” To help those who have considered or have tried on this option, how should someone in similar circumstances monitor the installation for unintended effects?

Hi all! I still experience the same issue. Tried to use solution proposed above with keys deleting in redis, however did not work. Problem occured, when I changed one of scss files to add an extra icon.
My version now is 18.0.9
I tried with enabled and sisabled file.locking in config file.
It seem to be no files within files_locks table where value of ‘lock’ was different than 0. WHen table empty also did not work. Still was given a log message that file is locked for SCSS cacher.
Restarting redis and apache was useless as well.

Why do you suggest to update the cache with occ files:scan --all and then clean the cache immediately with occ files:cleanup? I do not understand your logic.

Maybe we need to clean the cache at first and to fill it after?

Since it has been up to 39 months since the quoted users have submitted a post on this topic, I believe that it is necessary to ask for an update: has anyone experienced any problems as a result of disabling file lock? The admin is making a cautious decision regarding the file lock configuration on an installation with one user on Notes, Calendar, and Deck at a time. Please provide the version numbers in your reply to provide readers a more informed decision.

Is it written like this? ?
‘Filelocking.enabled’ => false
After I add it, my php can’t be used directly

Hello all! I have a question.

The usual solution given to wipe stale locks is the following:

  1. DELETE all the rows from oc_file_locks
  2. Run occ files:scan --all

I am thus wondering why it would not be reasonable to set lock to 0 on all non-zero rows, like this :

UPDATE `oc_file_locks` 
SET `oc_file_locks`.`lock` = 0
WHERE `oc_file_locks`.`lock` != 0;

Would that be asking for trouble? (given maintenance mode is enabled, of course)


DELETE FROM oc_file_locks WHERE 1

results in:

ERROR: argument of WHERE must be type boolean, not type integer LINE 1: DELETE FROM oc_file_locks WHERE 1

modify the command:

DELETE FROM oc_file_locks WHERE true

My site is hosted on Cloudways. This automatically installs the Varnish Cache which turns out not to work with nextcloud. Turning off Varnish in the Cloudways settings resolved this for me.

I am experiencing issues with locked files that I cannot delete or move, but I have a subscription with a provider and thus have no admin access. Is there really no end-user-accessible way to escape from this situation? If so, any chance at getting one added?

I’m having similar problems. First of all, I have to say my head is spinning a bit from looking at these help pages because I am a total novice when it comes to coding and stuff like that. I didn’t think I’d have to know such things when I left Google Drive for NextCloud.

I’m having problems moving folders. I keep getting messages that say “could not move” and sometimes “target exists.”

Can someone help me figure this out in simple English?

Thank you so much!

I have exactly the same problem.
Moreover, when synchronizing a large file, somewhere around 180GB through the Nextcloud client. Error message 423 Locked appears, and after a while everything starts to synchronize all over again. In the log I see the following error "Error PHP Error: fopen (/ var / nextcloud / uploads / 1939388670/00000839): failed to open stream: No such file or directory at / var / www / nextcloud / lib / private / Files / Storage / Local.php # 354 "
What to do with it? in php.ini the maximum time is 10400.

1 Like

Make sense…

" Empty table oc_file_locks"
Oh ok. It’s nice if you wrote how to do it, because it’s not written anywhere …
One problem generates another. Opensource world.

Please be respectful. The description of how to perform exactly this action is described in detail by @tflidd in the post you are quoting from.

Do you think if that was a solution, I would still be writing here?